在线检测未来函数

同花顺变味的MACD指标公式

来源:Internet,编辑:股旁网,2017-05-09

{"bias线平均";}
VAR3:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR5:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;
VAR6:=(VAR3+VAR4+VAR5)/3; VAR7:=EMA(VAR6,5);
指标: EMA(EMA(VAR3,5),5)*3, COLORSTICK;{"单独的红绿柱指标";}
{"近底用VAR8,底用VARA,橙色柱";}
VAR8:=IF(VAR6<=-20,10,0);{"橙色柱使用条件";}
VAR9:=HHV(VAR8,10);{"橙色柱使用条件";}
STICKLINE(VAR8=10,20,10,5,0),COLOR6666FF;{"橙色柱";}
{"底的条件用到了VARA";}
VARA:=IF(VAR9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);
{"由BIAS决定的KDJ";}
K:EMA(VAR7,5)*2,coloryellow;
D:EMA(K,5),colorliblue;
J:K*3-D*2,COLORFF00FF;
{"未用的数据";}
VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J>10;
换手:=VOL/CAPITAL*100;{"单独的指标,未使用的数据";}
成交〖万手〗:=VOL/10000;{"未使用的数据";}
{"近底的条件";}
DRAWTEXT(VAR8=10 AND FILTER(VAR8=10,5),-10,'近底'),LINETHICK1,coloryellow;
STICKLINE(VAR8=10 AND FILTER(VAR8=10,8),-1.6,-10,8,0),coloryellow;{"-1.6--10之间画黄柱";}
{"底的条件";}
DRAWTEXT(VARA=20,15,'底'),LINETHICK1,colorwhite;
STICKLINE((VARA=20),0,10,8,0),colorwhite;{"0-10之间画白柱";}
{"ZIG买卖点";}
VARC:=(ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND
(REF(ZIG (3,5),2)<=REF(ZIG(3,5),3));
VARD:=(ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND
(REF(ZIG (3,5),2)>=REF(ZIG(3,5),3));
STICKLINE((VARC=1),-14,0,8,0),COLOR0000FF;
DRAWTEXT((VARC=1),-14,'买'),COLOR0000FF;
STICKLINE((VARD=1),14,0,8,0),COLOR00FF00;
DRAWTEXT((VARD=1),18,'卖'),COLOR00FF00;
{"VARE是大笔出货条件,VARF和VAR10是大资金活动条件";}
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA ((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA ((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
{"增加大资金活动条件";}
Var11:=VarF<REF(Var10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);{"条件并有成交量>昨天的成交量";}
DRAWTEXT(Var11 AND COUNT(Var11,30)=1,12,'大资金活动'),linethick1,COLORff00ff;{"写大资金活动";}
STICKLINE(Var11 AND COUNT(Var11,30)=1,1,10,8,0),colorff00ff;{"在1-10之间画粉红柱,大资金活动";}
{"大笔出货条件";}
VAR12:=(HIGH+LOW+CLOSE)/3;
VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));
VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));
VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);
VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15); VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR18:=100-ABS(VAR17); VAR19:=IF(VAR18<90,VAR18,100);
VAR1A:=IF(VARE>0,VARE,0);
VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;
VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,15,'大笔出货'),LINETHICK1,COLORFFCC66;
STICKLINE(VAR1C AND COUNT(VAR1C,30)=1,0,10,8,0),COLORFFCC66;{"在0-10之间画蓝柱";}

同花顺变味的MACD指标公式

 

相关文章