在线检测未来函数

通达信反线主图指标公式

来源:Internet,编辑:股旁网,2017-05-15

{反线主图:}
DRAWGBK(C>0, RGB(10,10,30),RGB(66,10,20),0,'11',0);
DRAWKLINE(H,O,L,C);
MA120:MA(CLOSE,120),COLORFFFF00,LINETHICK1;
MA60:MA(CLOSE,60),COLOR00FF00,LINETHICK1;
{MA30:MA(CLOSE,30),COLORF0F000,LINETHICK1;}
MA20:MA(CLOSE,20),COLORFF00FF,LINETHICK1;
MA10:MA(CLOSE,10),COLOR00FFFF,LINETHICK1;
MA5:MA(CLOSE,5),COLORWHITE,LINETHICK1;
{涨跌停标识}
C2:=REF(C,1);
非ST涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
涨停:=非ST涨停;
{STICKLINE(涨停,O,C,2.8,0),COLOR00E8E8;}
STICKLINE(涨停,O,C,2.6,0),COLOR9B37FF;
STICKLINE(涨停,H,L,1,0),COLOR7400E8;
非ST跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
跌停:=非ST跌停;
STICKLINE(跌停,O,C,2.7,0),COLORFF5555;
STICKLINE(跌停,H,L,1,0),COLORBLUE;
半涨1:=IF((C-C2)*100/C2>=(5-0.01*100/C2),1,0);
半涨2:=IF((C-C2)*100/C2<(10-0.01*100/C2),1,0);
JRS:=半涨1 AND 半涨2 AND FINANCE(33)>0;
STICKLINE(JRS AND C>O,O,C,2.7,0),COLOR020EF4;
{STICKLINE(JRS,H,L,0,0),COLOR020EF4;}
NUMBER:=COUNT(非ST涨停,BARSSINCE(非ST涨停)+1);
DRAWNUMBER(非ST涨停,HIGH*1.02,NUMBER),COLORWHITE;{涨停处标识次序}
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.56,0,0,NUMBER),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.45,0,0,'上市以来共涨停:'),COLORYELLOW;
{前期小高位}
A1:=REF(H,10)=HHV(H,2*10+1);
B1:=FILTER(A1,10);
C1:=BACKSET(B1,10+1);
HD:=FILTER(C1,10);
A2:=REF(H,10)=LLV(H,2*10+1);
B2:=FILTER(A2,10);
C3:=BACKSET(B2,10+1);
LD:=FILTER(C3,10);
前期小高位:REF(H,BARSLAST(HD)),COLORFFA346,POINTDOT;
STICKLINE(H,前期小高位,前期小高位,8,0),COLORFFA346;
{鲤鱼跃龙门}
LT8:=LLVBARS(L,60);
LTT8:=BARSLAST(CURRBARSCOUNT=CONST(LT8)+1);
HT8:=FINDHIGHBARS(H,LT8+1,60,1);
龙门:DRAWLINE(CURRBARSCOUNT=CONST(HT8)+1,H,ISLASTBAR,REF(H,HT8),0),COLORYELLOW,LINETHICK2;
DRAWTEXT(ISLASTBAR,龙门,' 龙门'),COLORLIGRAY;
TT8:=BARSLAST(CURRBARSCOUNT=CONST(HT8)+1);
AA8:=CROSS(C,CONST(龙门));
TJ8:=COUNT(AA8,TT8+1)=1 AND AA8;
TJ18:=COUNT(V<MA(V,277),TT8+1) ;
BL8:=TJ18/(TT8+1)*100;
XG8:=TJ8 AND TT8>40 AND BL8>70;
XGT8:=BARSLAST(CURRBARSCOUNT=CONST(BARSLAST(XG8))+1);
ZH8:=REF(H,TT8);
YL8:=REF(L,LTT8);
XC8:=REF(C,XGT8);
YZ8:=(XC8-YL8)/YL8*100;
ZBL8:=YZ8/REF(LTT8,XGT8);
XGA8:=XG8 AND ZBL8<2.95;
NOTEXT_AA:DRAWLINE(TT8=0,H,LTT8=0,L,0),COLORFF8080,LINETHICK2;
NOTEXT_BB:DRAWLINE(LTT8=0,L,XGT8=0,L,0),COLORFF8080,LINETHICK2;
STICKLINE(XGA8,C,O,1,0),COLOR0E66FA;
DRAWTEXT(XGA8,龙门*0.985,'跃龙门'),COLORYELLOW;
{量能平台}
N1:=19;
TK:=CONST(REFV(HHVBARS(V,21),1)+1);
LNPT:=IF(CURRBARSCOUNT<=N1+3,CONST(IF(TK=0,C,REF((H+L)/2,TK))),DRAWNULL);
量能平台:HHV(LNPT,21),COLOR8000FF,LINETHICK2;
NOTEXT_新量能点:
IF(CURRBARSCOUNT=TK+1,量能平台,DRAWNULL),CIRCLEDOT,COLORRED,LINETHICK4;
NOTEXT2:IF(CURRBARSCOUNT=TK+1,量能平台,DRAWNULL),CIRCLEDOT,COLORYELLOW,LINETHICK2;
DRAWTEXT(ISLASTBAR,量能平台,' 量能'),COLORLIGRAY;
{锁仓拉升}
获利盘:=WINNER(C)*100;
近邻筹码:=(WINNER(C*1.07)-WINNER(C*0.93))*85;
换手率:=V/CAPITAL*100;
VAR7:=ZIG(3,13);
转向:=REF(VAR7,2)<REF(VAR7,1) AND VAR7<REF(VAR7,1);
STICKLINE(转向,C,O,2,0),COLOR00FF00;
锁仓:=获利盘>=85 AND 近邻筹码<30 AND 换手率<5 AND NOT(EXIST(转向,5));
DRAWTEXT(锁仓,(L*0.99),'◆'),COLORWHITE;
{现价:DRAWLINE(CURRBARSCOUNT=TOTALBARSCOUNT,CONST(C),CURRBARSCOUNT=1,C,3)DOTLINE;}
{支撑.阻力画线}
Y1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,22))/MA(CLOSE,22);
Y2:=CONST((1-5/100)*(DMA(CLOSE,Y1)));
Y3:=CONST((1+3/100)*(DMA(CLOSE,Y1)));
支撑:IF(PERIOD=5,IF(BARSLAST(CURRBARSCOUNT=60),Y2,DRAWNULL),DRAWNULL),DOTLINE,LINETHICK1,COLORFFFF00;
阻力:IF(PERIOD=5,IF(BARSLAST(CURRBARSCOUNT=22),Y3,DRAWNULL),DRAWNULL),DOTLINE,LINETHICK1,COLORGREEN;
{红五星蓝方块:一组买卖信号}
LC:=REF(CLOSE,3);
JH:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(FILTER(CROSS(JH,30),55),LOW*0.99,'★'),COLOR8000FF;
DRAWTEXT(FILTER(CROSS(84,JH),22),HIGH*1.005,'◆'),COLOR008080;
{一绝涨跌信号}
Q_1:=C-REF(C,1);
Q_2:=100*EMA(EMA(Q_1,6),6)/EMA(EMA(ABS(Q_1),6),6);
Q_3:=CROSS(EMA(C,19),EMA(C,7));
Q_4:=CROSS(EMA(C,7),EMA(C,19));
ZD1:=L=LLV(L,BARSLAST(Q_3)+1);
ZD2:=LLV(L,BARSLAST(Q_3)+1);
ZD3:=H=HHV(H,BARSLAST(Q_4)+1);
ZD4:=HHV(H,BARSLAST(Q_4)+1);
Q_A:=DRAWLINE(ZD1,ZD2,ZD3,ZD4,0);
U1:=H=HHV(H,BARSLAST(Q_4)+1);
U2:=HHV(H,BARSLAST(Q_4)+1);
U3:=L=LLV(L,BARSLAST(Q_3)+1);
U4:=LLV(L,BARSLAST(Q_3)+1);
Q_B:=DRAWLINE(U1,U2,U3,U4,0);
TJS:=IF(Q_B<REF(Q_B,1) AND Q_B=Q_A,1,0);
BB:=REF(TJS,1)=0 AND TJS>=1 ;
DRAWICON(BB,L*0.98,34);
SS:=REF(Q_A<REF(Q_A,1) AND Q_B=Q_A,1)=0 AND TJS<1;
DRAWICON(SS,H*1.02,35);
{周线走好}
TW:=BARSLAST(WEEKOFYEAR!=REF(WEEKOFYEAR,1));
CC1:=REF(C,TW+1);
CC2:=REF(CC1,TW+1);
CC3:=REF(CC2,TW+1);
CC4:=REF(CC3,TW+1);
CC5:=REF(CC4,TW+1);
CC6:=REF(CC5,TW+1);
CC7:=REF(CC6,TW+1);
CC8:=REF(CC7,TW+1);
CC9:=REF(CC8,TW+1);
MM10:=(C+CC1+CC2+CC3+CC4+CC5+CC6+CC7+CC8+CC9)/10;
E20:=EXPMA(C,20);
E120:=EXPMA(C,120);
E250:=EXPMA(C,250);
A:=MACD.DIF;
B:=MACD.DEA;
TA1:=BARSLAST(CROSS(A,B));
ST:=BARSLAST(CROSS(B,A));
ZF:=(HHV(H,110)-LLV(L,110))/LLV(L,110)*100;
TJ:=EVERY(V>REF(V,1),2);
HH:=MAX(MAX(E20,E120),E250);
LL:=MIN(MIN(E20,E120),E250);
NH:=HH/LL*100-100;
TJ1:=EVERY(NH<40,25);
ZZF:=(C-REF(C,10))/REF(C,10)*100 ;
TJA:=C>MM10;
XG:=TA1=0 AND A<REF(A,ST) AND B<REF(B,ST) AND ZF<70 AND TJ AND TJ1 AND ZZF<1.4 AND TJA;
STICKLINE(XG,C,O,2,0),COLORYELLOW;
STICKLINE(XG,H,L,0,0),COLORYELLOW;
DRAWTEXT(XG,L*0.98,'周线走好'),COLORYELLOW;
M5:=MA(C,5);
M10:=MA(C,10);
M15:=MA(C,15);
FTJ:=M5>REF(M5,1) AND M10>REF(M10,1) AND M15>=REF(M15,10);
FT:=BARSLAST(CROSS(FTJ,0.5));
FTT:=BARSLAST(WEEKOFYEAR!=REF(WEEKOFYEAR,1));
FHH:=MAX(MAX(M5,M10),M15);
FLL:=MIN(MIN(M5,M10),M15);
FNH:=FHH/FLL*100-100;
FZZF:=(C-REF(C,FTT+1))/REF(C,FTT+1)*100;
FZZF1:=REF(FZZF,FTT+1);
FTJ2:=CROSS(FZZF>20,0.5) OR CROSS(FZZF1>20,0.5);
FJD:=(ATAN((M5/REF(M5,1)-1)*100)*180/3.1415926);
FTJA:=FZZF1>0 AND FZZF1>0 ;
FDT:=M10/M15*100-100>1 AND H/MAX(C,O)<1.03;
FBL:=MIN(C,O)/M5;
FBL5:=M5/M10*100-100;
FXG:=FTJ2 AND C=HHV(C,5) AND BETWEEN(FT,0,5)AND FTJA AND FNH<12 AND FDT AND FBL<1.045 AND FBL5<7.2 AND FJD<77.5;
STICKLINE(CROSS(FXG,0.5),C,O,1.8,0),COLORMAGENTA;
STICKLINE(CROSS(FXG,0.5),H,L,0,0),COLORMAGENTA;
DRAWTEXT(CROSS(FXG,0.5),L*0.98,'周线翻红'),COLORYELLOW;
{短线盈利}
{E20:=EXPMA(C,20);
E120:=EXPMA(C,120);
E250:=EXPMA(C,250);}
SNH:=E120/E250*100-100;
STA:=EVERY(SNH<3 AND E120>E250,20);
STB:=CROSS(E20,MAX(E120,E250));
STC:=MIN(C,O)/E20<1.08;
SXG:=STB AND STA AND STC;
STICKLINE(SXG,C,O,2.5,0),COLOR1E67FF;
DRAWICON(SXG,H*1.02,18);
DRAWTEXT(SXG,L*0.97,'短赢')COLORYELLOW;
{与庄共舞主图}
{M5:=MA(C,5);
M10:=MA(C,10);}
M20:=MA(C,20);
M60:=MA(C,60);
T:=BARSLAST(C>REF(C,1)*1.095 AND C=H);
T2:=BARSLAST(C<REF(C,1)*1.095 AND C>REF(C,1)*1.08);
T3:=BARSLAST(C<REF(C,1)*1.08 AND C>REF(C,1)*1.07);
T4:=BARSLAST(C<REF(C,1)*1.07 AND C>REF(C,1)*1.06);
T5:=BARSLAST(C<REF(C,1)*1.06 AND C>REF(C,1)*1.05);
TJAA:=C>REF(C,1)*1.05;
AAA:=REF(T,1)>100 AND REF(T2,1)>100 AND REF(T3,1)>100 AND REF(T4,1)>100 AND REF(T5,1)>80 AND TJAA;
HHM:=HHV(MACD.MACD*100,200);
LLM:=LLV(MACD.MACD*100,200);
D1:=MIN(MIN(M5,M10),M20)<M60;
D3:=MIN(MIN(M5,M10),M20)>M60;
XGTT:=BARSLAST(AAA AND HHM<60 AND LLM>-55);
D6:=BARSSINCEN(MIN(MIN(M5,M10),M20)>M60,XGTT+1);
XGAA:=CROSS((XGTT=0 AND D3) OR D6=0,0.5);
TAA:=COUNT(XGAA,30)=1 AND XGAA;
TJY:=COUNT(XGAA,30)=2 AND XGAA;
STICKLINE(TAA,C,O,1.5,0),COLORYELLOW;
STICKLINE(TAA,H,L,0,0),COLORYELLOW;
DRAWTEXT(TAA,L*0.97,'建仓'),COLORYELLOW;
STICKLINE(TJY,C,O,1.5,0),COLORLIMAGENTA;
STICKLINE(TJY,H,L,0,0),COLORLIMAGENTA;
DRAWTEXT(TJY,L*0.97,'拉升'),COLORLIMAGENTA;
{第二波启动}
M25:=MA(C,25),COLORYELLOW;
BU:=OBV.OBV;
MB:=OBV.MAOBV;
GL:=(MAX(BU,MB)/MIN(BU,MB)-1)*100;
TA:=BARSLAST(CROSS(GL>8,0.5));
TJB:=BARSLAST(COUNT(TA=0,100)=2 AND TA=0);
TJC:=CROSS(C,M25);
ZFY:=(C-REF(C,1))/REF(C,1)*100;
XG1:=COUNT(TJC,TJB+1)=1 AND TJC AND ZFY<7;
STICKLINE(XG1,L,H,0,0),COLORFF00FF;
STICKLINE(XG1,C,O,1.5,0),COLOR1E67FF;
DRAWTEXT(XG1,L*0.97,'第二波'),COLORWHITE;
{突破阴线}
QT:=BARSLAST(C>REF(C,1)*1.095 AND C=H);
QTJ:=(C-REF(C,QT+1))/REF(C,QT+1)*100;
QTJ1:=EVERY(C<O,QT);
QTJ2:=COUNT(REF(C,1)/C>1.09,QT)>0 AND REF(C,1)/C>1.09;
QA:=QTJ>-1 AND QTJ1 AND QTJ2;
QTA:=BARSLAST(QA);
QHH:=REF(H,QTA);
QTJ3:=EVERY(MAX(C,O)<QHH,QTA);
QTJ4:=MIN(C,O)<QHH AND MAX(C,O)>QHH AND COUNT(MIN(C,O)<QHH AND MAX(C,O)>QHH,QTA)=1;
QTJ5:=REF(QTJ3,1) AND QTA<69 AND IF(C<O,O/QHH>1.007,C>O) AND IF(C<O,REF(C,1)/C<1.06,C>O);
QXG:=QTJ4 AND QTJ5;
STICKLINE(QTA>=0,REF(H,QTA),REF(H,QTA),6,0),COLORBLUE;
DRAWICON(QXG=1,H*1.01,1);
DRAWTEXT(QXG=1,L*0.97,'突破阴'),COLORYELLOW;
DRAWTEXT(QTA=0,H*1.01,STRCAT(STRCAT('阴线最高价:',VAR2STR(REF(H,QTA),2)),'元'))COLORYELLOW;
{横盘突破主图}
MAA10:=EXPMA(C,10);
TTJ:=IF(MAX(C,O)<=MAA10,RANGE(MAX(C,O)/MAA10,0.99,1.005),IF(MIN(C,O)>=MAA10,RANGE(MIN(C,O)/MAA10,0.999,1.01),DRAWNULL));
TTJ1:=C=HHV(MAX(C,O),10) AND V=HHV(V,10);
TTT:=BARSLAST(REF(EVERY(TTJ,10),1) AND TTJ1);
TTJ2:=CROSS(C,MAA10);
XGG:=COUNT(TTJ2,TTT+1)=1 AND TTJ2;
STICKLINE(XGG=1,C,O,1,0),COLORYELLOW;
DRAWTEXT(XGG=1,L*0.98,'横破'),COLORYELLOW;
{起程 绽放 蚂蚁上树联合主图}
E13:=EXPMA(C,13),,COLORGREEN;
M8:=MA(C,8);
M21:=MA(C,21);
M233:=MA(C,233);
E10:=EXPMA(C,10),COLORRED;
ZZT:=C/REF(C,1)>1.095 AND C=H;
ZA:=BARSLASTCOUNT(ZZT);
ZT:=BARSLAST(CROSS(ZA=3,0.5));
ZLL:=REF(L,(ZT+2));
ZTJ:=C<ZLL;
ZAA:=COUNT(ZTJ,ZT+1)=1 AND ZTJ;
ZTA:=BARSLAST(ZAA);
ZLT:=BARSLAST(L=LLV(L,ZTA+1));
ZTJ1:=CROSS(C,E10);
ZXG:=COUNT(ZTJ1,ZLT+1)=1 AND ZTJ1 AND TOTALBARSCOUNT>200;
STICKLINE(ZXG,C,O,2,0),COLORYELLOW;
DRAWTEXT(ZXG,L*0.99,'起轿'),COLORYELLOW;
{一壶清茶}
DTJ:=O>REF(H,1) AND C<O AND O/C<C/L AND V>REF(V,1);
DTT2:=BARSLAST(REF(ZA>1,1) AND DTJ);
DXG:=COUNT(CROSS(C,REF(H,DTT2)),DTT2+1)=1 AND CROSS(C,REF(H,DTT2));
STICKLINE(DTT2>=0,REF(H,DTT2),REF(H,DTT2),6,0),{COLORFF8000}COLOR00EC00,LINETHICK2;
DRAWTEXT(DTT2=0,REF(H,DTT2)*1.01,'清茶'),COLORYELLOW;
DRAWICON(DXG,L*0.97,34);
DRAWTEXT(DXG,L*0.96,'买');
{绽放}
HA:=M8/M21*100;
HTJ:=BARSLASTCOUNT(RANGE(HA,99.9,100.3));
HHB:=MAX(C,O)/MIN(C,O)*100-100;
HTJ1:=BARSLASTCOUNT(HHB<2);
HZF:=(HHV(H,5)-LLV(L,5))/LLV(L,5)*100;
HDZF:=(H-L)/REF(C,1)*100;
HTJ2:=COUNT(MIN(C,O)/L>1.03,5)=0;
HTJ3:=COUNT(H<REF(L,1),5)=0;
HTJ4:=C>M233;
HXG:=HTJ>4 AND HTJ1>4 AND HZF<10 AND HTJ2 AND HTJ3 AND HTJ4;
{STICKLINE(CROSS(HXG,0.5),C,O,2,0),COLORLIMAGENTA;}
STICKLINE(CROSS(HXG,0.5),H,L,1,0),COLORLIMAGENTA;
DRAWTEXT(CROSS(HXG,0.5),L*0.98,'绽放'),COLORYELLOW;
{DRAWTEXT(CROSS(HXG,0.5),HIGH*1.02,'◆'),COLORFF00FF;}
{蚂蚁上树}
ZF0:=(C-REF(C,1))/REF(C,1)*100;
TJJ:=EVERY(RANGE(ZF0,-2.22,2.55),15);
TJJ1:=C>O AND C/REF(C,1)>1.03;
TJJ2:=COUNT(E13>=REF(E13,1),15);
JD:=(ATAN((E13/REF(E13,15)-1)*100)*180/3.1415926);
A01:=IF(MIN(C,O)>E13,MAX(C,O)/E13*100-100,IF(MAX(C,O)<E13,E13/MIN(C,O),E13));
B01:=MAX(C,O)/MIN(C,O)*100-100;
LL0:=LLV(A01,15);
HH0:=HHV(A01,15);
HB:=COUNT(B01>3,15)<2;
XXG:=REF(TJJ,1) AND TJJ1 AND TJJ2>13 AND JD>72 AND REF(LL0,1)<1.37 AND REF(HH0,1)<11.15;
STICKLINE(XXG,L,H,0.6,0),COLOR0069D2;
{STICKLINE(XXG,C,O,2,0),COLOR0069D2;}
DRAWTEXT(XXG,L*0.98,'蚂蚁上树'),COLORYELLOW;
{平步青云主图}
DIF:=MACD.DIF;
H300:=HHVBARS(DIF,300);
AX1:=BOLL.UB;
T1:=BARSLAST(CROSS(AX1>=REF(AX1,1),0.5));
E25:=EXPMA(C,25),COLORMAGENTA;
ZF00:=EVERY(RANGE(C/REF(C,1),0.97,1.05),T1+1);
ZFF:=(HHV(H,T1+1)-LLV(L,T1+1))/LLV(L,T1+1)*100;
TJX:=EVERY(MAX(C,O)/AX1<1.02 ,T1+1);
XL:=(ATAN((E25/REF(E25,T1)-1)*100)*180/3.1415926);
TJ01:=CROSS(DIF>=REF(DIF,H300),0.5) AND ZFF<17 AND ZF00 AND TJX;
TJ2:=MIN(C,O)/E25>1.04;
XGS:=TJ01 AND XL>75;
STICKLINE(XGS,C,O,2,0),COLORLIRED;
STICKLINE(XGS,H,L,0,0),COLORLIRED;
DRAWICON(XGS,H*1.01,15);
DRAWTEXT(XGS,L*0.98,'起程')COLORYELLOW;
{抢反弹主图}
M25Q:=MA(C,25);
M60Q:=MA(C,60);
TQ:=BARSLAST(C>O AND C/REF(C,1)>1.05);
TJQ1:=EVERY(L>MA(C,60),TQ+1);
DF:=(C-REF(C,TQ+1))/REF(C,TQ+1)*100;
TJQ2:=DF<-11 AND C<O AND TJQ1 AND L=LLV(L,TQ+1);
C60:=BETWEEN(REF((L/M60Q-1)*100,1),0,6);
C25:=BETWEEN(REF((L/M25Q-1)*100,1),0,6);
TJQ3:=C60 OR C25;
QFTXG:=REF(TJQ2,1) AND C>O AND TJQ3;
STICKLINE(QFTXG,C,O,1.5,0),COLOR0072E3;
STICKLINE(QFTXG,H,L,0,0),COLORYELLOW;
DRAWTEXT(QFTXG,L*0.97,'抢反弹'),COLORYELLOW;
{大单成交}
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR12:=(HIGH+LOW+CLOSE)/3;
VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));
VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));
VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);
VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15);
VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR18:=100-ABS(VAR17);
VAR19:=IF(VAR18<90,VAR18,100);
VAR1A:=IF(VARE>0,VARE,0);
VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;
VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,L*0.98,'大单成交'),COLORWHITE;
{老鼠仓}
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CCA:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
老鼠仓:=BB1 AND CCA AND DD1 AND EE1,LINETHICK0;
DRAWTEXT(老鼠仓,(LOW* 0.99),'老鼠仓'),COLOR40CCFF;
{所属板块行业}
所属板块:=STRCAT('',STRCAT(STRCAT(STRCAT('',HYBLOCK),
STRCAT(' ',DYBLOCK)),STRCAT(' ',GNBLOCK)));
DRAWTEXT_FIX(ISLASTBAR,0,0,0,所属板块),COLORFFFF80;
DRAWTEXT_FIX(ISLASTBAR,0,0.05,0,EXTERNSTR(0,1)),COLORFFFF80;
DRAWTEXT_FIX(ISLASTBAR,0.11,0.1,0,FGBLOCK),COLORLIMAGENTA;
每股公积:=FINANCE(18)/1,NODRAW,COLORGREEN;
未分利润:=FINANCE(32)/1,NODRAW,COLORGREEN;
DRAWTEXT_FIX(1,0,0.1,0,STRCAT('【每股公积】: ',CON2STR(每股公积,3))),COLORYELLOW;
DRAWTEXT_FIX(1,0,0.15,0,STRCAT('【未分利润】: ',CON2STR(未分利润,3))),COLORYELLOW;
DRAWTEXT_FIX(1,0,0.2,0,STRCAT('【日换手率】: ',CON2STR(HSL,3))),COLORYELLOW;
{大小非.定向增发.回购.公开发行}
LTB:=FINANCE(7)*100/FINANCE(1);
ZGB:=FINANCE(1)/100000000;
JJS:=LTB-REF(LTB,1);
DRAWTEXT(LTB<REF(LTB,1)*0.95 AND ZGB>REF(ZGB,1),L*0.990,'定向增发'),COLORWHITE;
DRAWTEXT(ZGB<REF(ZGB,1)*0.95 AND LTB>REF(LTB,1),L*0.990,'回购'),COLORGREEN;
DRAWTEXT(LTB>REF(LTB,1)*1.05 AND ZGB=REF(ZGB,1),L*0.990,'大小非'),COLORYELLOW;
DRAWTEXT(LTB>REF(LTB,1)*1.05 AND ZGB>REF(ZGB,1),L*0.990,'公开发行');
{反线}
长周期:EMA(CLOSE,250),NODRAW,COLOR8000FF;
NOTEXTA:IF(长周期>=REF(长周期,1),长周期,DRAWNULL),COLORRED,LINETHICK4,POINTDOT;
NOTEXTB:IF(长周期<REF(长周期,1),长周期,DRAWNULL),COLOR006A6A,LINETHICK4,POINTDOT;
反线:EMA((长周期-(EMA(CLOSE,3)-长周期)),5),LINETHICK2,COLORBLUE;
效果:=CROSS(长周期,反线);
DRAWICON(CROSS(C,反线) AND MA(反线,3)<REF(MA(反线,3),1),反线*0.999,23);{起爆点做标记}
DRAWTEXT(效果,长周期*0.998,'起爆'),COLOR8000FF;
{强烈推荐}
中中中:=((XMA(XMA(H,15),15)+XMA(XMA(H,20),20)+XMA(XMA(H,30),30)+XMA(XMA(H,40),40))/4+(XMA(XMA(L,15),15)+XMA(XMA(L,20),20)+XMA(XMA(L,30),30)+XMA(XMA(L,40),40))/4)/2;
EMA中中中:=EMA(中中中,10);
中中底:=(XMA(XMA(L,15),15)+XMA(XMA(L,20),20)+XMA(XMA(L,30),30)+XMA(XMA(L,40),40))/4*2-(XMA(XMA(H,15),15)+XMA(XMA(H,20),20)+XMA(XMA(H,30),30)+XMA(XMA(H,40),40))/4;
短中底:=(XMA(XMA(L,5),5)+XMA(XMA(L,8),8)+XMA(XMA(L,11),11)+XMA(XMA(L,14),14))/4-((XMA(XMA(H,5),5)+XMA(XMA(H,8),8)+XMA(XMA(H,11),11)+XMA(XMA(H,14),14)+XMA(XMA(H,4),4))/5-(XMA(XMA(L,5),5)+XMA(XMA(L,8),8)+XMA(XMA(L,11),11)+XMA(XMA(L,14),14)+XMA(XMA(L,4),4))/5)/2;
AF中:=EMA((CLOSE+HIGH+LOW)/3,10);
BF中:=REF(AF中,1);
DRAWTEXT(中中中>=EMA中中中 AND CROSS(AF中,BF中) AND 短中底<中中底,L*0.97,'↖强烈推荐'),COLORFF00FF;
BC:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
分水岭:=IF(MA(CLOSE,17)<BC,BC,MA(CLOSE,17)),COLORFF8080,LINETHICK4,POINTDOT;
纠缠:分水岭-(EMA(C,3)-分水岭),COLOR808040,LINETHICK1,DOTLINE;

通达信反线主图指标公式

 

相关文章