在线检测未来函数

通达信基本面叠加分时主图指标公式

来源:Internet,编辑:股旁网,2017-05-15

MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA60:MA(CLOSE,60);
STICKLINE(C/REF(C,1)>=1.096 AND H=C,O,C,2,0),COLORYELLOW;
品种类型:=FINANCE(3);
行业板块:=HYBLOCK;
上市天数:=FINANCE(42);
股东人数:=FINANCE(8);
人均持股:=ROUND(FINANCE(7)/FINANCE(8));
净资收益率:=(FINANCE(33)/FINANCE(34)*100);
主营利润率:=(FINANCE(23)/FINANCE(20)*100);
现金负债比:=(FINANCE(25)/FINANCE(15));
主营业增长率:=FINANCE(44);
净利润增长率:=FINANCE(43);
每股收益:=CONST(FINANCE(38));
每股净资产:=CONST(FINANCE(34));
每股现金流:=CONST((FINANCE(25)/FINANCE(1)));
每股未分配:=CONST(FINANCE(32));
每股公积金:=CONST(FINANCE(18));
流通市值:=ROUND(FINANCE(40)/100000000);
A股流通:=FINANCE(7)/100000000;
市盈率:=DYNAINFO(39);
换手率:=VOL/CAPITAL*100;
资金净流:=L2_AMO(0,2)/100+L2_AMO(1,2)/100-L2_AMO(0,3)/100+L2_AMO(1,3)/100;
量比:=DYNAINFO(17);
成交方向:=DYNAINFO(40);
主动买单:=ISBUYORDER;
涨速:=DYNAINFO(24);
大单比率:=(LARGEINTRDVOL-LARGEOUTTRDVOL)/CAPITAL*100;
PEG指标:=DYNAINFO(39)/FINANCE(43)*100;
获利盘比例:=LWINNER(1,CLOSE);
区间成本:=COSTEX(CLOSE,REF(CLOSE,BARSCOUNT(C)-1));
收盘价:=REF(C,1);
今开盘价:=OPEN;
ER1:=净资收益率>3;
ER12:=净资收益率>0.01;
ER2:=主营利润率>2;
ER22:=主营利润率>0;
ER4:=主营业增长率>1;
ER42:=主营业增长率>0;
ER5:=净利润增长率>2;
ER52:=净利润增长率>0.2;
SAX1:=每股收益>0.01;
SAX12:= 每股收益>0.001;
SAX2:=每股净资产>2;
SAX22:=每股净资产>0.01;
SAX4:=每股未分配>0.5;
SAX42:=每股未分配>0.001;
SAX5:=每股公积金>0.5;
SAX52:=每股公积金>0.002;
DP3:=市盈率<200;
DP32:=市盈率<5000;
DP4:=换手率>0.1;
DP42:=换手率>0.01;
WMF1:=量比>0.8;
WMF12:=量比>0.3;
优秀:=ER1 AND ER2 AND ER4 AND ER5 AND SAX1 AND SAX2
AND SAX4 AND SAX5 AND DP3 AND DP4 AND WMF1,COLORRED;
QF:=NOT(优秀);
较好:=ER12 AND ER22 AND ER42 AND ER52 AND SAX12 AND SAX22
AND SAX42 AND SAX52 AND DP32 AND DP42 AND WMF12 AND QF,COLORMAGENTA;
DRAWTEXT_FIX(1,0.001,0.01,0,'品种类型:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.001,0.06,0,'行业板块:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.001,0.11,0,'上市天数:'),COLORYELLOW;{单位:天}
DRAWTEXT_FIX(1,0.001,0.16,0,'股东人数:'),COLORYELLOW;{单位:人}
DRAWTEXT_FIX(1,0.001,0.21,0,'人均持股:'),COLORYELLOW;{股}
DRAWTEXT_FIX(品种类型=1,0.052,0.01,0,'沪深A股'),COLORWHITE;
DRAWTEXT_FIX(品种类型=2,0.052,0.01,0,'中小板'),COLORWHITE;
DRAWTEXT_FIX(品种类型=3,0.052,0.01,0,'创业板'),COLORWHITE;
DRAWTEXT_FIX(1,0.052,0.06,0,HYBLOCK),COLORWHITE;
DRAWNUMBER_FIX(1,0.052,0.11,0,上市天数),COLORWHITE;
DRAWNUMBER_FIX(1,0.052,0.16,0,股东人数),COLORWHITE;
DRAWNUMBER_FIX(1,0.052,0.21,0,人均持股),COLORWHITE;
DRAWTEXT_FIX(1,0.001,0.26,0,'地区板块:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.052,0.26,0,DYBLOCK),COLORWHITE;
DRAWTEXT_FIX(1,0.108,0.26,0,'概念板块:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.158,0.26,0,GNBLOCK),COLORWHITE;
DRAWTEXT_FIX(1,0.001,0.31,0,'风格板块:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.052,0.31,0,FGBLOCK),COLORWHITE;
DRAWTEXT_FIX(1,0.108,0.01,0,'净资产收益率:'),COLORYELLOW;{单位:%}
DRAWTEXT_FIX(1,0.108,0.06,0,'主业务利润率:'),COLORYELLOW;{单位:%}
DRAWTEXT_FIX(1,0.108,0.11,0,'现金流负债比:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.108,0.16,0,'主营业增长率:'),COLORYELLOW;{单位:%}
DRAWTEXT_FIX(1,0.108,0.21,0,'净利润增长率:'),COLORYELLOW;{单位:%}
DRAWNUMBER_FIX(1,0.178,0.01,0,净资收益率),COLORWHITE;
DRAWNUMBER_FIX(1,0.178,0.06,0,主营利润率),COLORWHITE;
DRAWNUMBER_FIX(1,0.178,0.11,0,现金负债比),COLORWHITE;
DRAWNUMBER_FIX(1,0.178,0.16,0,主营业增长率),COLORWHITE;
DRAWNUMBER_FIX(1,0.178,0.21,0,净利润增长率),COLORWHITE;
DRAWTEXT_FIX(1,0.23,0.01,0,'每股收益:'),COLORYELLOW;{单位:元}
DRAWTEXT_FIX(1,0.23,0.06,0,'每股净资产:'),COLORYELLOW;{单位:元}
DRAWTEXT_FIX(1,0.23,0.11,0,'每股现金流:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.23,0.16,0,'每股未分配:'),COLORYELLOW;{单位:元}
DRAWTEXT_FIX(1,0.23,0.21,0,'每股公积金:'),COLORYELLOW;{单位:元}
DRAWNUMBER_FIX(1,0.309,0.01,1,每股收益),COLORWHITE;
DRAWNUMBER_FIX(1,0.323,0.06,1,每股净资产),COLORWHITE;
DRAWNUMBER_FIX(1,0.323,0.11,1,每股现金流),COLORWHITE;
DRAWNUMBER_FIX(1,0.323,0.16,1,每股未分配),COLORWHITE;
DRAWNUMBER_FIX(1,0.319,0.21,1,每股公积金),COLORWHITE;
DRAWTEXT_FIX(1,0.34,0.01,0,'流通市值:'),COLORYELLOW;{单位:亿元}
DRAWTEXT_FIX(1,0.34,0.06,0,'A股流通:'),COLORYELLOW;{单位:亿元}
DRAWTEXT_FIX(1,0.34,0.11,0,'市盈率:'),COLORYELLOW;{单位:%}
DRAWTEXT_FIX(1,0.34,0.16,0,'换手率:'),COLORYELLOW;{单位:%}
DRAWTEXT_FIX(1,0.34,0.21,0,'资金净流:'),COLORYELLOW;{单位:万元}
DRAWNUMBER_FIX(1,0.391,0.01,0,流通市值),COLORWHITE;
DRAWNUMBER_FIX(1,0.386,0.06,0,A股流通),COLORWHITE;
DRAWNUMBER_FIX(1,0.381,0.11,0,市盈率),COLORWHITE;
DRAWNUMBER_FIX(1,0.381,0.16,0,换手率),COLORWHITE;
DRAWNUMBER_FIX(1,0.391,0.21,0,资金净流),COLORWHITE;{需LEVE2数据}
DRAWTEXT_FIX(1,0.439,0.01,0,'量比:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.439,0.06,0,'成交方向:'),COLORYELLOW;{单位:亿元}
DRAWTEXT_FIX(1,0.439,0.11,0,'主动买单:'),COLORYELLOW;{单位:%}
DRAWTEXT_FIX(1,0.439,0.16,0,'涨速:'),COLORYELLOW;{单位:%}
DRAWTEXT_FIX(1,0.439,0.21,0,'大单比率:'),COLORYELLOW;{单位:万元}
DRAWNUMBER_FIX(1,0.469,0.01,0,量比),COLORWHITE;
DRAWNUMBER_FIX(1,0.49,0.06,0,成交方向),COLORWHITE;{0主动买,1主动卖,2中性单}
DRAWNUMBER_FIX(1,0.49,0.11,0,主动买单),COLORWHITE;{主动性买单1,否则0}
DRAWNUMBER_FIX(1,0.47,0.16,0,涨速),COLORWHITE;{需LEVE2数据}
DRAWNUMBER_FIX(1,0.49,0.21,0,大单比率),COLORWHITE;{需LEVE2数据}
DRAWTEXT_FIX(1,0.521,0.01,0,'PEG指标:'),COLORYELLOW;{1左右为安全,±50为较安全}
DRAWTEXT_FIX(1,0.521,0.06,0,'获利盘比例:'),COLORYELLOW;{当前价位的市场获利盘的比例}
DRAWTEXT_FIX(1,0.521,0.11,0,'区间成本:'),COLORYELLOW;{近两日收盘价格间筹码的成本}
DRAWTEXT_FIX(1,0.521,0.16,0,'昨收盘价:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.521,0.21,0,'今开盘价:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.573,0.01,0,PEG指标),COLORWHITE;
DRAWNUMBER_FIX(1,0.583,0.06,0,获利盘比例),COLORWHITE;
DRAWNUMBER_FIX(1,0.573,0.11,0,区间成本),COLORWHITE;
DRAWNUMBER_FIX(1,0.573,0.16,0,昨收盘价),COLORWHITE;
DRAWNUMBER_FIX(1,0.573,0.21,0,今开盘价),COLORWHITE;
DRAWTEXT_FIX(优秀,0.645,0.01,0,'基本面:优秀级!'),COLORRED;
DRAWTEXT_FIX(较好,0.645,0.06,0,'基本面:较好!'),COLORMAGENTA;

通达信基本面叠加分时主图指标公式

 

相关文章