在线检测未来函数

通达信辣手操盘主图指标公式

来源:Internet,编辑:股旁网,2017-05-15

A:=AMOUNT/V/100;
VARA:=EMA((((A-EMA(A,13))/EMA(A,13))*(0-100)),5);
QQ:=EMA(((VARA/10)+EMA(A,13)),0);
行情线:=MA(A,1);
重心:=(C+0.618*REF(C,1)+0.382*REF(C,1)+0.236*REF(C,3)+0.146*REF(C,4))/2.382;
【操盘线】:EMA(((SLOPE(C,22)*20)+C),55),COLORYELLOW,LINETHICK4;
【黄金线】:IF(重心>=【操盘线】,【操盘线】,DRAWNULL),COLORRED,LINETHICK2;
空仓线】:IF(重心<【操盘线】,【操盘线】,DRAWNULL),COLORCYAN,LINETHICK2;
DRAWTEXT(ISLASTBAR,【操盘线】,'【操盘线】'),COLORRED;
引:EMA(CLOSE,2),LINETHICK1,COLORMAGENTA;
探:MA(CLOSE,5),LINETHICK1;
变:EMA(CLOSE,5),LINETHICK1,COLORYELLOW;
金:IF(变>REF(变,1),变,DRAWNULL),COLORRED,LINETHICK1;
空:IF(变<REF(变,1),变,DRAWNULL),COLORGREEN,LINETHICK1;
DRAWTEXT(ISLASTBAR,变,'【雷达线】'),COLORRED;
{顶底信号}
DA:=(EMA(H,1)+EMA(L,1)+EMA(H,1)+EMA(H,1))/4;
DB:=EMA(REF(HHV(H,25),1),2),COLORGREEN,LINETHICK1;
DRAWTEXT(CROSS(DB,DA),DB,'←险'),COLORGREEN,LINETHICK1;
DRAWTEXT(CROSS(DA,【操盘线】),【操盘线】,'B'),COLORWHITE,LINETHICK1;
{涨跌停显示}
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0);
STICKLINE(涨停,O,C,1,0),COLORYELLOW;
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF<-9.9,O,C,1,0),COLORBLUE;
VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
S:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;
VAR100:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR200:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR300:=(100 - MA(((100 * (HHV(HIGH,5) - CLOSE)) / (HHV(HIGH,5) - LLV(LOW,5))),34));
F:IF(CROSS(VAR200,MA(VAR300,5)),LOW * 0.98,DRAWNULL),CROSSDOT,LINETHICK3,COLORFF00FF;
DRAWTEXT(CROSS(S,卖1),S,'←逃'),COLORWHITE,LINETHICK1;
DRAWTEXT(CROSS(B,买1),B,'←准备'),COLORRED,LINETHICK1;
{价:}
JC1:=(REF(C,3)+REF(C,5)+REF(C,7)+REF(C,8)+REF(C,13)+REF(C,21))/6;
参考价1:SMA(JC1,5,1),CIRCLEDOT,COLORGREEN;
IF(C>=参考价1,参考价1,DRAWNULL),CIRCLEDOT,COLOR0000FF;
PH:=TROUGHBARS(2,5,1);
LL:=HHV(H,PH);
TJ1:=LL=HIGH AND LL<REF(LL,1);{//=1}
TS:=SUMBARS(TJ1,2);
TJ:=PEAKBARS(2,5,1)=1 AND TS>=PH;
DRAWICON(TJ,HIGH*1.01+0.02,2);
警告灯:IF(TJ,HIGH*1.008,DRAWNULL),CROSSDOT,LINETHICK2,COLORCYAN;
PL:=BARSLAST(TJ);
支撑:IF(BARSLAST(TJ1),
REF(LOW,BARSLAST(TJ1)),DRAWNULL),COLOREA91B5;
压力:IF(BARSLAST(TJ),REF(HIGH,PL),DRAWNULL),COLORYELLOW;
TJ_2:=LOW>REF(REF(LOW,TS),PL);
DRAWTEXT(ISLASTBAR,压力,'压力'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,支撑,'支撑'),COLOREA91B5;
DRAWICON(COUNT(TJ_2,PL+1)=1,HIGH*1.005,2);{//向下的箭头表示出局点}
DRAWICON(BARSLAST(TJ1),REF(LOW*0.995,BARSLAST(TJ1)),1);
{基本面}
MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA60:MA(CLOSE,60);
STICKLINE(C/REF(C,1)>=1.096 AND H=C,O,C,2,0),COLORYELLOW;
品种类型:=FINANCE(3);
行业板块:=HYBLOCK;
上市天数:=FINANCE(42);
股东人数:=FINANCE(8);
人均持股:=ROUND(FINANCE(7)/FINANCE(8));
DRAWTEXT_FIX(1,0.001,0.01,0,'品种类型:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.001,0.05,0,'行业板块:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.001,0.09,0,'上市天数:'),COLORYELLOW;{单位:天}
DRAWTEXT_FIX(1,0.001,0.13,0,'股东人数:'),COLORYELLOW;{单位:人}
DRAWTEXT_FIX(1,0.001,0.17,0,'人均持股:'),COLORYELLOW;{股}
DRAWTEXT_FIX(品种类型=1,0.052,0.01,0,'沪深A股'),COLORWHITE;
DRAWTEXT_FIX(品种类型=2,0.052,0.01,0,'中小板'),COLORWHITE;
DRAWTEXT_FIX(品种类型=3,0.052,0.01,0,'创业板'),COLORWHITE;
DRAWTEXT_FIX(1,0.052,0.05,0,HYBLOCK),COLORWHITE;
DRAWNUMBER_FIX(1,0.052,0.09,0,上市天数),COLORWHITE;
DRAWNUMBER_FIX(1,0.052,0.13,0,股东人数),COLORWHITE;
DRAWNUMBER_FIX(1,0.052,0.17,0,人均持股),COLORWHITE;
DRAWTEXT_FIX(1,0.001,0.21,0,'地区板块:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.052,0.21,0,DYBLOCK),COLORWHITE;
DRAWTEXT_FIX(1,0.108,0.21,0,'概念板块:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.158,0.21,0,GNBLOCK),COLORWHITE;
DRAWTEXT_FIX(1,0.001,0.25,0,'风格板块:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.052,0.25,0,FGBLOCK),COLORWHITE;
净资收益率:=(FINANCE(33)/FINANCE(34)*100);
主营利润率:=(FINANCE(23)/FINANCE(20)*100);
现金负债比:=(FINANCE(25)/FINANCE(15));
主营业增长率:=FINANCE(44);
净利润增长率:=FINANCE(43);
DRAWTEXT_FIX(1,0.108,0.01,0,'净资产收益率:'),COLORYELLOW;{单位:%}
DRAWTEXT_FIX(1,0.108,0.05,0,'主业务利润率:'),COLORYELLOW;{单位:%}
DRAWTEXT_FIX(1,0.108,0.09,0,'现金流负债比:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.108,0.13,0,'主营业增长率:'),COLORYELLOW;{单位:%}
DRAWTEXT_FIX(1,0.108,0.17,0,'净利润增长率:'),COLORYELLOW;{单位:%}
DRAWNUMBER_FIX(1,0.178,0.01,0,净资收益率),COLORWHITE;
DRAWNUMBER_FIX(1,0.178,0.05,0,主营利润率),COLORWHITE;
DRAWNUMBER_FIX(1,0.178,0.09,0,现金负债比),COLORWHITE;
DRAWNUMBER_FIX(1,0.178,0.13,0,主营业增长率),COLORWHITE;
DRAWNUMBER_FIX(1,0.178,0.17,0,净利润增长率),COLORWHITE;
每股收益:=CONST(FINANCE(38));
每股净资产:=CONST(FINANCE(34));
每股现金流:=CONST((FINANCE(25)/FINANCE(1)));
每股未分配:=CONST(FINANCE(32));
每股公积金:=CONST(FINANCE(18));
DRAWTEXT_FIX(1,0.23,0.01,0,'每股收益:'),COLORYELLOW;{单位:元}
DRAWTEXT_FIX(1,0.23,0.05,0,'每股净资产:'),COLORYELLOW;{单位:元}
DRAWTEXT_FIX(1,0.23,0.09,0,'每股现金流:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.23,0.13,0,'每股未分配:'),COLORYELLOW;{单位:元}
DRAWTEXT_FIX(1,0.23,0.17,0,'每股公积金:'),COLORYELLOW;{单位:元}
DRAWNUMBER_FIX(1,0.309,0.01,1,每股收益),COLORWHITE;
DRAWNUMBER_FIX(1,0.318,0.05,1,每股净资产),COLORWHITE;
DRAWNUMBER_FIX(1,0.319,0.09,1,每股现金流),COLORWHITE;
DRAWNUMBER_FIX(1,0.319,0.13,1,每股未分配),COLORWHITE;
DRAWNUMBER_FIX(1,0.319,0.17,1,每股公积金),COLORWHITE;
流通市值:=ROUND(FINANCE(40)/100000000);
A股流通:=FINANCE(7)/100000000;
市盈率:=DYNAINFO(39);
换手率:=VOL/CAPITAL*100;
资金净流:=L2_AMO(0,2)/100+L2_AMO(1,2)/100-L2_AMO(0,3)/100+L2_AMO(1,3)/100;
DRAWTEXT_FIX(1,0.34,0.01,0,'流通市值:'),COLORYELLOW;{单位:亿元}
DRAWTEXT_FIX(1,0.34,0.05,0,'A股流通:'),COLORYELLOW;{单位:亿元}
DRAWTEXT_FIX(1,0.34,0.09,0,'市盈率:'),COLORYELLOW;{单位:%}
DRAWTEXT_FIX(1,0.34,0.13,0,'换手率:'),COLORYELLOW;{单位:%}
DRAWTEXT_FIX(1,0.45,0.17,0,'资金净流:'),COLORYELLOW;{单位:万元}
DRAWNUMBER_FIX(1,0.391,0.01,0,流通市值),COLORWHITE;
DRAWNUMBER_FIX(1,0.386,0.05,0,A股流通),COLORWHITE;
DRAWNUMBER_FIX(1,0.381,0.09,0,市盈率),COLORWHITE;
DRAWNUMBER_FIX(1,0.381,0.13,0,换手率),COLORWHITE;
DRAWNUMBER_FIX(1,0.501,0.17,0,资金净流),COLORWHITE;{需LEVE2数据}
量比:=DYNAINFO(17);
成交方向:=DYNAINFO(40);
主动买单:=ISBUYORDER;
涨速:=DYNAINFO(24);
大单比率:=(LARGEINTRDVOL-LARGEOUTTRDVOL)/CAPITAL*100;
DRAWTEXT_FIX(1,0.45,0.01,0,'量比:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.45,0.05,0,'成交方向:'),COLORYELLOW;{单位:亿元}
DRAWTEXT_FIX(1,0.45,0.09,0,'主动买单:'),COLORYELLOW;{单位:%}
DRAWTEXT_FIX(1,0.45,0.13,0,'涨速:'),COLORYELLOW;{单位:%}
DRAWTEXT_FIX(1,0.34,0.17,0,'大单比率:'),COLORYELLOW;{单位:万元}
DRAWNUMBER_FIX(1,0.481,0.01,0,量比),COLORWHITE;
DRAWNUMBER_FIX(1,0.501,0.05,0,成交方向),COLORWHITE;{0主动买,1主动卖,2中性单}
DRAWNUMBER_FIX(1,0.501,0.09,0,主动买单),COLORWHITE;{主动性买单1,否则0}
DRAWNUMBER_FIX(1,0.481,0.13,0,涨速),COLORWHITE;{需LEVE2数据}
DRAWNUMBER_FIX(1,0.391,0.17,0,大单比率),COLORWHITE;{需LEVE2数据};
ER1:=净资收益率>3;
ER12:=净资收益率<3 AND 净资收益率>1;
ER2:=主营利润率>5;
ER22:=主营利润率>1;
ER4:=主营业增长率>5;
ER42:=主营业增长率>1;
ER5:=净利润增长率>5;
ER52:=净利润增长率>0.5;
SAX1:=每股收益>0.01;
SAX12:= 每股收益>0.002;
SAX2:=每股净资产>2;
SAX22:=每股净资产>0.2;
SAX4:=每股未分配>0.5;
SAX42:=每股未分配>0.01;
SAX5:=每股公积金>0.5;
SAX52:=每股公积金>0.05;
DP2:=A股流通<20;
DP22:=A股流通<5000;
DP3:=市盈率<200;
DP32:=市盈率<5000;
DP4:=换手率>1;
DP42:=换手率>0.5;
WMF1:=量比>0.8;
WMF12:=量比>0.5;
优秀:=ER1 AND ER2 AND ER4 AND ER5 AND SAX1 AND SAX2
AND SAX4 AND SAX5 AND DP2 AND DP3 AND DP4 AND WMF1;
较好:=ER12 AND ER22 AND ER42 AND ER52 AND SAX12 AND SAX22
AND SAX42 AND SAX52 AND DP22 AND DP32 AND DP42 AND WMF12;
DRAWTEXT_FIX(优秀,0.55,0.01,0,'基本面:优秀级!'),COLORRED;
DRAWTEXT_FIX(较好,0.55,0.05,0,'基本面:较好!'),COLORMAGENTA;

通达信辣手操盘主图指标公式

 

相关文章