在线检测未来函数

通达信贴心参谋指标公式

来源:Internet,编辑:股旁网,2017-05-16

DRAWRECTREL(0,0,1000,1000,RGB(50,78,50));
DRAWRECTREL(0,80,973,920,RGB(50,100,140));
GD:=CONST(HHV("999999$H",100)),NODRAW;{高点}
DD:=CONST(LLV("999999$L",100)),NODRAW;{低点}
{=======}
MMM:=REFDATE(HHV("999999$H",233),DATE);
NNN:=REFDATE(LLV("999999$L",233),DATE);
DPX:=EMA(INDEXC,21);
JJ:=(INDEXO+INDEXH+INDEXC)/3;
参:=GD-DD,NODRAW;
高:=GD-(参*0.095),NODRAW;
低:=DD+(参*0.095),NODRAW;
STICKLINE(JJ<DPX,高,低,4,0),COLOR333333;
{上证指数K线副图指标}
DRAWKLINE("999999$H","999999$O","999999$L","999999$C");
{====}
DRAWRECTREL(0,0,408,1000,RGB(50,78,50));
DRAWRECTREL(27,50,403,950,RGB(50,78,50));
DRAWRECTREL(0,0,22,1000,RGB(128,58,0));
DRAWRECTREL(408,0,430,1000,RGB(128,58,0));
DRAWRECTREL(978,0,1000,1000,RGB(128,58,0));
{=======}
DRAWTEXT_FIX(C>O,0.006,0.075,0,'个 '),COLORWHITE;{白}
DRAWTEXT_FIX(C>O,0.006,0.3,0,'股 '),COLORWHITE;{白}
DRAWTEXT_FIX(C>O,0.006,0.53,0,'动 '),COLORWHITE;{白}
DRAWTEXT_FIX(C>O,0.006,0.75,0,'态 '),COLORWHITE;{白}
{=======}
DRAWTEXT_FIX(C>O,0.4125,0.075,0,'大 '),COLORWHITE;{白}
DRAWTEXT_FIX(C>O,0.4125,0.3,0,'盘 '),COLORWHITE;{白}
DRAWTEXT_FIX(C>O,0.4125,0.53,0,'走 '),COLORWHITE;{白}
DRAWTEXT_FIX(C>O,0.4125,0.75,0,'势 '),COLORWHITE;{白}
{=======}
DRAWTEXT_FIX(C>O,0.983,0.075,0,'贴 '),COLORWHITE;{白}
DRAWTEXT_FIX(C>O,0.983,0.3,0,'心 '),COLORWHITE;{白}
DRAWTEXT_FIX(C>O,0.983,0.53,0,'参 '),COLORWHITE;{白}
DRAWTEXT_FIX(C>O,0.983,0.75,0,'谋 '),COLORWHITE;{白}
{========K 线 解 盘==========}
TT:=240/FROMOPEN;
比:=TT;
AY2:=EMA(CLOSE,12)-EMA(CLOSE,26);
AZ2:=EMA(AY2,9);
LT2:=(AY2-AZ2);
L211:=IF(LT2,LLV(L,21),DRAWNULL),COLOR217158,CIRCLEDOT;
ZGD:=HHV(H,80)*0.99;
ZGD2:=CONST(ZGD);
ZDD:=LLV(L211,80);
ZDD2:=CONST(ZDD);
YA4:=MA(CLOSE,20);
YA5:=(CLOSE > MA(CLOSE,5));
YA6:=(MA(CLOSE,5) > MA(CLOSE,10));
YA7:=(CLOSE > MA(CLOSE,10));
YA8:=(MA(CLOSE,5) > MA(CLOSE,20));
YA9:=(CLOSE > MA(CLOSE,20));
YA10:=REF(YA4,1);
YA11:=(YA4 > YA10);
YAVX:=(((((IF(YA5,10,(0 - 10)) + IF(YA6,10,(0 - 10))) + IF(YA7,10,(0 - 10))) + IF(YA8,10,(0 - 10))) + IF(YA9,10,(0 - 10))) + IF(YA11,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
YYV1:=MA(VOL,5);
YYV2:=MA(VOL,10);
J1:=CONST(IF( YAVX > 0,200,100));
J2:=CONST(IF( YAVX > 0,00,100));
J3:=CONST(IF( YAVX > 0,100,100));
ZGD3:=ZGD2;
ZDD3:=ZDD2;
ZGD4:=ZGD2;
情况1:=CONST(IF(((CROSS(YAVX,1) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0)),NODRAW;
情况2:=CONST(IF(((CROSS(YAVX,1) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况3:=CONST(IF(((CROSS(YAVX,1) AND (YYV1 > YYV2)) AND (DSLX < DSLX1)),1,0));
情况4:=CONST(IF(((CROSS(YAVX,1) AND (YYV1 <= YYV2)) AND (DSLX < DSLX1)),1,0));
情况5:=CONST(IF(((CROSS(1,YAVX) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况6:=CONST(IF(((CROSS(1,YAVX) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况7:=CONST(IF(((CROSS(1,YAVX) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));
情况8:=CONST(IF(((CROSS(1,YAVX) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
情况9:=CONST(IF(((((YAVX >= 1) AND (REF(YAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况10:=CONST(IF(((((YAVX >= 1) AND (REF(YAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况11:=CONST(IF(((((YAVX >= 1) AND (REF(YAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0)),NODRAW;
情况12:=CONST(IF(((((YAVX >= 1) AND (REF(YAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
情况13:=CONST(IF(((((YAVX < 1) AND (REF(YAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况14:=CONST(IF(((((YAVX < 1) AND (REF(YAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况15:=CONST(IF(((((YAVX < 1) AND (REF(YAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));
情况16:=CONST(IF(((((YAVX < 1) AND (REF(YAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
大盘1:=CONST(IF((CROSS(YAVX,1) AND (YYV1 >= YYV2)),1,0));
大盘2:=CONST(IF((CROSS(YAVX,1) AND (YYV1 < YYV2)),1,0));
大盘3:=CONST(IF((CROSS(1,YAVX) AND (YYV1 >= YYV2)),1,0));
大盘4:=CONST(IF((CROSS(1,YAVX) AND (YYV1 < YYV2)),1,0));
大盘5:=CONST(IF((((YAVX >= 1) AND (REF(YAVX,1) > 0)) AND (YYV1 >= YYV2)),1,0));
大盘6:=CONST(IF((((YAVX >= 1) AND (REF(YAVX,1) > 0)) AND (YYV1 < YYV2)),1,0));
大盘7:=CONST(IF((((YAVX < 1) AND (REF(YAVX,1) < 0)) AND (YYV1 >= YYV2)),1,0));
大盘8:=CONST(IF((((YAVX < 1) AND (REF(YAVX,1) < 0)) AND (YYV1 < YYV2)),1,0));
TS1:=IF(情况1=1,0.25,-0.05{高低});
TS2:=IF(情况2=1,TS1+0.3,TS1);
TS3:=IF(情况3=1,TS2+0.3,TS2);
TS4:=IF(情况4=1,TS3+0.3,TS3);
TS5:=IF(情况5=1,TS4+0.3,TS4);
TS6:=IF(情况6=1,TS5+0.3,TS5);
TS7:=IF(情况7=1,TS6+0.3,TS6);
TS8:=IF(情况8=1,TS7+0.3,TS7);
TS9:=IF(情况9=1,TS8+0.3,TS8);
TS10:=IF(情况10=1,TS9+0.3,TS9);
TS11:=IF(情况11=1,TS10+0.3,TS10);
TS12:=IF(情况12=1,TS11+0.3,TS11);
TS13:=IF(情况13=1,TS12+0.3,TS12);
TS14:=IF(情况14=1,TS13+0.3,TS13);
TS15:=IF(情况15=1,TS14+0.3,TS14);
TS16:=IF(情况16=1,TS15+0.3,TS15);
TS17:=IF(大盘1=1,TS16+0.3,TS16);
TS18:=IF(大盘2=1,TS17+0.3,TS17);
TS19:=IF(大盘3=1,TS18+0.3,TS18);
TS20:=IF(大盘4=1,TS19+0.3,TS19);
TS21:=IF(大盘5=1,TS20+0.3,TS20);
TS22:=IF(大盘6=1,TS21+0.3,TS21);
TS23:=IF(大盘7=1,TS22+0.3,TS22);
TS24:=IF(大盘8=1,TS23+0.3,TS23);
DRAWTEXT_FIX(情况1=1 ,0.035,TS1,0,'量 能 理 想 , 明 显 走 强 ,中 线 参 与 ,仓 位 控 制 在 70% 左 右 。'),COLORWHITE;{白}
DRAWTEXT_FIX(情况2=1 ,0.035,TS2,0,'走 势 趋 强 , 量 能 不 足 ,短 线 进 场 ,仓 位 控 制 在 50 % 左 右 。'),COLORWHITE;{白}
DRAWTEXT_FIX(情况3=1 ,0.035,TS3,0,'量 价 良 好 , 并 无 明 显 走 强 ,短 线 可 进 场 ,仓 位 50 % 左 右。'),COLORWHITE;{白}
DRAWTEXT_FIX(情况4=1 ,0.035,TS4,0,'形 态 尚 可 , 量 能 不 足 ,未 全 走 强 ,短 入,仓 位 30 % 左 右 。'),COLORWHITE;{白}
DRAWTEXT_FIX(情况5=1 ,0.035,TS5,0,'形 态 已 变 坏 , 走 势 尚 可,重 仓 者 减 大 半 ,清 仓 者 观 望。'),COLORWHITE;{白}
DRAWTEXT_FIX(情况6=1 ,0.035,TS6,0,'随 大 盘 下 跌 ,明 显 缩 量 ,考 虑 大 盘 风 险 ,减 持 或 清 仓 。'),COLORWHITE;{白}
DRAWTEXT_FIX(情况7=1 ,0.035,TS7,0,'该 股 放 量 下 跌 ,走 势 明 显 偏弱,不 抢 反 弹 ,离 场 观 望 。'),COLORWHITE;{白}
DRAWTEXT_FIX(情况8=1 ,0.035,TS8,0,'该 股 缩 量 下 跌 ,走 势 偏 弱 无力,人 气 散 失 ,离 场 观 望 。'),COLORWHITE;{白}
DRAWTEXT_FIX(情况9=1 ,0.035,TS9,0,'该 股 形 态 良 好 ,强 势 明 显,量 能 充 足,可 以 继 续 持 有 。'),COLORWHITE;{白}
DRAWTEXT_FIX(情况10=1,0.035,TS10,0,'上 行 趋 势 不 变 ,强 势 依 然,量 能 开 始 转 弱 ,注 意 风 险 。'),COLORWHITE;{白}
DRAWTEXT_FIX(情况11=1,0.035,TS11,0,'该 股 仍 然 具 备 上 涨 潜 力,但 股 性 偏 弱 ,可 以 考 虑 减 仓。'),COLORWHITE;{白}
DRAWTEXT_FIX(情况12=1,0.035,TS12,0,'该 股 走 趋 弱,量 能 明 显 不 足 ,减 大 部 分 筹 码 或 空 仓 。'),COLORWHITE;{白}
DRAWTEXT_FIX(情况13=1,0.035,TS13,0,'该 股 形 态 不 佳 ,注 意 成 交 量 变 化,但 目 前 不 适 合 参 与 。'),COLORWHITE;{白}
DRAWTEXT_FIX(情况14=1,0.035,TS14,0,'该 股 趋 势 不 明 ,股 价 偏 弱 ,注 意 量 能 变 化,暂 不参 与 。'),COLORWHITE;{白}
DRAWTEXT_FIX(情况15=1,0.035,TS15,0,'有 走 强 迹 象 ,但 量 能 不 足 ,趋 势 不 明 朗 ,不 适 合 操 作 。'),COLORWHITE;{白}
DRAWTEXT_FIX(情况16=1,0.035,TS16,0,'该 股 走 势 太 弱 ,主 动 性 买 盘 弱 ,没 有 太 大 的 参 与 价 值 。'),COLORWHITE;{白}
DRAWTEXT_FIX(大盘1=1,0.035,TS17,0,'总 势 量 能 理 想 , 70 % 仓 位 , 若 最 佳 买 点 ,否 则 谨 慎 介 入 。'),COLORWHITE;{白}
DRAWTEXT_FIX(大盘2=1,0.035,TS18,0,'总 势 趋 强 ,量 不 足 , 若 前 轮 下 跌 ,短 进 50 % ,量 大 加 仓 。'),COLORWHITE;{白}
DRAWTEXT_FIX(大盘3=1,0.035,TS19,0,'总 势 形 态 走 坏 ,重 仓 者 可 减 去 大 部 分 仓 位 或 放 空 筹 码 。'),COLORWHITE;{白}
DRAWTEXT_FIX(大盘4=1,0.035,TS20,0,'总 势 缩 量 调 整 ,注 意 大 盘 系 统 风 险,短 线 可 清 仓 观 望 。'),COLORWHITE;{白}
DRAWTEXT_FIX(大盘5=1,0.035,TS21,0,'总 势 走 势 良 好 ,量 能 理 想 ,可 继 续 持 有 或 加 仓 强 势 股 。'),COLORWHITE;{白}
DRAWTEXT_FIX(大盘6=1,0.035,TS22,0,'总 势 形 态 良 好 ,但 量 能 稍 显 不 足 ,随 时 准 备 减 仓 调 仓 。'),COLORWHITE;{白}
DRAWTEXT_FIX(大盘7=1,0.035,TS23,0,'总 势 趋 势 不 明 ,注 意 成 交 量 变 化 ,目 前 暂 不 适 宜 进 场 。'),COLORWHITE;{白}
DRAWTEXT_FIX(大盘8=1,0.035,TS24,0,'总 势 趋 势 向 下 ,量 能 萎 缩 ,短 线 可 杀 跌 ,不 适 合 进 场 。'),COLORWHITE;{白};

通达信贴心参谋指标公式

 

相关文章