在线检测未来函数

通达信短线追主图指标公式

来源:Internet,编辑:股旁网,2017-05-18

MA250:MA(C,250),COLOR0000FF;
MA120:MA(C,120),COLORFF0066;
MA5:MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20),COLOR33FFFF;
MA30:MA(C,30),COLORFFFFFF,LINETHICK2;
MA55:MA(C,55),COLORCCFF66,LINETHICK1;
BM1:=(C+O)/2;
BM2:=COUNT(MA30>REF(MA30,1),5)=5 OR COUNT(MA55>REF(MA55,1),5)=5;
BM3:=COUNT(MA5/MA30>REF(MA5/MA30,1),5)=5;
BM4:=(BM1*2-REF(BM1,3));
BM5:=C/MA(C,5);
BM6:=REF(BM1/MA(BM1,5),1);
BM7:=COUNT(BM6>BM5,3)=3;
BM8:=C>O;
买:=(CROSS(BM4,MA5) OR CROSS(BM4,MA30)) AND BM2 AND BM8 AND C>MA(C,60);
优选:=买 AND (BM7 OR REF(BM7,1) OR REF(BM7,2)),COLORYELLOW,LINETHICK2;
{以下设置主图显示}
STICKLINE(买,O,C,4,1),COLOR00FF00,LINETHICK2;
DRAWTEXT(买 ,LLV(L,2)*0.98,'▲'),COLORYELLOW;
DRAWTEXT(优选,LLV(L,2)*0.93, '短线追'),COLOR00FF66;
DRAWICON(优选,LLV(L,2)*0.96, 1);
STICKLINE(优选,O,C,4,1),COLORYELLOW,LINETHICK2;
{以下设置逃顶}
BM9:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
涨:IF(MA(CLOSE,5)>REF(MA(CLOSE,5),1),MA(CLOSE,5),DRAWNULL),COLORRED,LINETHICK2;
平:IF(MA(CLOSE,5)=REF(MA(CLOSE,5),1),MA(CLOSE,5),DRAWNULL),COLORYELLOW,LINETHICK3;
跌:IF(MA(CLOSE,5)<REF(MA(CLOSE,5),1),MA(CLOSE,5),DRAWNULL),COLORGREEN,LINETHICK2;
BM10:=3*SMA(BM9,3,1)-2*(SMA(SMA(BM9,3,1),3,1));
DRAWICON(CROSS(90,BM10),H*1.03,2);

通达信短线追主图指标公式

 

相关文章