在线检测未来函数

同花顺牛熊争锋主图指标公式

来源:Internet,编辑:股旁网,2017-05-22

攻击线:EMA(C,7),colorwhite;
黄金线:(EMA(C,18)),LINETHICK4,coloryellow;
生命线:(MA(C,28)),colormagenta;
决策线:(EMA(C,56)),colorcyan;
牛熊线:(MA(C,120)),COLOR0099FF;
A3:=EMA((((SLOPE(C,21)) * 20) + C),68);
A4:=EMA(C,10);
A5:=REF(C,2);
A6:=((SMA((MAX((C - A5),0)),6,1)) / (SMA(ABS((C - A5)),6,1))) * 100;
A7:=IF(((A6 < (REF(A6,1))) AND (A6 > 79)),A6,0);
A8:=LLV(L,21);
A9:=HHV(H,21);
A10:=EMA((((CLOSE - A8) / (A9 - A8)) * 100),5);
A11:=EMA((((CLOSE - A8) / (A9 - A8)) * 50),13);
A12:=EMA(((0.667 * (REF(A10,1))) + (0.333 * A10)),2);
A13:=LLV(L,55);
A14:=HHV(H,34);
A15:=EMA((((C - A13) / (A14 - A13)) * 100),3);
A16:=(A11 + A15) / 2;
A17:=EMA(((0.667 * (REF(A15,1))) + (0.333 * A10)),2);
A18:=EMA(A16,5);
A19:=EMA(((0.667 * (REF(A18,1))) + (0.333 * A18)),2);
A20:=CROSS(A10,A11);
A21:=(CROSS(A10,A19)) AND (A19 < 30);
A22:=A21 * 0.6;
A23:=((C + L) + H) / 3;
A24:=EMA(A23,6);
A25:=EMA(A24,5);
A26:=CROSS(A24,A25);
DRAWICON(A26,(LOW / 1.030),1),LINETHICK2,colormagenta;
DRAWTEXT(CROSS(A4,A3),L*0.88,'牛'),LINETHICK4,coloryellow;
STICKLINE(((C >= 黄金线) AND (C >= O)),H,L,0,1),colorred;
STICKLINE(((C >= 黄金线) AND (C >= O)),O,C,2,1),colorred;
STICKLINE(((C >= 黄金线) AND (C <= O)),H,L,0,0),colorred;
STICKLINE(((C >= 黄金线) AND (C <= O)),O,C,2,0),colorred;
STICKLINE(((C < 黄金线) AND (C >= O)),H,L,0,1),colorgreen;
STICKLINE(((C < 黄金线) AND (C >= O)),O,C,2,1),colorgreen;
STICKLINE(((C < 黄金线) AND (C <= O)),H,L,0,0),colorgreen;
STICKLINE(((C < 黄金线) AND (C <= O)),O,C,2,0),colorgreen;

同花顺牛熊争锋主图指标公式

 

相关文章