在线检测未来函数

通达信牛股基因指标公式

来源:Internet,编辑:股旁网,2017-05-23

RSV89:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100;
K89:=SMA(RSV89,13,1);
D89:=SMA(K89,3,1);
J89:=3*K89-2*D89;
长:=EMA(J89,5);
RSV1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
K1:=SMA(RSV1,3,1);
D1:=SMA(K1,3,1);
J1:=3*K1-2*D1;
中:=EMA(J1,5),COLORYELLOW;
RSV2:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
K2:=SMA(RSV2,3,1);
D2:=SMA(K2,3,1);
J2:=3*K2-2*D2;
短:=EMA(J2,5),COLORWHITE;
{个股涨幅跟沪深两大盘对比}
ZF5:=(CLOSE-REF(CLOSE,4))/REF(CLOSE,4)*100;
ZF5D1:=("999999$CLOSE"-REF("999999$CLOSE",4))/REF("999999$CLOSE",4)*100;
ZF5D2:=("399001$CLOSE"-REF("399001$CLOSE",4))/REF("399001$CLOSE",4)*100;
DPDB:=MA(ZF5-MAX(ZF5D1,ZF5D2),5);
{成本重心}
CBZX:=AMOUNT/VOL/100;
斜率:=SLOPE(CBZX,3)+SLOPE(CBZX,5);
{相对强度}
相对强度:=DPDB,COLORWHITE;
TJ1:=SLOPE(DPDB,3)>0 AND 斜率>0;
TJ2:=中<20 AND 短<20 AND 长<60;
条件1:=相对强度>REF(相对强度,1) AND REF(相对强度,1)>REF(相对强度,2) AND REF(相对强度,2)<REF(相对强度,3)
AND REF(相对强度,1)<-4 AND TJ1 AND REF(TJ1,1);
条件2:=相对强度>REF(相对强度,1) AND REF(相对强度,1)>REF(相对强度,2) AND REF(相对强度,2)>REF(相对强度,3) AND REF(相对强度,3)<REF(相对强度,4)
AND REF(相对强度,1)<-4 AND TJ1 AND REF(TJ1,1);
条件3:=相对强度>REF(相对强度,1) AND REF(相对强度,1)<REF(相对强度,2)
AND 相对强度<-4 AND TJ1;
因子:=ABS(LLV(相对强度,5));
牛股基因: ((条件1 OR 条件2 OR 条件3) AND EXIST(TJ2,5))*因子,COLORRED,LINETHICK2;

通达信牛股基因指标公式

 

相关文章