在线检测未来函数

通达信跟庄线主图指标公式

来源:Internet,编辑:股旁网,2017-05-25

M:=20;
均价:=(2*C+(C+H+L+O)/4+O)/4;
R:=(3*L+2*均价)/5;R1:=(3*H+2*均价)/5;
KX:=(R+R1)/2;
跟庄线:MA(SUM(KX*V,2)/SUM(V,2),M),COLORWHITE,LINETHICK3;
止损:=((M/4)*HHV(REF(跟庄线,1),1)-(M/4-1)*跟庄线),COLORGREEN;
止赢:=2*跟庄线-止损,COLORYELLOW;
买入持股:IF(止赢>止损 AND KX>跟庄线,跟庄线,DRAWNULL)COLORMAGENTA,LINETHICK4;
MA1:=MA(CLOSE,120),COLORA02DA7,LINETHICK2;
MA3:=MA(CLOSE,60);
MA2:=MA(CLOSE,30),LINETHICK2;
MID :=MA(CLOSE,20);
HH:=HHV(HIGH,10);
LL:=LLV(LOW,10);
HH1:=BARSLAST(HH > REF(HH,1))+1;
LL1:=BARSLAST(LL < REF(LL,1))+1;
HH2:=REF(HH1,1);
LL2:=REF(LL1,1);
DRAWTEXT(CROSS(MA3,C) AND MID<MA3 AND MA3<MA1 AND MA3>MA2 AND BARSLAST(CROSS(MA3,MA2))>3,HIGH*1.01,'卖'),COLORFFF00F;
A20:=EMA(CLOSE,20),COLOREFFFFF,LINETHICK2;
A10:=EMA(CLOSE,10),LINETHICK2;
A60:=EMA(CLOSE,60),COLOR111199,LINETHICK2;
M1:EMA(C,5);
M2:EMA(C,10);
M3:=EMA(CLOSE,60);M4:=MA(CLOSE,60);
STICKLINE(M1>M2,M1,M2,2,0),COLORMAGENTA;
STICKLINE(M1<M2,M1,M2,2,0),COLORGREEN;
MA132:=EMA(CLOSE,130);
DRAWTEXT(CROSS(C,跟庄线) AND CROSS(C,M2)AND CROSS(C,M1)
AND V<REF(V,1) AND 跟庄线<M1 ,L*0.95,'谨慎做多'),COLORRED;
DRAWTEXT(CROSS(MA3,跟庄线) AND C<MA3,L*0.97,'逢高卖出'),COLORGREEN;
DRAWTEXT(CROSS(跟庄线,C) AND CROSS(M2,C)AND CROSS(M1,C)
AND V>REF(V,1) AND 跟庄线>M1 ,H*1.07,'减仓'),COLORGREEN;
DRAWTEXT(CROSS(M1,C)AND C<MA3 AND C<跟庄线 AND MA2>跟庄线
AND BARSLAST(CROSS(MA2,跟庄线))>3 AND 跟庄线<MA3 AND M1<REF(C,1) AND MA3<REF(MA3,1) ,H*1.03,'割肉'),COLORGREEN;
DRAWTEXT(CROSS(跟庄线,MA3) AND C>MA3,H*1.08,'回调买进'),COLORRED;
做空:=FILTER(BARSLAST(CROSS(跟庄线,M1) OR CROSS(MA3,跟庄线))<4 AND MA3>REF(MA3,1) AND BARSLAST(CROSS(跟庄线,MA3))>50,10);
做多:=FILTER(BARSLAST(CROSS(M1,跟庄线) OR CROSS(跟庄线,MA3))<4 AND MA3<REF(MA3,1) AND BARSLAST(CROSS(MA3,跟庄线))>50,10);
DRAWTEXT(做空,H*1.02,'减仓'),COLOR0066FF;
WR1:=(HHV(HIGH,10)-LLV(LOW,10))/LLV(LOW,10);
WR2:=REF(WR1,1)<=0.3;
WR3:=BARSCOUNT(C)>10;
WR4:=C>=HHV(HIGH,10);
突破:=FILTER(WR2&&WR3&&WR4,4);
DRAWTEXT(突破,LOW*0.94,'●突破'),COLORGREEN;
WR15:=(HHV(HIGH,20)-LLV(LOW,20))/HHV(HIGH,20);
WR25:=REF(WR15,1)<=0.3;
WR35:=BARSCOUNT(C)>20;
WR45:=C<=LLV(LOW,20);
PPP:=SUM(VOL,3)/CAPITAL>0.15;
PPP2:=VOL>REF(VOL,1);
PPP3:=H=HHV(H,3);
DRAWTEXT(PPP AND PPP2 AND PPP3 AND WR2 AND WR3 AND WR4,LOW*0.97,'●跟进'),COLORGREEN;
DRAWTEXT(WR25&&WR35&&WR45,HIGH*1.02,'●快跑'),COLORGREEN;

通达信跟庄线主图指标公式

 

相关文章