在线检测未来函数

通达信KDJ演化一种指标公式

来源:Internet,编辑:股旁网,2017-05-26

M1:=18;
Q1:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1)*100;
Q2:=(CLOSE-LLV(LOW, M1))/(HHV(HIGH, M1)-LLV(LOW, M1))*100;
Q3:=SMA(Q2, 9, 1);
Q4:=SMA(Q3, 3, 1);
AA:3*Q3-2*Q4, ,COLOR1010FF;
Q5:=AA>1*REF(AA, 1);
Q6:=LLVBARS(LOW, 50);
Q7:=SUM(VOL, Q6);
Q8:=HHVBARS(HIGH, 50);
Q9:=SUM(VOL, Q8);
Q10:=(CLOSE-REF(OPEN, Q8))/REF(OPEN, Q8)*100;
Q11:=HHV(AA,5);
A1:EMA(Q3, 3) , COLOR33AA33;
A2:EMA(A1, 3) , COLOR44BB44;
A3:EMA(A2, 3) , COLOR55CC55;
A4:EMA(A3, 3) , COLOR66DD66;
A5:EMA(A4, 3) , COLOR66EE66;
A6:EMA(A5, 3) , COLOR66FF66;
A7:EMA(A4, 3) , COLOR33FF33;
IF(A1>=REF(A1,1),A1,DRAWNULL),COLOR3333AA;
IF(A2>=REF(A2,1),A2,DRAWNULL),COLOR4444BB;
IF(A3>=REF(A3,1),A3,DRAWNULL),COLOR5555CC;
IF(A4>=REF(A4,1),A4,DRAWNULL),COLOR6666DD;
IF(A5>=REF(A5,1),A5,DRAWNULL),COLOR6666EE;
IF(A6>=REF(A6,1),A6,DRAWNULL),COLOR6666FF;
IF(A7>=REF(A7,1),A7,DRAWNULL),COLOR3333FF;
DRAWTEXT(CROSS(AA, 20) AND Q10<-13,10,'*大底'), COLOR00FF00;
DRAWTEXT(CROSS(AA, A5) AND REF(AA,1)<34,REF(AA,1),'小'), COLOR00FFFF;
DRAWTEXT(CROSS(A1, AA) AND REF(AA,1)>80, REF(AA,3), '*顶'), COLOR00FF00;
DRAWTEXT(CROSS(AA, A1) AND Q5 AND A1<20 AND Q1>9 OR A1>1*REF(A1, 1)
AND Q1>4 AND A1<60, 30, '拉'), COLORFFFFCC;
20,COLOR990099;
50,COLOR006666;
80,COLOR009900;

通达信KDJ演化一种指标公式

 

相关文章