在线检测未来函数

通达信表格指标公式

来源:Internet,编辑:股旁网,2017-06-01

代码1:=CODELIKE('600744'){≮填买入代码}* DATE>=(20161123){≮填买入时间}-19000000;
代码2:=CODELIKE('002526'){≮填买入代码}* DATE>=(20151230){≮填买入时间}-19000000;
代码3:=CODELIKE('999999'){≮填买入代码}* DATE>=(20161122){≮填买入时间}-19000000;
代码4:=CODELIKE('002157'){≮填买入代码}* DATE>=(20161122){≮填买入时间}-19000000;
代码5:=CODELIKE('002157'){≮填买入代码}* DATE>=(20161122){≮填买入时间}-19000000;
代码6:=CODELIKE('002157'){≮填买入代码}* DATE>=(20161122){≮填买入时间}-19000000;
代码7:=CODELIKE('002157'){≮填买入代码}* DATE>=(20161122){≮填买入时间}-19000000;
代码8:=CODELIKE('002157'){≮填买入代码}* DATE>=(20161122){≮填买入时间}-19000000;
{=========}
代码:=代码1 OR 代码2 OR 代码3 OR 代码4 OR 代码5 OR 代码6 OR 代码7 OR 代码8;
高点:=PEAKBARS(0,10,1)=0;
高:=高点 AND (SUM(高点,400-CURRBARSCOUNT) = CONST(SUM(高点,400-CURRBARSCOUNT))-2);
仿代码:=BARSLAST(高)>=0 AND 代码=0;
用心算:=IF(CONST(代码),代码,仿代码);
{====}
高减昨收:=IF(H>REF(C,1),H-REF(C,1),0)*用心算,NODRAW;
昨收减低:=IF(REF(C,1)>L,REF(C,1)-L,0)*用心算,NODRAW;
高减开:=(H-O)*用心算,NODRAW;
开减低:=(O-L)*用心算,NODRAW;
{===表格竖线===}
DRAWRECTREL(5,0,993,990,RGB(50,100,140));
DRAWRECTREL(73,0,131,990,RGB(50,50,50));
DRAWRECTREL(189,0,247,990,RGB(50,50,50));
DRAWRECTREL(305,0,388,990,RGB(50,50,50));{成交}
DRAWRECTREL(388,0,471,990,RGB(50,50,50));{总成交}
DRAWRECTREL(471,0,529,990,RGB(50,78,50));
DRAWRECTREL(587,0,645,990,RGB(50,78,50));
DRAWRECTREL(703,0,761,990,RGB(50,78,50));
DRAWRECTREL(819,0,877,990,RGB(50,100,140));
DRAWRECTREL(935,0,993,990,RGB(50,100,140));
{==表格横线==};
DRAWRECTREL(5,90,993,90,RGB(250,250,250));
DRAWRECTREL(5,190,993,190,RGB(250,250,250));
DRAWRECTREL(5,290,993,290,RGB(250,250,250));
DRAWRECTREL(5,390,993,390,RGB(250,250,250));
DRAWRECTREL(5,490,993,490,RGB(250,250,250));
DRAWRECTREL(5,590,993,590,RGB(250,250,250));
DRAWRECTREL(5,690,993,690,RGB(250,250,250));
DRAWRECTREL(5,790,993,790,RGB(250,250,250));
DRAWRECTREL(5,890,993,890,RGB(250,250,250));
{====}
DRAWTEXT_FIX(C>0,0.01,0.91,0,' 今 ' ),COLORYELLOW;
AX1:=STRCAT(STRCAT(STRCAT(STRCAT('日 期' ,' 开') ,' 高') ,' 低') ,' 收');
DRAWTEXT_FIX(C>0,0.02,0.015,0,AX1),COLORYELLOW;
AX2:=STRCAT('成交量',' 成交 {差 合}');
DRAWTEXT_FIX(C>0,0.325,0.015,0,AX2),COLORWHITE;
AX3:=STRCAT(STRCAT(STRCAT(STRCAT('测 开', ' 测 高'),' 均 中' ), ' 测 收'),' 测 低' );
DRAWTEXT_FIX(C>0,0.487,0.015,0,AX3),,COLORYELLOW;
AX4:=STRCAT(STRCAT(STRCAT('高-(昨收)',' (昨收)-低' ),' 高-开(和' ),' 开-低(和)');
DRAWTEXT_FIX(C>0,0.765,0.015,0,AX4),COLORWHITE;
{====}
AA2:=STRCAT(CON2STR(DAY,0),'日');
DRAWTEXT_FIX(C>0,0.03,0.91,0,AA2),COLORYELLOW;
BB1:=STRCAT(CON2STR(REF(MONTH,1),0),'月');
BB2:=STRCAT(CON2STR(REF(DAY,1),0),'日');
BB3:=STRCAT(BB1,BB2);
DRAWTEXT_FIX(C>0,0.01,0.81,0,BB3),COLORYELLOW;
CC2:=STRCAT(CON2STR(REF(DAY,2),0),'日');
CC3:=STRCAT(BB1,CC2);
DRAWTEXT_FIX(C>0,0.01,0.71,0,CC3),COLORYELLOW;
DD2:=STRCAT(CON2STR(REF(DAY,3),0),'日');
DD3:=STRCAT(BB1,DD2);
DRAWTEXT_FIX(C>0,0.011,0.61,0,DD3),COLORYELLOW;
EE2:=STRCAT(CON2STR(REF(DAY,4),0),'日');
EE3:=STRCAT(BB1,EE2);
DRAWTEXT_FIX(C>0,0.011,0.51,0,EE3),COLORYELLOW;
FF2:=STRCAT(CON2STR(REF(DAY,5),0),'日');
FF3:=STRCAT(BB1,FF2);
DRAWTEXT_FIX(C>0,0.011,0.41,0,FF3),COLORYELLOW;
GG2:=STRCAT(CON2STR(REF(DAY,6),0),'日');
GG3:=STRCAT(BB1,GG2);
DRAWTEXT_FIX(C>0,0.011,0.31,0,GG3),COLORYELLOW;
HH2:=STRCAT(CON2STR(REF(DAY,7),0),'日');
HH3:=STRCAT(BB1,HH2);
DRAWTEXT_FIX(C>0,0.011,0.21,0,HH3),COLORYELLOW;
YY2:=STRCAT(CON2STR(REF(DAY,8),0),'日');
YY3:=STRCAT(BB1,YY2);
DRAWTEXT_FIX(C>0,0.011,0.11,0,YY3),COLORYELLOW;
{====}
大盘代码:=CODELIKE('999999') OR CODELIKE('399107');
成交:=IF(大盘代码,INDEXA/1000000,V);
成交量:IF(C>O OR (C=O AND C>=REF(C,1)),成交,-成交)*用心算,NODRAW;
DRAWTEXT_FIX(V>0,0.313,0.91,0,CON2STR(成交量,0)),COLORYELLOW;
DRAWTEXT_FIX(REF(V,1)>0,0.313,0.81,0,CON2STR(REF(成交量,1),0)),COLORYELLOW;
DRAWTEXT_FIX(REF(V,2)>0,0.313,0.71,0,CON2STR(REF(成交量,2),0)),COLORYELLOW;
DRAWTEXT_FIX(REF(V,3)>0,0.313,0.61,0,CON2STR(REF(成交量,3),0)),COLORYELLOW;
DRAWTEXT_FIX(REF(V,4)>0,0.313,0.51,0,CON2STR(REF(成交量,4),0)),COLORYELLOW;
DRAWTEXT_FIX(REF(V,5)>0,0.313,0.41,0,CON2STR(REF(成交量,5),0)),COLORYELLOW;
DRAWTEXT_FIX(REF(V,6)>0,0.313,0.31,0,CON2STR(REF(成交量,6),0)),COLORYELLOW;
DRAWTEXT_FIX(REF(V,7)>0,0.313,0.21,0,CON2STR(REF(成交量,7),0)),COLORYELLOW;
DRAWTEXT_FIX(REF(V,8)>0,0.313,0.11,0,CON2STR(REF(成交量,8),0)),COLORYELLOW;
{====}
天:=SUM(成交量,用心算);
总量:SUM(成交量,天),NODRAW,COLORYELLOW;
LL1:=IF(总量>0,1,DRAWNULL);
LL2:=IF(REF(总量>0,1),1,DRAWNULL);
LL3:=IF(REF(总量>0,2),1,DRAWNULL);
LL4:=IF(REF(总量>0,3),1,DRAWNULL);
LL5:=IF(REF(总量>0,4),1,DRAWNULL);
LL6:=IF(REF(总量>0,5),1,DRAWNULL);
LL7:=IF(REF(总量>0,6),1,DRAWNULL);
LL8:=IF(REF(总量>0,7),1,DRAWNULL);
LL9:=IF(REF(总量>0,8),1,DRAWNULL);
{===}
DRAWTEXT_FIX(CONST(LL1)=DRAWNULL,0.392,0.91,0,CON2STR(总量,0)*LL1),COLORGREEN;
DRAWTEXT_FIX(CONST(LL1)=1,0.392,0.91,0,CON2STR(总量,0)*LL1),COLORRED;
DRAWTEXT_FIX(CONST(LL2)=DRAWNULL,0.392,0.81,0,CON2STR(REF(总量,1),0)*LL2),COLORGREEN;
DRAWTEXT_FIX(CONST(LL2)=1,0.392,0.81,0,CON2STR(REF(总量,1),0)*LL2),COLORRED;
DRAWTEXT_FIX(CONST(LL3)=DRAWNULL,0.392,0.71,0,CON2STR(REF(总量,2),0)*LL3),COLORGREEN;
DRAWTEXT_FIX(CONST(LL3)=1,0.392,0.71,0,CON2STR(REF(总量,2),0)*LL3),COLORRED;
DRAWTEXT_FIX(CONST(LL4)=DRAWNULL,0.392,0.61,0,CON2STR(REF(总量,3),0)*LL4),COLORGREEN;
DRAWTEXT_FIX(CONST(LL4)=1,0.392,0.61,0,CON2STR(REF(总量,3),0)*LL4),COLORRED;
DRAWTEXT_FIX(CONST(LL5)=DRAWNULL,0.392,0.51,0,CON2STR(REF(总量,4),0)*LL5),COLORGREEN;
DRAWTEXT_FIX(CONST(LL5)=1,0.392,0.51,0,CON2STR(REF(总量,4),0)*LL5),COLORRED;
DRAWTEXT_FIX(CONST(LL6)=DRAWNULL,0.392,0.41,0,CON2STR(REF(总量,5),0)*LL6),COLORGREEN;
DRAWTEXT_FIX(CONST(LL6)=1,0.392,0.41,0,CON2STR(REF(总量,5),0)*LL6),COLORRED;
DRAWTEXT_FIX(CONST(LL7)=DRAWNULL,0.392,0.31,0,CON2STR(REF(总量,6),0)*LL7),COLORGREEN;
DRAWTEXT_FIX(CONST(LL7)=1,0.392,0.31,0,CON2STR(REF(总量,6),0)*LL7),COLORRED;
DRAWTEXT_FIX(CONST(LL8)=DRAWNULL,0.392,0.21,0,CON2STR(REF(总量,7),0)*LL8),COLORGREEN;
DRAWTEXT_FIX(CONST(LL8)=1,0.392,0.21,0,CON2STR(REF(总量,7),0)*LL8),COLORRED;
DRAWTEXT_FIX(CONST(LL9)=DRAWNULL,0.392,0.11,0,CON2STR(REF(总量,8),0)*LL9),COLORGREEN;
DRAWTEXT_FIX(CONST(LL9)=1,0.392,0.11,0,CON2STR(REF(总量,8),0)*LL9),COLORRED;
{=====}
低价1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(O,2),' '), STRCAT(CON2STR(H,2),' ')), STRCAT(CON2STR(L,2),' ')), CON2STR(C,2)) ;
低价2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,1),2),' '),STRCAT(CON2STR(REF(H,1),2),' ')),STRCAT(CON2STR(REF(L,1),2),' ')),CON2STR(REF(C,1),2)) ;
低价3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,2),2),' '),STRCAT(CON2STR(REF(H,2),2),' ')),STRCAT(CON2STR(REF(L,2),2),' ')),CON2STR(REF(C,2),2)) ;
低价4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,3),2),' '),STRCAT(CON2STR(REF(H,3),2),' ')),STRCAT(CON2STR(REF(L,3),2),' ')),CON2STR(REF(C,3),2)) ;
低价5:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,4),2),' '),STRCAT(CON2STR(REF(H,4),2),' ')),STRCAT(CON2STR(REF(L,4),2),' ')),CON2STR(REF(C,4),2)) ;
低价6:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,5),2),' '),STRCAT(CON2STR(REF(H,5),2),' ')),STRCAT(CON2STR(REF(L,5),2),' ')),CON2STR(REF(C,5),2)) ;
低价7:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,6),2),' '),STRCAT(CON2STR(REF(H,6),2),' ')),STRCAT(CON2STR(REF(L,6),2),' ')),CON2STR(REF(C,6),2)) ;
低价8:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,7),2),' '),STRCAT(CON2STR(REF(H,7),2),' ')),STRCAT(CON2STR(REF(L,7),2),' ')),CON2STR(REF(C,7),2)) ;
低价9:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,8),2),' '),STRCAT(CON2STR(REF(H,8),2),' ')),STRCAT(CON2STR(REF(L,8),2),' ')),CON2STR(REF(C,8),2)) ;
中价1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(O,2),' '),STRCAT(CON2STR(H,2),' ')),STRCAT(CON2STR(L,2),' ')),CON2STR(C,2)) ;
中价2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,1),2),' '),STRCAT(CON2STR(REF(H,1),2),' ')),STRCAT(CON2STR(REF(L,1),2),' ')),CON2STR(REF(C,1),2)) ;
中价3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,2),2),' '),STRCAT(CON2STR(REF(H,2),2),' ')),STRCAT(CON2STR(REF(L,2),2),' ')),CON2STR(REF(C,2),2)) ;
中价4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,3),2),' '),STRCAT(CON2STR(REF(H,3),2),' ')),STRCAT(CON2STR(REF(L,3),2),' ')),CON2STR(REF(C,3),2)) ;
中价5:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,4),2),' '),STRCAT(CON2STR(REF(H,4),2),' ')),STRCAT(CON2STR(REF(L,4),2),' ')),CON2STR(REF(C,4),2)) ;
中价6:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,5),2),' '),STRCAT(CON2STR(REF(H,5),2),' ')),STRCAT(CON2STR(REF(L,5),2),' ')),CON2STR(REF(C,5),2)) ;
中价7:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,6),2),' '),STRCAT(CON2STR(REF(H,6),2),' ')),STRCAT(CON2STR(REF(L,6),2),' ')),CON2STR(REF(C,6),2)) ;
中价8:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,7),2),' '),STRCAT(CON2STR(REF(H,7),2),' ')),STRCAT(CON2STR(REF(L,7),2),' ')),CON2STR(REF(C,7),2)) ;
中价9:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,8),2),' '),STRCAT(CON2STR(REF(H,8),2),' ')),STRCAT(CON2STR(REF(L,8),2),' ')),CON2STR(REF(C,8),2)) ;
高价1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(O,2),' '), STRCAT(CON2STR(H,2),' ')), STRCAT(CON2STR(L,2),' ')), CON2STR(C,2)) ;
高价2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,1),2),' '),STRCAT(CON2STR(REF(H,1),2),' ')),STRCAT(CON2STR(REF(L,1),2),' ')),CON2STR(REF(C,1),2)) ;
高价3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,2),2),' '),STRCAT(CON2STR(REF(H,2),2),' ')),STRCAT(CON2STR(REF(L,2),2),' ')),CON2STR(REF(C,2),2)) ;
高价4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,3),2),' '),STRCAT(CON2STR(REF(H,3),2),' ')),STRCAT(CON2STR(REF(L,3),2),' ')),CON2STR(REF(C,3),2)) ;
高价5:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,4),2),' '),STRCAT(CON2STR(REF(H,4),2),' ')),STRCAT(CON2STR(REF(L,4),2),' ')),CON2STR(REF(C,4),2)) ;
高价6:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,5),2),' '),STRCAT(CON2STR(REF(H,5),2),' ')),STRCAT(CON2STR(REF(L,5),2),' ')),CON2STR(REF(C,5),2)) ;
高价7:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,6),2),' '),STRCAT(CON2STR(REF(H,6),2),' ')),STRCAT(CON2STR(REF(L,6),2),' ')),CON2STR(REF(C,6),2)) ;
高价8:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,7),2),' '),STRCAT(CON2STR(REF(H,7),2),' ')),STRCAT(CON2STR(REF(L,7),2),' ')),CON2STR(REF(C,7),2)) ;
高价9:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,8),2),' '),STRCAT(CON2STR(REF(H,8),2),' ')),STRCAT(CON2STR(REF(L,8),2),' ')),CON2STR(REF(C,8),2)) ;
指数1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(O,2),' '), STRCAT(CON2STR(H,2),' ')), STRCAT(CON2STR(L,2),' ')), CON2STR(C,2)) ;
指数2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,1),2),' '),STRCAT(CON2STR(REF(H,1),2),' ')),STRCAT(CON2STR(REF(L,1),2),' ')),CON2STR(REF(C,1),2)) ;
指数3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,2),2),' '),STRCAT(CON2STR(REF(H,2),2),' ')),STRCAT(CON2STR(REF(L,2),2),' ')),CON2STR(REF(C,2),2)) ;
指数4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,3),2),' '),STRCAT(CON2STR(REF(H,3),2),' ')),STRCAT(CON2STR(REF(L,3),2),' ')),CON2STR(REF(C,3),2)) ;
指数5:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,4),2),' '),STRCAT(CON2STR(REF(H,4),2),' ')),STRCAT(CON2STR(REF(L,4),2),' ')),CON2STR(REF(C,4),2)) ;
指数6:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,5),2),' '),STRCAT(CON2STR(REF(H,5),2),' ')),STRCAT(CON2STR(REF(L,5),2),' ')),CON2STR(REF(C,5),2)) ;
指数7:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,6),2),' '),STRCAT(CON2STR(REF(H,6),2),' ')),STRCAT(CON2STR(REF(L,6),2),' ')),CON2STR(REF(C,6),2)) ;
指数8:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,7),2),' '),STRCAT(CON2STR(REF(H,7),2),' ')),STRCAT(CON2STR(REF(L,7),2),' ')),CON2STR(REF(C,7),2)) ;
指数9:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(O,8),2),' '),STRCAT(CON2STR(REF(H,8),2),' ')),STRCAT(CON2STR(REF(L,8),2),' ')),CON2STR(REF(C,8),2)) ;
QQ1:=IF(CONST(H)<10,低价1,IF(CONST(H)<100,中价1,IF(CONST(H)<1000,高价1,指数1)));
QQ2:=IF(CONST(REF(H,1))<10,低价2,IF(CONST(REF(H,1))<100,中价2,IF(CONST(REF(H,1))<1000,高价2,指数2)));
QQ3:=IF(CONST(REF(H,2))<10,低价3,IF(CONST(REF(H,2))<100,中价3,IF(CONST(REF(H,2))<1000,高价3,指数3)));
QQ4:=IF(CONST(REF(H,3))<10,低价4,IF(CONST(REF(H,3))<100,中价4,IF(CONST(REF(H,3))<1000,高价4,指数4)));
QQ5:=IF(CONST(REF(H,4))<10,低价5,IF(CONST(REF(H,4))<100,中价5,IF(CONST(REF(H,4))<1000,高价5,指数5)));
QQ6:=IF(CONST(REF(H,5))<10,低价6,IF(CONST(REF(H,5))<100,中价6,IF(CONST(REF(H,5))<1000,高价6,指数6)));
QQ7:=IF(CONST(REF(H,6))<10,低价7,IF(CONST(REF(H,6))<100,中价7,IF(CONST(REF(H,6))<1000,高价7,指数7)));
QQ8:=IF(CONST(REF(H,7))<10,低价8,IF(CONST(REF(H,7))<100,中价8,IF(CONST(REF(H,7))<1000,高价8,指数8)));
QQ9:=IF(CONST(REF(H,8))<10,低价9,IF(CONST(REF(H,8))<100,中价9,IF(CONST(REF(H,8))<1000,高价9,指数9)));
DRAWTEXT_FIX(C>0,0.078,0.91,0,QQ1);
DRAWTEXT_FIX(C>0,0.078,0.81,0,QQ2);
DRAWTEXT_FIX(C>0,0.078,0.71,0,QQ3);
DRAWTEXT_FIX(C>0,0.078,0.61,0,QQ4);
DRAWTEXT_FIX(C>0,0.078,0.51,0,QQ5);
DRAWTEXT_FIX(C>0,0.078,0.41,0,QQ6);
DRAWTEXT_FIX(C>0,0.078,0.31,0,QQ7);
DRAWTEXT_FIX(C>0,0.078,0.21,0,QQ8);
DRAWTEXT_FIX(C>0,0.078,0.11,0,QQ9);
{=====}
均中:=(H+L+C)/3;{3}
测开:=均中+(REF(H,1)-REF(L,1));{1}
测高:=均中*2-L;{2}
测低:=均中*2-H;{4}
测收:=均中-(REF(H,1)-REF(L,1));{5}
{===}
DRAWTEXT_FIX(C>0,0.594,0.91,0,CON2STR(均中,2)),COLORYELLOW;
DRAWTEXT_FIX(C>0,0.594,0.81,0,CON2STR(REF(均中,1),2)),COLORYELLOW;
DRAWTEXT_FIX(C>0,0.594,0.71,0,CON2STR(REF(均中,2),2)),COLORYELLOW;
DRAWTEXT_FIX(C>0,0.594,0.61,0,CON2STR(REF(均中,3),2)),COLORYELLOW;
DRAWTEXT_FIX(C>0,0.594,0.51,0,CON2STR(REF(均中,4),2)),COLORYELLOW;
DRAWTEXT_FIX(C>0,0.594,0.41,0,CON2STR(REF(均中,5),2)),COLORYELLOW;
DRAWTEXT_FIX(C>0,0.594,0.31,0,CON2STR(REF(均中,6),2)),COLORYELLOW;
DRAWTEXT_FIX(C>0,0.594,0.21,0,CON2STR(REF(均中,7),2)),COLORYELLOW;
DRAWTEXT_FIX(C>0,0.594,0.11,0,CON2STR(REF(均中,8),2)),COLORYELLOW;
{===}
测低1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(测开,2),' '),STRCAT(CON2STR(测高,2),' ')),STRCAT(CON2STR(测低,2),' ')),CON2STR(测收,2)) ;
测低2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,1),2),' '),STRCAT(CON2STR(REF(测高,1),2),' ')),STRCAT(CON2STR(REF(测低,1),2),' ')),CON2STR(REF(测收,1),2)) ;
测低3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,2),2),' '),STRCAT(CON2STR(REF(测高,2),2),' ')),STRCAT(CON2STR(REF(测低,2),2),' ')),CON2STR(REF(测收,2),2)) ;
测低4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,3),2),' '),STRCAT(CON2STR(REF(测高,3),2),' ')),STRCAT(CON2STR(REF(测低,3),2),' ')),CON2STR(REF(测收,3),2)) ;
测低5:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,4),2),' '),STRCAT(CON2STR(REF(测高,4),2),' ')),STRCAT(CON2STR(REF(测低,4),2),' ')),CON2STR(REF(测收,4),2)) ;
测低6:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,5),2),' '),STRCAT(CON2STR(REF(测高,5),2),' ')),STRCAT(CON2STR(REF(测低,5),2),' ')),CON2STR(REF(测收,5),2)) ;
测低7:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,6),2),' '),STRCAT(CON2STR(REF(测高,6),2),' ')),STRCAT(CON2STR(REF(测低,6),2),' ')),CON2STR(REF(测收,6),2)) ;
测低8:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,7),2),' '),STRCAT(CON2STR(REF(测高,7),2),' ')),STRCAT(CON2STR(REF(测低,7),2),' ')),CON2STR(REF(测收,7),2)) ;
测低9:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,8),2),' '),STRCAT(CON2STR(REF(测高,8),2),' ')),STRCAT(CON2STR(REF(测低,8),2),' ')),CON2STR(REF(测收,8),2)) ;
测中1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(测开,2),' '),STRCAT(CON2STR(测高,2),' ')),STRCAT(CON2STR(测低,2),' ')),CON2STR(测收,2)) ;
测中2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,1),2),' '),STRCAT(CON2STR(REF(测高,1),2),' ')),STRCAT(CON2STR(REF(测低,1),2),' ')),CON2STR(REF(测收,1),2)) ;
测中3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,2),2),' '),STRCAT(CON2STR(REF(测高,2),2),' ')),STRCAT(CON2STR(REF(测低,2),2),' ')),CON2STR(REF(测收,2),2)) ;
测中4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,3),2),' '),STRCAT(CON2STR(REF(测高,3),2),' ')),STRCAT(CON2STR(REF(测低,3),2),' ')),CON2STR(REF(测收,3),2)) ;
测中5:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,4),2),' '),STRCAT(CON2STR(REF(测高,4),2),' ')),STRCAT(CON2STR(REF(测低,4),2),' ')),CON2STR(REF(测收,4),2)) ;
测中6:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,5),2),' '),STRCAT(CON2STR(REF(测高,5),2),' ')),STRCAT(CON2STR(REF(测低,5),2),' ')),CON2STR(REF(测收,5),2)) ;
测中7:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,6),2),' '),STRCAT(CON2STR(REF(测高,6),2),' ')),STRCAT(CON2STR(REF(测低,6),2),' ')),CON2STR(REF(测收,6),2)) ;
测中8:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,7),2),' '),STRCAT(CON2STR(REF(测高,7),2),' ')),STRCAT(CON2STR(REF(测低,7),2),' ')),CON2STR(REF(测收,7),2)) ;
测中9:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,8),2),' '),STRCAT(CON2STR(REF(测高,8),2),' ')),STRCAT(CON2STR(REF(测低,8),2),' ')),CON2STR(REF(测收,8),2)) ;
测高1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(测开,2),' '),STRCAT(CON2STR(测高,2),' ')),STRCAT(CON2STR(测低,2),' ')),CON2STR(测收,2)) ;
测高2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,1),2),' '),STRCAT(CON2STR(REF(测高,1),2),' ')),STRCAT(CON2STR(REF(测低,1),2),' ')),CON2STR(REF(测收,1),2)) ;
测高3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,2),2),' '),STRCAT(CON2STR(REF(测高,2),2),' ')),STRCAT(CON2STR(REF(测低,2),2),' ')),CON2STR(REF(测收,2),2)) ;
测高4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,3),2),' '),STRCAT(CON2STR(REF(测高,3),2),' ')),STRCAT(CON2STR(REF(测低,3),2),' ')),CON2STR(REF(测收,3),2)) ;
测高5:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,4),2),' '),STRCAT(CON2STR(REF(测高,4),2),' ')),STRCAT(CON2STR(REF(测低,4),2),' ')),CON2STR(REF(测收,4),2)) ;
测高6:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,5),2),' '),STRCAT(CON2STR(REF(测高,5),2),' ')),STRCAT(CON2STR(REF(测低,5),2),' ')),CON2STR(REF(测收,5),2)) ;
测高7:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,6),2),' '),STRCAT(CON2STR(REF(测高,6),2),' ')),STRCAT(CON2STR(REF(测低,6),2),' ')),CON2STR(REF(测收,6),2)) ;
测高8:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,7),2),' '),STRCAT(CON2STR(REF(测高,7),2),' ')),STRCAT(CON2STR(REF(测低,7),2),' ')),CON2STR(REF(测收,7),2)) ;
测高9:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,8),2),' '),STRCAT(CON2STR(REF(测高,8),2),' ')),STRCAT(CON2STR(REF(测低,8),2),' ')),CON2STR(REF(测收,8),2)) ;
测指1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(测开,2),' '),STRCAT(CON2STR(测高,2),' ')),STRCAT(CON2STR(测低,2),' ')),CON2STR(测收,2)) ;
测指2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,1),2),' '),STRCAT(CON2STR(REF(测高,1),2),' ')),STRCAT(CON2STR(REF(测低,1),2),' ')),CON2STR(REF(测收,1),2)) ;
测指3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,2),2),' '),STRCAT(CON2STR(REF(测高,2),2),' ')),STRCAT(CON2STR(REF(测低,2),2),' ')),CON2STR(REF(测收,2),2)) ;
测指4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,3),2),' '),STRCAT(CON2STR(REF(测高,3),2),' ')),STRCAT(CON2STR(REF(测低,3),2),' ')),CON2STR(REF(测收,3),2)) ;
测指5:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,4),2),' '),STRCAT(CON2STR(REF(测高,4),2),' ')),STRCAT(CON2STR(REF(测低,4),2),' ')),CON2STR(REF(测收,4),2)) ;
测指6:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,5),2),' '),STRCAT(CON2STR(REF(测高,5),2),' ')),STRCAT(CON2STR(REF(测低,5),2),' ')),CON2STR(REF(测收,5),2)) ;
测指7:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,6),2),' '),STRCAT(CON2STR(REF(测高,6),2),' ')),STRCAT(CON2STR(REF(测低,6),2),' ')),CON2STR(REF(测收,6),2)) ;
测指8:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,7),2),' '),STRCAT(CON2STR(REF(测高,7),2),' ')),STRCAT(CON2STR(REF(测低,7),2),' ')),CON2STR(REF(测收,7),2)) ;
测指9:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测开,8),2),' '),STRCAT(CON2STR(REF(测高,8),2),' ')),STRCAT(CON2STR(REF(测低,8),2),' ')),CON2STR(REF(测收,8),2)) ;
测Q1:=IF(CONST(H)<10,测低1,IF(CONST(H)<100,测中1,IF(CONST(H)<1000,测高1,测指1)));
测Q2:=IF(CONST(H)<10,测低2,IF(CONST(H)<100,测中2,IF(CONST(H)<1000,测高2,测指2)));
测Q3:=IF(CONST(H)<10,测低3,IF(CONST(H)<100,测中3,IF(CONST(H)<1000,测高3,测指3)));
测Q4:=IF(CONST(H)<10,测低4,IF(CONST(H)<100,测中4,IF(CONST(H)<1000,测高4,测指4)));
测Q5:=IF(CONST(H)<10,测低5,IF(CONST(H)<100,测中5,IF(CONST(H)<1000,测高5,测指5)));
测Q6:=IF(CONST(H)<10,测低6,IF(CONST(H)<100,测中6,IF(CONST(H)<1000,测高6,测指6)));
测Q7:=IF(CONST(H)<10,测低7,IF(CONST(H)<100,测中7,IF(CONST(H)<1000,测高7,测指7)));
测Q8:=IF(CONST(H)<10,测低8,IF(CONST(H)<100,测中8,IF(CONST(H)<1000,测高8,测指8)));
测Q9:=IF(CONST(H)<10,测低9,IF(CONST(H)<100,测中9,IF(CONST(H)<1000,测高9,测指9)));
DRAWTEXT_FIX(C>0,0.476,0.91,0,测Q1);
DRAWTEXT_FIX(C>0,0.476,0.81,0,测Q2);
DRAWTEXT_FIX(C>0,0.476,0.71,0,测Q3);
DRAWTEXT_FIX(C>0,0.476,0.61,0,测Q4);
DRAWTEXT_FIX(C>0,0.476,0.51,0,测Q5);
DRAWTEXT_FIX(C>0,0.476,0.41,0,测Q6);
DRAWTEXT_FIX(C>0,0.476,0.31,0,测Q7);
DRAWTEXT_FIX(C>0,0.476,0.21,0,测Q8);
DRAWTEXT_FIX(C>0,0.476,0.11,0,测Q9);
{====}
高减昨收累和:=SUM(高减昨收,0),NODRAW,COLORWHITE;
昨收减低累和:=SUM(昨收减低,0),NODRAW,COLORYELLOW;
高减开累和:=SUM(高减开,0),NODRAW,COLORWHITE;
开减低累和:=SUM(开减低,0),NODRAW,COLORYELLOW;
SSSW1:=MAX(MAX(高减昨收累和,昨收减低累和),MAX(高减开累和,开减低累和));
{====}
高减昨A1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(高减昨收累和,2),' '),STRCAT(CON2STR(昨收减低累和,2),' ')),STRCAT(CON2STR(高减开累和,2),' ')),CON2STR(开减低累和,2)) ;
高减昨B1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,1),2),' '),STRCAT(CON2STR(REF(昨收减低累和,1),2),' ')),STRCAT(CON2STR(REF(高减开累和,1),2),' ')),CON2STR(REF(开减低累和,1),2)) ;
高减昨C1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,2),2),' '),STRCAT(CON2STR(REF(昨收减低累和,2),2),' ')),STRCAT(CON2STR(REF(高减开累和,2),2),' ')),CON2STR(REF(开减低累和,2),2)) ;
高减昨D1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,3),2),' '),STRCAT(CON2STR(REF(昨收减低累和,3),2),' ')),STRCAT(CON2STR(REF(高减开累和,3),2),' ')),CON2STR(REF(开减低累和,3),2)) ;
高减昨E1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,4),2),' '),STRCAT(CON2STR(REF(昨收减低累和,4),2),' ')),STRCAT(CON2STR(REF(高减开累和,4),2),' ')),CON2STR(REF(开减低累和,4),2)) ;
高减昨F1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,5),2),' '),STRCAT(CON2STR(REF(昨收减低累和,5),2),' ')),STRCAT(CON2STR(REF(高减开累和,5),2),' ')),CON2STR(REF(开减低累和,5),2)) ;
高减昨G1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,6),2),' '),STRCAT(CON2STR(REF(昨收减低累和,6),2),' ')),STRCAT(CON2STR(REF(高减开累和,6),2),' ')),CON2STR(REF(开减低累和,6),2)) ;
高减昨H1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,7),2),' '),STRCAT(CON2STR(REF(昨收减低累和,7),2),' ')),STRCAT(CON2STR(REF(高减开累和,7),2),' ')),CON2STR(REF(开减低累和,7),2)) ;
高减昨Y1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,8),2),' '),STRCAT(CON2STR(REF(昨收减低累和,8),2),' ')),STRCAT(CON2STR(REF(高减开累和,8),2),' ')),CON2STR(REF(开减低累和,8),2)) ;
高减昨A2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(高减昨收累和,2),' '),STRCAT(CON2STR(昨收减低累和,2),' ')),STRCAT(CON2STR(高减开累和,2),' ')),CON2STR(开减低累和,2)) ;
高减昨B2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,1),2),' '),STRCAT(CON2STR(REF(昨收减低累和,1),2),' ')),STRCAT(CON2STR(REF(高减开累和,1),2),' ')),CON2STR(REF(开减低累和,1),2)) ;
高减昨C2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,2),2),' '),STRCAT(CON2STR(REF(昨收减低累和,2),2),' ')),STRCAT(CON2STR(REF(高减开累和,2),2),' ')),CON2STR(REF(开减低累和,2),2)) ;
高减昨D2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,3),2),' '),STRCAT(CON2STR(REF(昨收减低累和,3),2),' ')),STRCAT(CON2STR(REF(高减开累和,3),2),' ')),CON2STR(REF(开减低累和,3),2)) ;
高减昨E2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,4),2),' '),STRCAT(CON2STR(REF(昨收减低累和,4),2),' ')),STRCAT(CON2STR(REF(高减开累和,4),2),' ')),CON2STR(REF(开减低累和,4),2)) ;
高减昨F2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,5),2),' '),STRCAT(CON2STR(REF(昨收减低累和,5),2),' ')),STRCAT(CON2STR(REF(高减开累和,5),2),' ')),CON2STR(REF(开减低累和,5),2)) ;
高减昨G2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,6),2),' '),STRCAT(CON2STR(REF(昨收减低累和,6),2),' ')),STRCAT(CON2STR(REF(高减开累和,6),2),' ')),CON2STR(REF(开减低累和,6),2)) ;
高减昨H2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,7),2),' '),STRCAT(CON2STR(REF(昨收减低累和,7),2),' ')),STRCAT(CON2STR(REF(高减开累和,7),2),' ')),CON2STR(REF(开减低累和,7),2)) ;
高减昨Y2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,8),2),' '),STRCAT(CON2STR(REF(昨收减低累和,8),2),' ')),STRCAT(CON2STR(REF(高减开累和,8),2),' ')),CON2STR(REF(开减低累和,8),2)) ;
高减昨A3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(高减昨收累和,2),' '),STRCAT(CON2STR(昨收减低累和,2),' ')),STRCAT(CON2STR(高减开累和,2),' ')),CON2STR(开减低累和,2)) ;
高减昨B3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,1),2),' '),STRCAT(CON2STR(REF(昨收减低累和,1),2),' ')),STRCAT(CON2STR(REF(高减开累和,1),2),' ')),CON2STR(REF(开减低累和,1),2)) ;
高减昨C3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,2),2),' '),STRCAT(CON2STR(REF(昨收减低累和,2),2),' ')),STRCAT(CON2STR(REF(高减开累和,2),2),' ')),CON2STR(REF(开减低累和,2),2)) ;
高减昨D3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,3),2),' '),STRCAT(CON2STR(REF(昨收减低累和,3),2),' ')),STRCAT(CON2STR(REF(高减开累和,3),2),' ')),CON2STR(REF(开减低累和,3),2)) ;
高减昨E3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,4),2),' '),STRCAT(CON2STR(REF(昨收减低累和,4),2),' ')),STRCAT(CON2STR(REF(高减开累和,4),2),' ')),CON2STR(REF(开减低累和,4),2)) ;
高减昨F3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,5),2),' '),STRCAT(CON2STR(REF(昨收减低累和,5),2),' ')),STRCAT(CON2STR(REF(高减开累和,5),2),' ')),CON2STR(REF(开减低累和,5),2)) ;
高减昨G3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,6),2),' '),STRCAT(CON2STR(REF(昨收减低累和,6),2),' ')),STRCAT(CON2STR(REF(高减开累和,6),2),' ')),CON2STR(REF(开减低累和,6),2)) ;
高减昨H3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,7),2),' '),STRCAT(CON2STR(REF(昨收减低累和,7),2),' ')),STRCAT(CON2STR(REF(高减开累和,7),2),' ')),CON2STR(REF(开减低累和,7),2)) ;
高减昨Y3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,8),2),' '),STRCAT(CON2STR(REF(昨收减低累和,8),2),' ')),STRCAT(CON2STR(REF(高减开累和,8),2),' ')),CON2STR(REF(开减低累和,8),2)) ;
高减昨A4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(高减昨收累和,2),' '),STRCAT(CON2STR(昨收减低累和,2),' ')),STRCAT(CON2STR(高减开累和,2),' ')),CON2STR(开减低累和,2)) ;
高减昨B4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,1),2),' '),STRCAT(CON2STR(REF(昨收减低累和,1),2),' ')),STRCAT(CON2STR(REF(高减开累和,1),2),' ')),CON2STR(REF(开减低累和,1),2)) ;
高减昨C4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,2),2),' '),STRCAT(CON2STR(REF(昨收减低累和,2),2),' ')),STRCAT(CON2STR(REF(高减开累和,2),2),' ')),CON2STR(REF(开减低累和,2),2)) ;
高减昨D4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,3),2),' '),STRCAT(CON2STR(REF(昨收减低累和,3),2),' ')),STRCAT(CON2STR(REF(高减开累和,3),2),' ')),CON2STR(REF(开减低累和,3),2)) ;
高减昨E4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,4),2),' '),STRCAT(CON2STR(REF(昨收减低累和,4),2),' ')),STRCAT(CON2STR(REF(高减开累和,4),2),' ')),CON2STR(REF(开减低累和,4),2)) ;
高减昨F4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,5),2),' '),STRCAT(CON2STR(REF(昨收减低累和,5),2),' ')),STRCAT(CON2STR(REF(高减开累和,5),2),' ')),CON2STR(REF(开减低累和,5),2)) ;
高减昨G4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,6),2),' '),STRCAT(CON2STR(REF(昨收减低累和,6),2),' ')),STRCAT(CON2STR(REF(高减开累和,6),2),' ')),CON2STR(REF(开减低累和,6),2)) ;
高减昨H4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,7),2),' '),STRCAT(CON2STR(REF(昨收减低累和,7),2),' ')),STRCAT(CON2STR(REF(高减开累和,7),2),' ')),CON2STR(REF(开减低累和,7),2)) ;
高减昨Y4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(高减昨收累和,8),2),' '),STRCAT(CON2STR(REF(昨收减低累和,8),2),' ')),STRCAT(CON2STR(REF(高减开累和,8),2),' ')),CON2STR(REF(开减低累和,8),2)) ;
KK1:=IF(CONST(SSSW1)<10,高减昨A3,IF(CONST(SSSW1)<100,高减昨A2,IF(CONST(SSSW1)<1000,高减昨A1,高减昨A4)));
KK2:=IF(CONST(REF(SSSW1,1))<10,高减昨B3,IF(CONST(REF(SSSW1,1))<100,高减昨B2,IF(CONST(SSSW1)<1000,高减昨B1,高减昨B4)));
KK3:=IF(CONST(REF(SSSW1,2))<10,高减昨C3,IF(CONST(REF(SSSW1,2))<100,高减昨C2,IF(CONST(SSSW1)<1000,高减昨C1,高减昨C4)));
KK4:=IF(CONST(REF(SSSW1,3))<10,高减昨D3,IF(CONST(REF(SSSW1,3))<100,高减昨D2,IF(CONST(SSSW1)<1000,高减昨D1,高减昨D4)));
KK5:=IF(CONST(REF(SSSW1,4))<10,高减昨E3,IF(CONST(REF(SSSW1,4))<100,高减昨E2,IF(CONST(SSSW1)<1000,高减昨E1,高减昨E4)));
KK6:=IF(CONST(REF(SSSW1,5))<10,高减昨F3,IF(CONST(REF(SSSW1,5))<100,高减昨F2,IF(CONST(SSSW1)<1000,高减昨F1,高减昨F4)));
KK7:=IF(CONST(REF(SSSW1,6))<10,高减昨G3,IF(CONST(REF(SSSW1,6))<100,高减昨G2,IF(CONST(SSSW1)<1000,高减昨G1,高减昨G4)));
KK8:=IF(CONST(REF(SSSW1,7))<10,高减昨H3,IF(CONST(REF(SSSW1,7))<100,高减昨H2,IF(CONST(SSSW1)<1000,高减昨H1,高减昨H4)));
KK9:=IF(CONST(REF(SSSW1,8))<10,高减昨Y3,IF(CONST(REF(SSSW1,8))<100,高减昨Y2,IF(CONST(SSSW1)<1000,高减昨Y1,高减昨Y4)));
DRAWTEXT_FIX(C>0,0.765,0.91,0,KK1),COLORWHITE;
DRAWTEXT_FIX(C>0,0.765,0.81,0,KK2),COLORWHITE;
DRAWTEXT_FIX(C>0,0.765,0.71,0,KK3),COLORWHITE;
DRAWTEXT_FIX(C>0,0.765,0.61,0,KK4),COLORWHITE;
DRAWTEXT_FIX(C>0,0.765,0.51,0,KK5),COLORWHITE;
DRAWTEXT_FIX(C>0,0.765,0.41,0,KK6),COLORWHITE;
DRAWTEXT_FIX(C>0,0.765,0.31,0,KK7),COLORWHITE;
DRAWTEXT_FIX(C>0,0.765,0.21,0,KK8),COLORWHITE;
DRAWTEXT_FIX(C>0,0.765,0.11,0,KK9),COLORWHITE;

通达信表格指标公式

 

相关文章