在线检测未来函数

通达信成交量真假指标公式

来源:Internet,编辑:股旁网,2017-06-06

量:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买量:=IF(CLOSE>OPEN,量*(HIGH-LOW),IF(CLOSE<OPEN,量*((HIGH-OPEN)+ (CLOSE-LOW)),VOL/2));
卖量:=(IF(CLOSE>OPEN,0-量*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0- 量*(HIGH-LOW),0-VOL/2)))*-1;
总量:=买量+卖量;
净量:买量-卖量,LINETHICK0;
MAA:=MA( CLOSE ,2) ;
STICKLINE(买量>0,0,买量,3,0),COLOR000099;
STICKLINE(净量>0,0,净量,0.1,0),COLOR00FFFF;
STICKLINE(V>=2*REF(V,1),1,总量,4,1),COLOR0000FF;
STICKLINE(C>MAA,总量,1,4,1 ),COLOR00FFFF;
STICKLINE(C<MAA,总量,1,4,1 ),COLORFF00FF;
STICKLINE(净量<0,1,总量,4,1),COLORFFFF00;
STICKLINE(C<MAA AND 净量>0,净量,1,4,1 ),COLOR0000FF;
STICKLINE(V>=2*REF(V,1),1,总量,4,1),COLOR0000FF;
STICKLINE(买量>0,0,买量,3,0),COLOR000099;
STICKLINE(买量>0,0,买量,2,0),COLOR0000AA;
STICKLINE(买量>0,0,买量,1,0),COLOR0000FF;
STICKLINE(买量>0,0,买量,0.1,0),COLORCC00FF;
STICKLINE(净量>0,0,净量,3,0),COLOR0033FF;
STICKLINE(净量>0,0,净量,2,0),COLOR0077FF;
STICKLINE(净量>0,0,净量,1,0),COLOR00BBFF;
STICKLINE(净量>0,0,净量,0.1,0),COLOR00FFFF;
STICKLINE(C<MAA AND 净量>0,净量,0,3,0 ),COLOR777777;
STICKLINE(C<MAA AND 净量>0,净量,0,2,0 ),COLOR999999;
STICKLINE(C<MAA AND 净量>0,净量,0,1,0 ),COLORBBBBBB;
STICKLINE(C<MAA AND 净量>0,净量,0,0.1,0 ),COLORFFFFFF;
MA5:=MA(VOL,5);
MA10:=MA(VOL,10);
MA20:=MA(VOL,20);
净买量金色:0,COLORYELLOW;买量红色:0,COLORRED;短买灰色:0,COLORLIGRAY;
DRAWTEXT(CROSS(净量,0),0-0,'买'),COLORFF00FF;
DRAWTEXT(CROSS(0,净量),0-0,'减仓'),COLORGREEN;

通达信成交量真假指标公式

 

相关文章