在线检测未来函数

通达信量价对比指标公式

来源:Internet,编辑:股旁网,2017-06-07

价量同升:=C>REF(C,1) AND V>REF(V,1);
价量背离1:=C<REF(C,1) AND V>REF(V,1);
价量背离2:=C>=REF(C,1) AND V<REF(V,1);
价量同降:=C<REF(C,1) AND V<REF(V,1);
DRAWRECTREL(10,10,990,990,RGB(55,55,0));
DRAWRECTREL(10,500,990,500,255);
DRAWRECTREL(500,10,500,990,255);
DRAWTEXT_FIX(价量同升,0.9,0.9,1,'价量同升且量较小,低买');
DRAWTEXT_FIX(价量同降,0.2,0.9,1,'价量同降,清仓');
DRAWTEXT_FIX(价量背离1,0.2,0.7,1,'价量背离,清仓');
DRAWTEXT_FIX(价量背离2,0.9,0.2,1,'价量背离,观望');
DRAWTEXT_FIX(价量同升,0.2,0.2,1,'价量同升且量大,持股');
DRAWNUMBER_FIX(CURRBARSCOUNT=1 AND 价量同升,0.98,0.9,1,C),COLORRED;
DRAWNUMBER_FIX(CURRBARSCOUNT=1 AND 价量同降,0.28,0.9,1,C),COLORGREEN;
DRAWNUMBER_FIX(CURRBARSCOUNT=1 AND 价量同升,0.28,0.20,1,C),COLORRED;
DRAWNUMBER_FIX(CURRBARSCOUNT=1 AND 价量背离1,0.28,0.7,1,C),COLORGREEN;
DRAWNUMBER_FIX(CURRBARSCOUNT=1 AND 价量背离2,0.98,0.20,1,C),COLORRED;
涨幅1:=(C-REF(C,1))/REF(C,1);
量涨幅1:=(V-REF(V,1))/REF(V,1);
价涨幅:SUM(价涨幅1,0),COLORRED,LINETHICK2,LINESTICK;
量涨幅:=SUM(量涨幅1,0);
量涨幅2:=EMA(量涨幅,50)/EMA(价涨幅,20);
量涨幅线:量涨幅/量涨幅2,COLORBLUE,LINETHICK2,LINESTICK;

通达信量价对比指标公式

 

相关文章