在线检测未来函数

通达信双均线买入卖出主图指标公式

来源:Internet,编辑:股旁网,2017-06-08

M1:=13;
M2:=5;
MA1:MA(CLOSE,M1);{设定均线}
MA2:=MA(CLOSE,M2);{设定均线}
DRAWKLINE(H,O,L,C);{写K线}
STICKLINE(MA1>=REF(MA1,1),H,L,0,0),COLOR0000FF;{均线上行,标记影线}
STICKLINE(MA1>=REF(MA1,1) AND (C>=O),O,C,3,1),COLOR0000FF;{均线上行,标记阳线}
STICKLINE(MA1>=REF(MA1,1)AND (C<=O),O,C,3,0),COLOR0000FF;{均线上行,标记阴线}
STICKLINE(MA1>=REF(MA1,1) AND MA2<=REF(MA2,1) AND COUNT(MA1>=REF(MA1,1),20)>13,H,L,0,0),COLOR00FFFF;{做顶,标记影线}
STICKLINE(MA1>=REF(MA1,1) AND MA2<=REF(MA2,1) AND COUNT(MA1>=REF(MA1,1),20)>13 AND (C>=O),O,C,3,1),COLOR00FFFF;{做顶,标记阳线}
STICKLINE(MA1>=REF(MA1,1) AND MA2<=REF(MA2,1) AND COUNT(MA1>=REF(MA1,1),20)>13 AND (C<=O),O,C,3,0),COLOR00FFFF;{做顶,标记阴线}
STICKLINE(MA1<REF(MA1,1),H,L,0,0),COLOR00FF00;{均线下行,标记影线}
STICKLINE(MA1<REF(MA1,1) AND (C>=O),O,C,3,1),COLOR00FF00;{均线下行,标记阳线}
STICKLINE(MA1<REF(MA1,1) AND (C<=O),O,C,3,0),COLOR00FF00;{均线下行,标记阴线};
STICKLINE(MA1<=REF(MA1,1) AND MA2>=REF(MA2,1) AND COUNT(MA1<=REF(MA1,1),30)>15,H,L,0,0),COLORFF00FF;{做底,标记影线}
STICKLINE(MA1<=REF(MA1,1) AND MA2>=REF(MA2,1) AND COUNT(MA1<=REF(MA1,1),30)>15 AND (C>=O),O,C,3,1),COLORFF00FF;{做底,标记阳线}
STICKLINE(MA1<=REF(MA1,1) AND MA2>=REF(MA2,1) AND COUNT(MA1<=REF(MA1,1),30)>15 AND (C<=O),O,C,3,0),COLORFF00FF;{做底,标记阴线};

通达信双均线买入卖出主图指标公式

 

相关文章