在线检测未来函数

通达信量能彩图指标公式

来源:Internet,编辑:股旁网,2017-06-08

M1:=5;
M2:=10;
M3:=60;
M4:=250;
VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
{STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,-1,-1),COLOR00C0C0;}
VOLUME:=VOL,VOLSTICK;
MAVOL1:=SMA(MA(VOLUME,3),M1,1);
MAVOL2:=SMA(MA(VOLUME,3),M2,1);
MAVOL3:=SMA(MA(VOLUME,3),M3,1);
MAVOL4:=SMA(MA(VOLUME,3),M4,1);
DRAWBAND(MAVOL3,RGB(120,0,0),MAVOL4,RGB(0,55,0));
DRAWBAND(MAVOL2,RGB(170,0,0),MAVOL3,RGB(0,155,0));
DRAWBAND(MAVOL1,RGB(255,0,0),MAVOL2,RGB(0,255,0));
{VOLUME1:VOL,VOLSTICK;}
MA1:SMA(MA(VOLUME,3),M1,1),COLORYELLOW;
MA2:SMA(MA(VOLUME,3),M2,1),COLORMAGENTA;
MA3:SMA(MA(VOLUME,3),M3,1),COLORRED;
MA4:SMA(MA(VOLUME,3),M4,1),COLORBLUE;
IF(MA1<=REF(MA1,1),MA1,DRAWNULL),COLOR00FF00;
IF(MA2<=REF(MA2,1),MA2,DRAWNULL),COLOR33FF33,;
IF(MA3<=REF(MA3,1),MA3,DRAWNULL),COLOR44FF44;
IF(MA4<=REF(MA4,1),MA4,DRAWNULL),COLOR55FF55;
{DRAWICON(CROSS(MAVOL1,MAVOL3),REF(MAVOL1,1),1); {10日均量线上穿60日均量线做记号}}
{DRAWICON(CROSS(MAVOL3,MAVOL1),REF(MAVOL1,1),2); {10日均量线下穿60日均量线做记号}};

通达信量能彩图指标公式

 

相关文章