在线检测未来函数

通达信均线离差的平滑版指标公式

来源:Internet,编辑:股旁网,2017-06-08

N:=9;
MID:=SMA(C,N,1);
MA0:=MA(MID,30);
MA1:=MA(MID,1);
A1:=MA1-MA0;
MA2:=MA(MID,2);
A2:=MA2-MA0;
MA3:=MA(MID,3);
A3:=MA3-MA0;
MA4:=MA(MID,4);
A4:=MA4-MA0;
MA5:=MA(MID,5);
A5:=MA5-MA0;
MA6:=MA(MID,6);
A6:=MA6-MA0;
MA7:=MA(MID,7);
A7:=MA7-MA0;
MA8:=MA(MID,8);
A8:=MA8-MA0;
MA9:=MA(MID,9);
A9:=MA9-MA0;
MA10:=MA(MID,10);
A10:=MA10-MA0;
MA11:=MA(MID,11);
A11:=MA11-MA0;
MA12:=MA(MID,12);
A12:=MA12-MA0;
MA13:=MA(MID,13);
A13:=MA13-MA0;
MA14:=MA(MID,14);
A14:=MA14-MA0;
MA15:=MA(MID,15);
A15:=MA15-MA0;
MA16:=MA(MID,16);
A16:=MA16-MA0;
MA17:=MA(MID,17);
A17:=MA17-MA0;
MA18:=MA(MID,18);
A18:=MA18-MA0;
MA19:=MA(MID,19);
A19:=MA19-MA0;
MA20:=MA(MID,20);
A20:=MA20-MA0;
MA21:=MA(MID,21);
A21:=MA21-MA0;
MA22:=MA(MID,22);
A22:=MA22-MA0;
MA23:=MA(MID,23);
A23:=MA23-MA0;
MA24:=MA(MID,24);
A24:=MA24-MA0;
MA25:=MA(MID,25);
A25:=MA25-MA0;
MA26:=MA(MID,26);
A26:=MA26-MA0;
MA27:=MA(MID,27);
A27:=MA27-MA0;
MA28:=MA(MID,28);
A28:=MA28-MA0;
MA29:=MA(MID,29);
A29:=MA29-MA0;
MA30:=MA(MID,30);
A30:=MA30-MA0;
MA31:=MA(MID,31);
A31:=MA31-MA0;
MA32:=MA(MID,32);
A32:=MA32-MA0;
MA33:=MA(MID,33);
A33:=MA33-MA0;
MA34:=MA(MID,34);
A34:=MA34-MA0;
MA35:=MA(MID,35);
A35:=MA35-MA0;
MA36:=MA(MID,36);
A36:=MA36-MA0;
MA37:=MA(MID,37);
A37:=MA37-MA0;
MA38:=MA(MID,38);
A38:=MA38-MA0;
MA39:=MA(MID,39);
A39:=MA39-MA0;
MA40:=MA(MID,40);
A40:=MA40-MA0;
{A1+A2+A3+A4+A5++A21+A22+A23+A24+A25+A26+A27+A28+A29+A30}
LC:(A6+A7+A8+A9+A10+A11+A12+A13+A14+A15+A16+A17+A18+A19+A20)/30,LINETHICK0,COLORYELLOW;
VAR1:=LC;
VAR2:=REF(LC,1);
VAR3:=VAR1>VAR2 AND REF(LC,1)<REF(LC,2);
VAR4:=VAR1<VAR2 AND REF(LC,1)>REF(LC,2);
均线发散 : STICKLINE(VAR1>VAR2,LC,REF(LC,1),2,1),COLORRED;
均线粘合 : STICKLINE(VAR1<VAR2,LC,REF(LC,1),2,1),COLORGREEN;
EMA5:MA(VAR1,5),COLOR666666;
EMA10:MA(VAR1,10),COLOR999999;
B1:=BARSLAST(MA20>REF(MA20,1));
DRAWTEXT(VAR3 AND MA20<REF(MA20,1) AND COUNT(VAR3,B1)=1,0.95*REF(LC,1),'1'),COLORYELLOW;
DRAWTEXT(VAR3 AND MA20<REF(MA20,1) AND COUNT(VAR3,B1)=2,0.95*REF(LC,1),'2'),COLORYELLOW;
DRAWTEXT(VAR3 AND MA20<REF(MA20,1) AND COUNT(VAR3,B1)=3,0.95*REF(LC,1),'3'),COLORYELLOW;
DRAWTEXT(VAR3 AND MA20<REF(MA20,1) AND COUNT(VAR3,B1)=4,0.95*REF(LC,1),'4'),COLORYELLOW;
DRAWTEXT(VAR3 AND MA20<REF(MA20,1) AND COUNT(VAR3,B1)=5,0.95*REF(LC,1),'5'),COLORYELLOW;
B2:=BARSLAST(MA20<REF(MA20,1));
DRAWTEXT(VAR4 AND MA20>REF(MA20,1) AND COUNT(VAR4,B2)=1 ,1.05*REF(LC,1),'1');
DRAWTEXT(VAR4 AND MA20>REF(MA20,1) AND COUNT(VAR4,B2)=2 ,1.05*REF(LC,1),'2');
DRAWTEXT(VAR4 AND MA20>REF(MA20,1) AND COUNT(VAR4,B2)=3 ,1.05*REF(LC,1),'3');
DRAWTEXT(VAR4 AND MA20>REF(MA20,1) AND COUNT(VAR4,B2)=4 ,1.05*REF(LC,1),'4');
MACD:=(EMA5-EMA10)*2,COLORSTICK;
{此段为MACD柱变色}
{STICKLINE(((MACD>REF(MACD,1)) AND (MACD>0)),0,MACD,0,0),COLOR0000BB;
STICKLINE(((MACD<REF(MACD,1)) AND (MACD>0)),0,MACD,0,0),COLORLIGREEN;
STICKLINE(((MACD>REF(MACD,1)) AND (MACD<0)),0,MACD,0,0),COLORFFFF00;
STICKLINE(((MACD<REF(MACD,1)) AND (MACD<0)),0,MACD,0,0),COLOR333333;}
减速上行: STICKLINE(VAR1>REF(VAR1,1) AND MACD<REF(MACD,1),VAR1,REF(VAR1,1),2,1),COLORLIRED;
减速下行: STICKLINE(VAR1<REF(VAR1,1) AND MACD>REF(MACD,1),VAR1,REF(VAR1,1),2,1),COLORFFFF00;

通达信均线离差的平滑版指标公式

 

相关文章