在线检测未来函数

通达信专看大盘指标公式

来源:Internet,编辑:股旁网,2017-06-21

VAR24F:=EMA(AMOUNT/VOL/100,5);
VAR25F:=EMA(AMOUNT/VOL/100,13);
VAR26F:=VAR24F-VAR25F;
势能: IF(1000*VAR26F/VAR24F>0,1000*VAR26F/VAR24F,0),COLORYELLOW,LINETHICK2;
VAR1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR2:=2*ABS(VAR1);
VAR3:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR4:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR5:=(HIGH+LOW+CLOSE)/3;
VAR6:=(VAR5-MA(VAR5,14))/(0.015*AVEDEV(VAR5,14));
VAR7:=(VAR5-MA(VAR5,70))/(0.015*AVEDEV(VAR5,70));
VAR8:=IF(VAR6>=150 AND VAR6<200 AND VAR7>=150 AND VAR7<200,10,0);
VAR9:=IF(VAR6<=-150 AND VAR6>-200 AND VAR7<=-150 AND VAR7>-200,-10,VAR8);
VARA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VARB:=100-ABS(VARA);
VARC:=3*SMA((INDEXC-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1)-2*SMA(SMA((INDEXC-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1),15,1);
VARD:=3*SMA((INDEXO-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1)-2*SMA(SMA((INDEXO-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1),15,1);
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=VAR11-CLOSE;
VAR13:=REF(CLOSE,1);
VAR14:=SMA(MAX(CLOSE-VAR13,0),7,1)/SMA(ABS(CLOSE-VAR13),7,1)*100;
VAR15:=SMA(MAX(CLOSE-VAR13,0),13,1)/SMA(ABS(CLOSE-VAR13),13,1)*100;
VAR16:=BARSCOUNT(CLOSE);
VAR17:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
VAR18:=((-100)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+50)*2;
VAR19:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1A:=(SMA(VAR19,4,1)-50)*2;
VAR1B:=SMA(VAR1A,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=IF(VAR17<=25 AND VAR18<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR12>=-0.25 AND VAR14<22 AND VAR15<28 AND VAR16>50,80,0);
情报: VAR3;
天线: IF(VARB<90,VARB,100);
红军: IF(VAR1>0,VAR1,0),COLORRED, LINESTICK;
绿军: IF(VAR1<0,VAR2,0),COLORGREEN,LINESTICK;
导弹: VAR20;
预警系统: IF(VAR7>=200 AND VAR6>=150,15,IF(VAR7<=-200 AND VAR6<=-150,-15,VAR9))+60,COLORGREEN;
STICKLINE(VAR3>=REF(VAR4,1),VAR3,VAR4,8,1),COLORRED;
STICKLINE(VAR3<REF(VAR4,1),VAR3,VAR4,8,1),COLORGREEN;
VAR21:=CLOSE>MA(CLOSE,20) AND MA(CLOSE,20)>=REF(MA(CLOSE,20),1);
VAR22:=CLOSE<MA(CLOSE,20) AND MA(CLOSE,20)<REF(MA(CLOSE,20),1);
VAR23:=红军>50 AND 预警系统>60 AND 天线=100;
VAR24:=红军>48 AND 预警系统>60 AND 天线<100;
VAR25:=绿军>38 AND 预警系统<55;
VAR26:=导弹>50 AND 天线<90;
VAR27:=VAR3<REF(VAR4,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
VAR28:=VAR3>=REF(VAR4,1) AND CLOSE<REF(CLOSE,1) AND 预警系统=60 AND 导弹=0 AND 绿军>=REF(绿军,1) AND VARC<REF(VARD,1);
DRAWTEXT(VAR21 AND COUNT(VAR21,30)=1,100,'上升通道,持股待长或高抛低吸!');
DRAWTEXT(VAR22 AND COUNT(VAR22,30)=1,90,'下降通道,小心无量阴跌! ');
DRAWTEXT(VAR23 AND COUNT(VAR23,30)=1,70,'上涨过急,需要调整,短线先抛出! ');
DRAWTEXT(VAR24 AND COUNT(VAR24,30)=1,80,'庄家出货,大跌在即,中线抛出! ');
DRAWTEXT(VAR25 AND COUNT(VAR25,30)=1,50,'不必杀跌,应有小反弹 ,跌停除外!');
DRAWTEXT(VAR26 AND COUNT(VAR26,30)=1,30,'坚决抢反弹,但巨量封跌停除外 ');
DRAWTEXT(VAR27 AND COUNT(VAR27,30)=1,40,'有大资金进场迹象,关注!');
DRAWTEXT(VAR28 AND COUNT(VAR28,30)=1,20,'见顶回落');
买入:IF(VAR27 AND COUNT(VAR27,30)=1,100,0),LINETHICK3,COLORBLUE;
A1:=DATE <= 1170615;
A18:=SUM((IF((CLOSE > (REF(CLOSE,1))),VOL,(IF((CLOSE < (REF(CLOSE,1))),(0 - VOL),0)))),0);
A19:=SUMBARS(VOL,CAPITAL);
A20:=(IF((CLOSE > (LLV(CLOSE,A19))),1,-1)) * (IF((A18 > (LLV(A18,A19))),1,-1));
A21:=IF((A20 = -1),1,0);
A22:=(COUNT((A21 = 1),8)) > 2;
A23:=((SUM(AMOUNT,13)) / ((AMOUNT / VOL) / 100)) / 100;
A24:=DMA((((((3 * HIGH) + LOW) + OPEN) + (2 * CLOSE)) / 7),(VOL / A23));
A25:=(((CLOSE - A24) / A24) * 100) < -15;
A26:=((CLOSE - (MIN(((REF(CLOSE,5)) * 0.865),((REF(CLOSE,21)) * 0.772)))) / CLOSE) < 0.05;
MG:=((A25 AND A26) AND A22) * A1;
底部不买你后悔:(IF(((A25 AND A26) AND A22),50,0)) * A1,COLORLIRED,LINETHICK4;
RG1:=MA(CLOSE,27);
RG2:=((CLOSE - RG1)/(RG1))*(100);
RG3:=MA(RG2,2);
RG4:=BARSLAST((CROSS((-10),RG3) = 1));
RG5:=(RG3 < (-10)) AND (RG4 > 3);
V1:=C/REF(MA(C,36),6)*10;
RF1:=EMA(CLOSE,3);
RF2:=((SMA(MAX((CLOSE - RF1),0),9,1) / SMA(ABS((CLOSE - RF1)),9,1)) * 100);
RF3:=((100 - (3 * SMA((((CLOSE - LLV(LOW,75)) / (HHV(HIGH,75) - LLV(LOW,75))) * 100),30,1))) + (2 * SMA(SMA((((CLOSE - LLV(LOW,75)) / (HHV(HIGH,75) - LLV(LOW,75))) * 100),30,1),21,1)));
RF4:=((100 - (3 * SMA((((OPEN - LLV(LOW,75)) / (HHV(HIGH,75) - LLV(LOW,75))) * 100),30,1))) + (2 * SMA(SMA((((OPEN - LLV(LOW,75)) / (HHV(HIGH,75) - LLV(LOW,75))) * 100),30,1),21,1)));
RF5:=((((HHV(HIGH,21) - CLOSE) / (HHV(HIGH,21) - LLV(LOW,21))) * 100) - 10);
RF6:=(((CLOSE - LLV(LOW,21)) / (HHV(HIGH,21) - LLV(LOW,21))) * 100);
RF7:=SMA(SMA(RF6,16,8),25,8)-SMA(RF5,30,8);
K0:=IF((RF2< 14) AND L<REF(L,1) AND V1<8.8 AND RF7<-65,50,0);
K1:=K0>1 AND C>O;
K2:=IF(K0>1 AND C/L>1.045,50,0);
K3:=IF(REF(K0,1)>0 AND K0=0,10,0);
准备2:STICKLINE(K0>3 AND RG5>0,100,60,2,0),COLORFF00FF,LINETHICK4;
K5:=IF(MAX(MAX(K1,K2),K3) AND REF(准备2,1)>0,30,0);
CG:=K5>1 AND REF(K5,1)=0;
进场2:STICKLINE(CG,100,60,2,0),COLORFFFF00,LINETHICK4;
准备1:=K0>3 AND RG5=0;
K4:=IF(MAX(MAX(K1,K2),K3) AND REF(准备1,1)>0,30,0);
UU:=K4>0 AND REF(K4,1)=0;
进场1:STICKLINE(UU,100,60,2,0),COLORRED,LINETHICK4;
中轴线Q:50,COLOR8E2323,LINETHICK2;
股价趋势Q:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK;
底部警戒Q:10,COLORRED,LINETHICK2;
买入警戒Q:STICKLINE(股价趋势Q<=10,0,20,2,0),COLORGREEN,LINETHICK2;
买入信号Q:STICKLINE(CROSS(股价趋势Q,底部警戒Q),0,20,3,0),COLORRED,LINETHICK7;
顶部警戒Q:90,COLORFFBB66,LINETHICK2;
卖出警戒Q:STICKLINE(股价趋势Q>=85,100,80,2,0),STICK,COLORF00FF0,LINETHICK2;
DRAWTEXT_FIX(CURRBARSCOUNT=60,0.4,0.01,0,'【有未来】'),COLORGREEN;
止损出局Q:STICKLINE(CROSS(顶部警戒Q,股价趋势Q),100,70,3,0),COLORFFF666,LINETHICK5;
多方趋势Q:7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)
-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1),2,1),COLOR8811FF,LINETHICK3;
突击套利线Q:=14;
套利阻力线Q:=78.89;
抄底Q:=CROSS(多方趋势Q,突击套利线Q);
逃顶Q:=CROSS(套利阻力线Q,多方趋势Q);
DRAWICON(抄底Q,多方趋势Q,1);
DRAWICON(逃顶Q,多方趋势Q,2);
LC:=REF(CLOSE,1);
ARQ:=SUM(HIGH-OPEN,26)/SUM(OPEN-LOW,26)*100;
VARHQ:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
VARGQ:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
VARLQ:=BARSCOUNT(CLOSE);
买点雷达:IF(VARHQ< 20 AND VARGQ< 25 AND VARLQ> 50 AND ARQ<70,1,0)*30,LINETHICK2,COLOR0078FF;
VAR2Q:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
VAR3Q:=SMA(SMA(VAR2Q,3,1),3,1);
VAR4Q:=SMA(VAR3Q,3,1);
VAR5Q:=3*VAR3Q-2*VAR4Q;
底2Q: STICKLINE(VAR3Q<20 AND VAR4Q<20 AND CROSS(VAR5Q,VAR3Q) AND CROSS(VAR3Q,VAR4Q),20,50,2,0), COLORYELLOW,LINETHICK6;
VARBQ:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VARCQ:=SMA(VARBQ,5,1);
VARDQ:=SMA(VARCQ,5,1);
底5Q: IF(CROSS(VARCQ,VARDQ) AND VARCQ<20,60,0),STICK,COLORWHITE,LINETHICK2;
VAR8Q:=(CLOSE-LLV(LOW,60.135))/(HHV(HIGH,60.135)-LLV(LOW,60))*80;
VAR9Q:=SMA(VAR8Q,7,1);
VARAQ:=SMA(VAR9Q,5,1);
底4Q: IF(CROSS(VAR9Q,VARAQ) AND VAR9Q<20,50,0),STICK,COLORDBDB70,LINETHICK4;
VAR6Q:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR7Q:=10;
底3Q:= IF(CROSS(VAR6Q,VAR7Q),40,0),STICK,COLORDB7093,LINETHICK3;
VAREQ:=1/WINNER(CLOSE);
VARFQ:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR10Q:=100-ABS(VARFQ);
VAR11Q:=IF(VAREQ>5,IF(VAREQ<100,VAREQ,VAR10Q-10),0);
VAR12Q:=HHV(HIGH,25);
VAR13Q:=LLV(LOW,25);
VAR14Q:=EMA((CLOSE-VAR13Q)/(VAR12Q-VAR13Q)*100,5);
底6Q:= IF(CROSS(VAR14Q,VAR11Q),80,0),STICK,LINETHICK2,COLORRED;
底7Q: (CLOSE-MA(CLOSE,58))/MA(CLOSE,58)<-0.225,STICK,LINETHICK2,COLOR7093DB;
RSV1Q:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
RSV2Q:=(CLOSE-LLV(LOW,37))/(HHV(HIGH,37)-LLV(LOW,37))*100;
RSV3Q:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
短线Q:=SMA(SMA(RSV1Q,3,1),3,1)+3*STD(CLOSE,21),COLOR00FF00,LINETHICK3;
中线Q:=SMA(RSV2Q,5,1)+2*STD(CLOSE,37),COLORRED,LINETHICK3;
长线Q:=SMA(RSV3Q,5,1),COLORYELLOW,LINETHICK3;
DRAWTEXT(CROSS(短线Q,长线Q)AND 长线Q<18 AND 长线Q>REF(长线Q,1)OR CROSS(长线Q,5),60,'翻倍'),COLORRED,LINETHICK1;

通达信专看大盘指标公式

 

相关文章