在线检测未来函数

通达信操盘专用系统主图指标公式

来源:Internet,编辑:股旁网,2017-06-21

显示仪表盘1:=1;
短线5日:EMA(C,5),COLOR00FF00,LINETHICK1;
红升5:IF(短线5日>REF(短线5日,1),短线5日,DRAWNULL),COLORFFFFFF,LINETHICK2;
绿降5:IF(短线5日<REF(短线5日,1),短线5日,DRAWNULL)DOTLINE,COLORFFFFFF,LINETHICK1;
短线13日:EMA(C,13),COLOR00FF00,LINETHICK1;
升:IF(短线13日>REF(短线13日,1),短线13日,DRAWNULL),COLOR00E8E8,LINETHICK2;
降:IF(短线13日<REF(短线13日,1),短线13日,DRAWNULL)DOTLINE,COLOR00FFFF,LINETHICK1;
操作线21日:EMA(C,21),COLOR00FF00,LINETHICK1;
红升:IF(操作线21日>REF(操作线21日,1),操作线21日,DRAWNULL),COLOR0000FF,LINETHICK3;
绿降:IF(操作线21日<REF(操作线21日,1),操作线21日,DRAWNULL)DOTLINE,COLOR00FF00,LINETHICK3;
生命线62日:EMA(C,62),COLORYELLOW,LINETHICK1,NODRAW;
红升4:IF(生命线62日>REF(生命线62日,1),生命线62日,DRAWNULL),COLORFF00FF,LINETHICK2;
绿降4:IF(生命线62日<REF(生命线62日,1),生命线62日,DRAWNULL),COLORFF00FF,DOTLINE;
趋势线半年:EMA(C,120),COLORYELLOW,LINETHICK1,NODRAW;
半年红升:IF(趋势线半年>REF(趋势线半年,1),趋势线半年,DRAWNULL)POINTDOT,COLOR0000BF,LINETHICK4;
半年绿降:IF(趋势线半年<REF(趋势线半年,1),趋势线半年,DRAWNULL),COLOR0000BF,POINTDOT;
年线:EMA(C,250),COLORYELLOW,LINETHICK1,NODRAW;
年红升:IF(年线>REF(年线,1),年线,DRAWNULL),COLORFF0000,LINETHICK1;
年绿降:IF(年线<REF(年线,1),年线,DRAWNULL),COLORFF0000,DOTLINE,LINETHICK1;
R1:=(C+L+H)/3;
R2:=EMA(R1,6);
R3:=EMA(R2,5);
N:=5;
M1:=6;
M2:=6;
M3:=8;
R:=IF(DATE<1910612,1,0);
EE:=(H+MAX(C,O))/2;
EE1:=MA(EE,3);
EE2:=(L+MIN(C,O))/2;
EE3:=MA(EE2,3);
超短线3日:MA(EE,3),COLOR00FF00;
红升1:IF(超短线3日>REF(超短线3日,1),超短线3日,DRAWNULL),COLOR8EB3FF,LINETHICK2;
绿降1:IF(超短线3日<REF(超短线3日,1),超短线3日,DRAWNULL),COLOR8EB3FF,LINETHICK1,DOTLINE;
FF:=(H+L+C+O)/4,COLORWHITE;
FF1:=MA(FF,3),COLORGREEN;
FF3:=REF((C+O)/2,1)>REF((C+O)/2,2) AND REF(MIN(C,O),1)>REF(MAX(C,O),2);
实际乖离:=(MAX(FF,FF1)-MIN(FF,FF1))/MIN(FF,FF1)*100,LINETHICK;
FF4:=(((FF1-(REF(FF1,1)-FF1))-L)/L)*100;
FF5:=(((EE1+(EE1-REF(EE1,1)))-L)/L)*100;
FF6:=FF1-(REF(FF1,1)-FF1);
FF7:=EE1+(EE1-REF(EE1,1));
期望获利率:=IF(FF3,FF5,FF4),LINETHICK;
YY1:=REF(EVERY(C>=O,4),1) AND REF(EVERY((C+O)/2>FF1,4),1) AND (C+O)/2<FF1;
YY2:=NOT(YY1) AND (FF1-O)/O*1000>5 AND O<REF(MIN(C,O),1);
A:=SMA(L,4,3);
B:=SMA(H,4,3);
BB:=SMA(MIN(C,O),4,3);
BB1:=REF(L,1)-HHV((MAX(REF(L,2),REF(L,1))-MIN(REF(L,2),REF(L,1))),2);
BB2:=REF((C+O)/2,1)>REF((C+O)/2,2);
BB3:=L<=BB1+BB1*0.01 AND O>REF(O,2) AND O>=REF(L,3) AND COUNT(C>O,7)>3;
BB6:=(BB1-L)/L*100;
BB7:=(REF(L,1)-BB1)/BB1*100;
A1:=(A-L)/L>N/1000 ;
A8:=A1;
A9:=(REF(H,1)-O)/O*100-(REF(MAX(C,O),2)-REF(MAX(C,O),1))/REF(MAX(C,O),1)*100;
A10:=IF(BB2,BB6,A9);
BB4:=BB6+A10>2;
BB5:=IF(BB2,BB3,BB4) AND 期望获利率>2;
D5:=R AND A8 AND BB5;
STICKLINE(D5,A*0.995,A*0.992,3,0)COLOR00FFFF;
DRAWICON(R AND (REF((D5),1)) AND (L<REF((L/0.995),1)),L*0.97,23);
STICKLINE(C>=O,C,O,3.4,0),COLOR0000AA;
STICKLINE(C>=O,C,O,3.0,0),COLOR0000BB ;
STICKLINE(C>=O,C,O,2.4,0),COLOR0000CC;
STICKLINE(C>=O,C,O,2.0,0),COLOR0000DD ;
STICKLINE(C>=O,C,O,1.6,0),COLOR0000EE;
STICKLINE(C>=O,C,O,1.2,0),COLOR0000FF;
STICKLINE(C>=O,C,O,0.6,0),COLOR0000FF;
STICKLINE(C>=O,H,L,0,0),COLORRED;
STICKLINE(C<=O,C,O,3.4,0),COLORAAAA00;
STICKLINE(C<=O,C,O,3.0,0),COLORBBBB00;
STICKLINE(C<=O,C,O,2.4,0),COLORCCCC00;
STICKLINE(C<=O,C,O,2.0,0),COLORDDDD00;
STICKLINE(C<=O,C,O,1.6,0),COLOREEEE00;
STICKLINE(C<=O,C,O,1.2,0),COLORFFFF00;
STICKLINE(C<=O,C,O,0.6,0),COLORFFFF00;
STICKLINE(C<=O,H,L,0,0),COLORFFFF00;
{======================================================}
范围高A:=REFDATE(HHV(H,120),DATE)*1.05;
范围低A:=REFDATE(LLV(L,120),DATE)*0.95;
MA5:=MA(C,5),COLORCYAN,LINETHICK2;
MA24:=MA(C,24),COLORGREEN,LINETHICK2;
MA72:=MA(C,72),COLORRED,LINETHICK2;
MA200:=IF((MA(C,200)<=范围高A AND MA(C,200)>=范围低A) OR C>=MA(C,200),MA(C,200),DRAWNULL),COLORBLUE,LINETHICK2;
{=======================仪表盘=========================}
主升浪:=ISLASTBAR AND MA5>MA24 AND MA24>MA72 AND MA72>IF(MA200=DRAWNULL,0,MA200);
主浪回调:=ISLASTBAR AND MA24>MA5 AND MA5>MA72 AND MA72>IF(MA200=DRAWNULL,0,MA200);
主浪深调:=ISLASTBAR AND MA24>MA72 AND MA72>MA5 AND MA5>IF(MA200=DRAWNULL,0,MA200);
初升浪:=ISLASTBAR AND IF(MA200=DRAWNULL,300,MA200)>MAX(MA24,MA72) AND MA5>MA24 AND MA24>MA72;
底部反弹:=ISLASTBAR AND IF(MA200=DRAWNULL,300,MA200)>MA72 AND MA72>MA24 AND MA5>MA24;
探底阶段:=ISLASTBAR AND IF(MA200=DRAWNULL,300,MA200)>MA72 AND MA72>MA24 AND MA24>MA5;
观望:=ISLASTBAR AND IF(MA200=DRAWNULL,MA24>MA72 AND C<MA72,MA72>MA200 AND C<MA200);
有牛:=ISLASTBAR AND IF(MA200=DRAWNULL,MA24<MA72 AND C>=MA72,MA72<MA200 AND C>=MA200);
放弃:=ISLASTBAR AND IF(MA200=DRAWNULL,MA24<MA72 AND C<MA72,MA72<MA200 AND C<MA200);
DRAWGBK(显示仪表盘1=1 AND 主升浪=0 AND 主浪回调=0 AND 主浪深调=0 AND 初升浪=0 AND 底部反弹=0 AND 探底阶段=0 AND 观望=0 AND 有牛=0 AND 放弃=0,0,0,0,'观望',0)COLOR00BF00;
DRAWGBK(显示仪表盘1=1 AND 主升浪,0,0,0,'主升浪',0)COLORFF00FF;
DRAWGBK(显示仪表盘1=1 AND 主浪回调,0,0,0,'主浪回调',0)COLORFF8080;
DRAWGBK(显示仪表盘1=1 AND 主浪深调,0,0,0,'主浪深调',0)COLOR009500;
DRAWGBK(显示仪表盘1=1 AND 初升浪,0,0,0,'初升浪',0)COLOR00FFFF;
DRAWGBK(显示仪表盘1=1 AND 底部反弹,0,0,0,'底部反弹',0)COLORFFFF00;
DRAWGBK(显示仪表盘1=1 AND 探底阶段,0,0,0,'探底阶段',0);
DRAWGBK(显示仪表盘1=1 AND 观望,0,0,0,'观望',0)COLORFFFF00;
DRAWGBK(显示仪表盘1=1 AND 有牛,0,0,0,'有牛',0)COLOR00FFFF;
DRAWGBK(显示仪表盘1=1 AND 放弃,0,0,0,'放弃',0)COLOR00BF00;
引差:=REF(C,1)-LOW,LINETHICK1,NODRAW;
引跌幅:IF((REF(C,1)-LOW)/REF(C,1)*100>0,(REF(C,1)-LOW)/REF(C,1)*100,0),LINETHICK1,NODRAW;
三日均跌:MA(引跌幅,3),COLORWHITE,NODRAW;
今最高:HIGH,LINETHICK1,COLORRED,NODRAW;
今最低:LOW,LINETHICK1,COLORGREEN,NODRAW;
Z0T:=C/REF(C,1)>1.097;
XH:=FILTER(Z0T,13);
BH:=BARSLAST(Z0T);
CZ:=REF(H,BH)-REF(L,BH);
STICKLINE(Z0T,REF(O,BH),REF(C,BH),5,0),COLORYELLOW;
DRAWTEXT(Z0T,L*0.98,'★涨停'),COLORFFFFFF;
AAA:=CONST(HHV(H,50));PL5:=HHV(H,45);
F:=100*(C-REF(C,1))/REF(C,1);
博尔:=IF(C<REF(O,1) AND F<0,1,0);
P1:=博尔;
量化:=IF(C<REF(O,2) AND F<0,1,0);
P2:=量化;
STICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,3,0),COLORFF09FF;
ME2:=EMA(CLOSE,6);
五天:=EXPMA(CLOSE,5),COLORRED;
超短线:=EMA(ME2,11),COLORGREEN; LJL07:=(3*C+L+O+H)/6;
牛线:=(20*LJL07+19*REF(LJL07,1)+18*REF(LJL07,2)+17*REF(LJL07,3)+16*REF(LJL07,4)+15*REF(LJL07,5)+14*REF(LJL07,6)+13*REF(LJL07,7)+12*REF(LJL07,8)+11*REF(LJL07,9)+10*REF(LJL07,10)+9*REF(LJL07,11)+8*REF(LJL07,12)+7*REF(LJL07,13)+6*REF(LJL07,14)+5*REF(LJL07,15)+4*REF(LJL07,16)+3*REF(LJL07,17)+2*REF(LJL07,18)+REF(LJL07,20))/210,COLORRED;
熊线:=MA(牛线,5),COLORYELLOW,LINETHICK4,POINTDOT;
持股:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORWHITE;
{趋势}
赚了:=IF(EMA(CLOSE,3)>超短线,超短线,DRAWNULL),COLORRED;
持股角度:=ATAN((持股/REF(持股,1)-1)*100)*180/3.1416,COLORRED,NODRAW;
月线:=EMA(持股,30),COLORYELLOW,DOTLINE;
双月线:=EMA(持股,60),COLORCYAN,DOTLINE;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND ("DMI.PDI">"DMI.MDI") AND UPNDAY("DMI.ADXR",1) AND ("DMI.ADX">"DMI.ADXR"),0.460,0.26,0,'DMI 火箭升空'),COLOR8080FF;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND ("DMI.PDI"<"DMI.MDI") AND UPNDAY("DMI.ADXR",1) AND ("DMI.ADX">"DMI.ADXR"),0.460,0.26,0,'DMI 空中炸弹'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND ("DMI.PDI">"DMI.MDI"),0.460,0.21,0,'DMI 多头趋势'),COLOR8080FF;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND ("DMI.PDI"<"DMI.MDI"),0.460,0.21,0,'DMI 空头趋势'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS("KDJ.J","KDJ.K"),0.460,0.31,0,'K D J 金 叉'),COLOR8080FF;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS("KDJ.K","KDJ.J"),0.460,0.31,0,'K D J 死 叉'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND ("KDJ.J">"KDJ.K"),0.460,0.36,0,'K D J 多头趋势'),COLOR8080FF;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND ("KDJ.J"<"KDJ.K"),0.460,0.36,0,'K D J 空头趋势'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND ("MACD.DIF">"MACD.DEA") AND "MACD.MACD">0,0.460,0.41,0,'MACD 中线看多'),COLOR8080FF;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND ("MACD.DIF"<"MACD.DEA") AND "MACD.MACD"<0,0.460,0.41,0,'MACD 中线看空'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND ("MACD.DIF">"MACD.DEA"),0.460,0.46,0,'MACD 多头趋势'),COLOR8080FF;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND ("MACD.DIF"<"MACD.DEA"),0.460,0.46,0,'MACD 空头趋势'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS("MACD.DIF","MACD.DEA"),0.460,0.51,0,'MACD 金 叉'),COLOR8080FF;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS("MACD.DEA","MACD.DIF"),0.460,0.51,0,'MACD 死 叉'),COLORGREEN;
上涨:=CURRBARSCOUNT=1 AND UPNDAY(双月线,1) AND UPNDAY(月线,1) AND UPNDAY(超短线,1) AND UPNDAY(持股,1);
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND 上涨,0.460,0.15,0,'上 涨 趋 势'),COLORFF00FF;
短线上涨:=CURRBARSCOUNT=1 AND UPNDAY(双月线,1) AND UPNDAY(月线,1) AND DOWNNDAY(超短线,1) AND UPNDAY(持股,1);
短线上涨0:=CURRBARSCOUNT=1 AND UPNDAY(双月线,1) AND DOWNNDAY(月线,1) AND DOWNNDAY(超短线,1) AND UPNDAY(持股,1);
短线上涨1:=CURRBARSCOUNT=1 AND UPNDAY(双月线,1) AND DOWNNDAY(月线,1) AND UPNDAY(超短线,1) AND UPNDAY(持股,1);
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND (短线上涨 OR 短线上涨0 OR 短线上涨1),0.460,0.15,0,'短 线 上 涨'),COLOR8080FF;
短线回调:=CURRBARSCOUNT=1 AND UPNDAY(双月线,1) AND UPNDAY(月线,1) AND UPNDAY(超短线,1) AND DOWNNDAY(持股,1);
短线回调0:=CURRBARSCOUNT=1 AND UPNDAY(双月线,1) AND DOWNNDAY(月线,1) AND UPNDAY(超短线,1) AND DOWNNDAY(持股,1);
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND (短线回调 OR 短线回调0),0.460,0.15,0,'短 线 回 调'),COLORYELLOW;
短线看空:=CURRBARSCOUNT=1 AND UPNDAY(双月线,1) AND UPNDAY(月线,1) AND DOWNNDAY(超短线,1) AND DOWNNDAY(持股,1);
短线看空0:=CURRBARSCOUNT=1 AND UPNDAY(双月线,1) AND DOWNNDAY(月线,1) AND DOWNNDAY(超短线,1) AND DOWNNDAY(持股,1);
短线空仓:=CURRBARSCOUNT=1 AND DOWNNDAY(双月线,1) AND DOWNNDAY(月线,1) AND DOWNNDAY(超短线,1) AND DOWNNDAY(持股,1);
短线空仓0:=CURRBARSCOUNT=1 AND DOWNNDAY(双月线,1) AND UPNDAY(月线,1) AND DOWNNDAY(超短线,1) AND DOWNNDAY(持股,1);
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND (短线空仓 OR 短线空仓0 OR 短线看空 OR 短线看空0),0.460,0.15,0,'短 线 空 仓'),COLORYELLOW;
短线震荡:=CURRBARSCOUNT=1 AND DOWNNDAY(双月线,1) AND UPNDAY(月线,1) AND UPNDAY(超短线,1) AND DOWNNDAY(持股,1);
短线震荡0:=CURRBARSCOUNT=1 AND DOWNNDAY(双月线,1) AND UPNDAY(月线,1) AND DOWNNDAY(超短线,1) AND UPNDAY(持股,1);
短线震荡1:=CURRBARSCOUNT=1 AND DOWNNDAY(双月线,1) AND DOWNNDAY(月线,1) AND UPNDAY(超短线,1) AND DOWNNDAY(持股,1);
注意该股:=CURRBARSCOUNT=1 AND DOWNNDAY(双月线,1) AND DOWNNDAY(月线,1) AND DOWNNDAY(超短线,1) AND UPNDAY(持股,1);
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND (短线震荡 OR 短线震荡0 OR 短线震荡1 OR 注意该股),0.460,0.15,0,'短 线 震 荡'),COLORYELLOW;
短线反弹:=CURRBARSCOUNT=1 AND DOWNNDAY(双月线,1) AND DOWNNDAY(月线,1) AND UPNDAY(超短线,1) AND UPNDAY(持股,1);
短线反弹0:=CURRBARSCOUNT=1 AND DOWNNDAY(双月线,1) AND UPNDAY(月线,1) AND UPNDAY(超短线,1) AND UPNDAY(持股,1);
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND (短线反弹 OR 短线反弹0),0.460,0.15,0,'短 线 反 弹'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 ,0.360,0.09,0,'★---今 日 操 作 提 示---★')COLOR95B8FF;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND ("MACD.MACD">0) AND (CROSS("MACD.DIF","MACD.DEA") OR CROSS(持股,超短线)) AND UPNDAY(超短线,1),0.55,0.09,0,' 决策:中 线 全 仓 买 入'),COLOR95B8FF;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND ("MACD.MACD"<0) AND (CROSS("MACD.DEA","MACD.DIF") OR CROSS(超短线,持股)) AND DOWNNDAY(超短线,1),0.55,0.09,0,' 决策:中 线 空 仓'),COLOR95B8FF;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND DOWNNDAY(超短线,1) AND DOWNNDAY(持股,1),0.55,0.09,0,' 决策:短 线 空(减) 仓【关注:阴 线 买、V 转、止 跌 买信号】'),COLOR95B8FF;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND DOWNNDAY(超短线,1) AND UPNDAY(持股,1),0.55,0.09,0,' 决策:短 线 买 入 30 %'),COLOR95B8FF;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND UPNDAY(超短线,1) AND UPNDAY(持股,1),0.55,0.09,0,' 决策:短 线 买 入 60 %'),COLOR95B8FF;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND UPNDAY(超短线,1) AND DOWNNDAY(持股,1),0.55,0.09,0,' 决策:短 线 震 荡 看 看 再 说【关注:阴 线 买 信 号】'),COLOR95B8FF;
DRAWICON(CROSS(MA(C,3),C),H,15);
DRAWTEXT_FIX(ISLASTBAR,0.1,0.05,0,HYBLOCK)COLOR80FFFF;
DRAWTEXT_FIX(ISLASTBAR,0.1,0,0,DYBLOCK)COLOR80FFFF;
DRAWTEXT_FIX(ISLASTBAR,0.55,0.85,0,GNBLOCK)COLOR80FFFF;
DRAWTEXT_FIX(ISLASTBAR,0.55,0.90,0,FGBLOCK)COLOR80FFFF;
DRAWTEXT_FIX(ISLASTBAR,0.55,0.95,0,ZSBLOCK)COLOR80FFFF;
止损:=REF(HHV(H,13),1)*0.95,COLORGRAY,DOTLINE;
STICKLINE(CURRBARSCOUNT=1,止损,止损,40,-1),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,止损*0.995,'破止损'),COLORFFFF00;
MAA10:=MA(CLOSE,10),COLORYELLOW,LINETHICK0;
MAA54:=MA(CLOSE,54),COLORFFCCCC,LINETHICK0;
PL1:=(((CLOSE - MAA54) / MAA54) < 0.1);PL2:=(((CLOSE - MAA10) / MAA10) < 0.3);
偏离率:=(((PL1 = 1) AND (PL2 = 1)) * 0.2);
突破加仓:=((((偏离率 = 0) AND (REF(偏离率,1) = 0.2)) AND (REF((COUNT((偏离率 = 0.2),10) = 10),1) = 1)) * 1);
DRAWTEXT(突破加仓,L,'----------突破加仓'),COLORFFFFFF;

通达信操盘专用系统主图指标公式

 

相关文章