在线检测未来函数

通达信波增回减主图及选股指标公式

来源:Internet,编辑:股旁网,2017-06-27

{使用说明:取最后两根涨幅大于4%的阳线,左侧起第一根大于4%的阳线幅度和量能大于左侧起第二根大于4%幅度的阳线幅度和量能,第一根阳线后回调力度小于第二根阳线回调力度,第一根阳线回调天数小于第二根阳线的回调天数,首次或上穿时买入。}

ZF:=(C/REF(C,1)-1)*100;
涨幅:=ZF>=4;
T1:=BARSLAST(涨幅);
T2:=REF(T1,T1+1)+T1+1;
T3:=BARSLAST(CURRBARSCOUNT=CONST(T1)+1);
T4:=BARSLAST(CURRBARSCOUNT=CONST(T2)+1);
高1H:REF(H,T3),COLORRED,LINETHICK2;
DRAWTEXT(ISLASTBAR,高1H,'ZT1'),COLORYELLOW;
高2H:REF(H,T4),COLORRED,LINETHICK2;
DRAWTEXT(ISLASTBAR,高2H,'ZT2'),COLORYELLOW;
高2L:REF(L,T4)NODRAW;
涨幅一:REF(ZF,T3)NODRAW;
涨幅二:REF(ZF,T4)NODRAW;
量一:REF(V,T3)NODRAW;
量二:REF(V,T4)NODRAW;
LL1:=IF(T3>0,CONST(LLV(L,T3)),DRAWNULL);
A1:=BARSLAST(LL1=L);
REF(L,A1),DOTLINE,COLORGREEN;
LL2:=IF(T4>0,CONST(LLV(L,T4)),DRAWNULL)DOTLINE,COLORGREEN;
A2:=BARSLAST(LL2=L);
REF(L,A2),DOTLINE,COLORGREEN;
TJ1:=BETWEEN(高1H/高2H,1,1.15) AND LL1/高1H>=LL2/高2H;
TJ2:=LL2>=高2L AND 涨幅一>=涨幅二 AND 量一>量二;
TJ3:=T4-A2>T3-A1 AND T4<30;
XG:=TJ1 AND TJ2 AND TJ3 AND (CROSS(C,高1H) AND COUNT(C>=高1H,T3)=1 AND C>=高1H);
DRAWICON(XG AND C/LLV(L,60)<1.3,H,1);
STICKLINE(T3+1=1,O,C,1.5,0),COLORYELLOW;
STICKLINE(T4+1=1,O,C,1.5,0),COLORYELLOW;

{
选股公式:

ZF:=(C/REF(C,1)-1)*100;
涨幅:=ZF>=4;
T1:=BARSLAST(涨幅);
T2:=REF(T1,T1+1)+T1+1;
T3:=BARSLAST(CURRBARSCOUNT=CONST(T1)+1);
T4:=BARSLAST(CURRBARSCOUNT=CONST(T2)+1);
高1H:=REF(H,T3);高2H:=REF(H,T4);
高2L:=REF(L,T4);
涨幅一:=REF(ZF,T3);涨幅二:=REF(ZF,T4);
量一:=REF(V,T3);量二:=REF(V,T4);
LL1:=IF(T3>0,CONST(LLV(L,T3)),DRAWNULL);
A1:=BARSLAST(LL1=L);
LL2:=IF(T4>0,CONST(LLV(L,T4)),DRAWNULL);
A2:=BARSLAST(LL2=L);
TJ1:=BETWEEN(高1H/高2H,1,1.15) AND LL1/高1H>=LL2/高2H;
TJ2:=LL2>=高2L AND 涨幅一>=涨幅二 AND 量一>量二;
TJ3:=T4-A2>T3-A1 AND T4<30 AND C/LLV(L,60)<1.3;
XG:=TJ1 AND TJ2 AND TJ3 AND (CROSS(C,高1H) AND COUNT(C>=高1H,T3)=1 AND C>=高1H);
COUNT(XG,5);
}

通达信波增回减主图及选股指标公式

 

相关文章