在线检测未来函数

通达信MACD柱线均势和背离指标公式

来源:Internet,编辑:股旁网,2017-07-10

DIF:EMA(CLOSE,12)-EMA(CLOSE,26),NODRAW,COLORWHITE;
DEA:EMA(DIF,9),NODRAW,COLORGREEN;
DRAWBAND(DIF,RGB(100,20,20),DEA,RGB(50,100,50));
STICKLINE(C>0,0,0,28,0)COLORGRAY;
MACD:(DIF-DEA)*2,NODRAW,COLOR4080FF;
STICKLINE(MACD>0,0,MACD,0,0)COLOR4080FF;
STICKLINE(MACD<0,0,MACD,0,0)COLORLIBLUE;
NOTEXT:MACD,COLORWHITE;
均MACD:EMA(MACD,5)COLORYELLOW;
DRAWICON(CROSS(MACD,均MACD),REF(MACD,1),1);
DRAWICON(CROSS(均MACD,MACD),REF(MACD,1),2);
DRAWTEXT_FIX(C>0,0.00,0,0,'MACD柱线均势和背离'),COLORWHITE;
A1:=BARSLAST(REF(CROSS(MACD,均MACD),1));
金叉底背:=REF(CLOSE,A1+1)>CLOSE AND MACD>REF(MACD,A1+1) AND CROSS(MACD,均MACD);
DRAWTEXT(金叉底背,REF(MACD,1),'__底背'),COLORYELLOW;
DRAWLINE(A1=0,均MACD,金叉底背,均MACD,0),COLORLIRED,DOTLINE;{底背画线};
A2:=BARSLAST(REF(CROSS(均MACD,MACD),1));
死叉顶背:=REF(CLOSE,A2+1)<CLOSE AND REF(MACD,A2+1)>MACD AND CROSS(均MACD,MACD);
DRAWTEXT(死叉顶背,REF(MACD,1),'__顶背'),COLORLIGREEN;
DRAWLINE(A2=0,均MACD,死叉顶背,均MACD,0),COLORGREEN,DOTLINE;{顶背画线};

通达信MACD柱线均势和背离指标公式

 

相关文章