在线检测未来函数

通达信好用多年主图指标公式

来源:Internet,编辑:股旁网,2017-07-14

SYCP2:=CONST(REF(C,60));
DP202:=INDEXC/CONST(REF(INDEXC,60))*SYCP2;
IF(CURRBARSCOUNT<62,DP202,DRAWNULL),COLORLIRED,LINETHICK2;
DRAWGBK(C>O,RGB(60,0,0),RGB(10,0,10),1,2,1);
DRAWKLINE(H,O,L,C);
HB:=COST(99.9);
LVB:=COST(0.1);
B3:=(HB-LVB)/50;
B31:=HB-B3;
B32:=HB-2*B3;
B33:=HB-3*B3;
B34:=HB-4*B3;
B35:=HB-5*B3;
B36:=HB-6*B3;
B37:=HB-7*B3;
B38:=HB-8*B3;
B39:=HB-9*B3;
B310:=HB-10*B3;
B311:=HB-11*B3;
B312:=HB-12*B3;
B313:=HB-13*B3;
B314:=HB-14*B3;
B315:=HB-15*B3;
B316:=HB-16*B3;
B317:=HB-17*B3;
B318:=HB-18*B3;
B319:=HB-19*B3;
B320:=HB-20*B3;
B321:=HB-21*B3;
B322:=HB-22*B3;
B323:=HB-23*B3;
B324:=HB-24*B3;
B325:=HB-25*B3;
B326:=HB-26*B3;
B327:=HB-27*B3;
B328:=HB-28*B3;
B329:=HB-29*B3;
B330:=HB-30*B3;
B331:=HB-31*B3;
B332:=HB-32*B3;
B333:=HB-33*B3;
B334:=HB-34*B3;
B335:=HB-35*B3;
B336:=HB-36*B3;
B337:=HB-37*B3;
B338:=HB-38*B3;
B339:=HB-39*B3;
B340:=HB-40*B3;
B341:=HB-41*B3;
B342:=HB-42*B3;
B343:=HB-43*B3;
B344:=HB-44*B3;
B345:=HB-45*B3;
B346:=HB-46*B3;
B347:=HB-47*B3;
B348:=HB-48*B3;
B349:=HB-49*B3;
A1:=WINNER(HB)*100-WINNER(B31)*100;
A2:=WINNER(B31)*100-WINNER(B32)*100;
A3:=WINNER(B32)*100-WINNER(B33)*100;
A4:=WINNER(B33)*100-WINNER(B34)*100;
A5:=WINNER(B34)*100-WINNER(B35)*100;
A6:=WINNER(B35)*100-WINNER(B36)*100;
A7:=WINNER(B36)*100-WINNER(B37)*100;
A8:=WINNER(B37)*100-WINNER(B38)*100;
A9:=WINNER(B38)*100-WINNER(B39)*100;
A10:=WINNER(B39)*100-WINNER(B310)*100;
A11:=WINNER(B310)*100-WINNER(B311)*100;
A12:=WINNER(B311)*100-WINNER(B312)*100;
A13:=WINNER(B312)*100-WINNER(B313)*100;
A14:=WINNER(B313)*100-WINNER(B314)*100;
A15:=WINNER(B314)*100-WINNER(B315)*100;
A16:=WINNER(B315)*100-WINNER(B316)*100;
A17:=WINNER(B316)*100-WINNER(B317)*100;
A18:=WINNER(B317)*100-WINNER(B318)*100;
A19:=WINNER(B318)*100-WINNER(B319)*100;
A20:=WINNER(B319)*100-WINNER(B320)*100;
A21:=WINNER(B320)*100-WINNER(B321)*100;
A22:=WINNER(B321)*100-WINNER(B322)*100;
A23:=WINNER(B322)*100-WINNER(B323)*100;
A24:=WINNER(B323)*100-WINNER(B324)*100;
A25:=WINNER(B324)*100-WINNER(B325)*100;
A26:=WINNER(B325)*100-WINNER(B326)*100;
A27:=WINNER(B326)*100-WINNER(B327)*100;
A28:=WINNER(B327)*100-WINNER(B328)*100;
A29:=WINNER(B328)*100-WINNER(B329)*100;
A30:=WINNER(B329)*100-WINNER(B330)*100;
A31:=WINNER(B330)*100-WINNER(B331)*100;
A32:=WINNER(B331)*100-WINNER(B332)*100;
A33:=WINNER(B332)*100-WINNER(B333)*100;
A34:=WINNER(B333)*100-WINNER(B334)*100;
A35:=WINNER(B334)*100-WINNER(B335)*100;
A36:=WINNER(B335)*100-WINNER(B336)*100;
A37:=WINNER(B336)*100-WINNER(B337)*100;
A38:=WINNER(B337)*100-WINNER(B338)*100;
A39:=WINNER(B338)*100-WINNER(B339)*100;
A40:=WINNER(B339)*100-WINNER(B340)*100;
A41:=WINNER(B340)*100-WINNER(B341)*100;
A42:=WINNER(B341)*100-WINNER(B342)*100;
A43:=WINNER(B342)*100-WINNER(B343)*100;
A44:=WINNER(B343)*100-WINNER(B344)*100;
A45:=WINNER(B344)*100-WINNER(B345)*100;
A46:=WINNER(B345)*100-WINNER(B346)*100;
A47:=WINNER(B346)*100-WINNER(B347)*100;
A48:=WINNER(B347)*100-WINNER(B348)*100;
A49:=WINNER(B348)*100-WINNER(B349)*100;
A50:=WINNER(B349)*100-WINNER(LVB)*100;
STICKLINE(ISLASTBAR,HB ,HB ,A1*15 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B31 ,B31 ,A1*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B32 ,B32 ,A2*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B33 ,B33 ,A3*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B34 ,B34 ,A4*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B35 ,B35 ,A5*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B36 ,B36 ,A6*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B37 ,B37 ,A7*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B38 ,B38 ,A8*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B39 ,B39 ,A9*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B310 ,B310 ,A10*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B311 ,B311 ,A11*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B312 ,B312 ,A12*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B313 ,B313 ,A13*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B314 ,B314 ,A14*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B315 ,B315 ,A15*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B316 ,B316 ,A16*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B317 ,B317 ,A17*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B318 ,B318 ,A18*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B319 ,B319 ,A19*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B320 ,B320 ,A20*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B321 ,B321 ,A21*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B322 ,B322 ,A22*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B323 ,B323 ,A23*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B324 ,B324 ,A24*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B325 ,B325 ,A25*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B326 ,B326 ,A26*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B327 ,B327 ,A27*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B328 ,B328 ,A28*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B329 ,B329 ,A29*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B330 ,B330 ,A30*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B331 ,B331 ,A31*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B332 ,B332 ,A32*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B333 ,B333 ,A33*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B334 ,B334 ,A34*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B335 ,B335 ,A35*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B336 ,B336 ,A36*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B337 ,B337 ,A37*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B338 ,B338 ,A38*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B339 ,B339 ,A39*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B340 ,B340 ,A40*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B341 ,B341 ,A41*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B342 ,B342 ,A42*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B343 ,B343 ,A43*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B344 ,B344 ,A44*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B345 ,B345 ,A45*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B346 ,B346 ,A46*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B347 ,B347 ,A47*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B348 ,B348 ,A48*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,LVB ,LVB ,A50*15 ,0 ),COLOR666600;
快线:EMA(EMA(EMA(EMA(CLOSE,2),2),2),2),LINETHICK2,COLOR0000FF;
慢线:EMA(REF(快线,1),2),LINETHICK2,COLOR00FFFF;
DRAWBAND(慢线,RGB(500,180,280),快线,RGB(500,280,180));
HIGHN:=10;LOWN:=10;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;
AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
高点压力:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORGREEN,LINETHICK2;
前期高点:DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,LINETHICK2;
近期高点:DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,LINETHICK2;
AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
低点支撑:=DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED,LINETHICK2;
ZGSTAR:=(高点压力+低点支撑)/2;
ZGEND:=CONST((高点压力+低点支撑)/2);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
中轨:=DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),COLORFF55BB,LINETHICK2;
N1:=7;
LC:=REF(CLOSE,1);
X:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORYELLOW,LINETHICK1;
魔鬼:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),X,1),COLOR00FF00;
魔王:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),1,X),COLOR00FF00;
TJ0:=X=魔王;
TJ1:=X=魔鬼;
TJ2:=X<REF(X,1);
TJ3:=X>REF(1,X);
A:=EMA((EMA(CLOSE,29)+EMA(CLOSE,31)+EMA(CLOSE,33))/3,3),COLORYELLOW;
生命线:REF(A,1),LINETHICK2,COLORRED;
JRS1:=DRAWICON(CROSS(快线,慢线){TJ1 AND TJ2},快线,1);
DRAWICON(CROSS(C,前期高点) OR CROSS(C,近期高点) OR CROSS(C,高点压力),(前期高点 OR 近期高点 OR 高点压力)*0.95,23);
DRAWICON(CROSS(C,生命线), 生命线*0.98,11);
JRS2:=DRAWICON(CROSS(慢线,快线){ AND TJ3},慢线,2);
DRAWICON(FILTER(JRS1>0,1),L*0.995,1);
DRAWICON(FILTER(JRS2>0,1),H*1.005,2);
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),2,1),COLORLIRED;
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),2,0),COLORCYAN;
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,0) ,COLORWHITE {COLORCYAN};
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2,1),COLORLIRED;
{TOWER}
基础值:=IF(C<REF(C,1) AND REF(C,1)<REF(C,2) AND L<REF(L,1) AND L>REF(L,2),REF(C,2),IF(C>REF(C,1),C,REF(C,1)))NODRAW;
每股收益:FINANCE(38),NODRAW;
流通股:FINANCE(7)/100000000,NODRAW;
公积金:FINANCE(18),NODRAW;
每股未分配利润:FINANCE(32),NODRAW;

通达信好用多年主图指标公式

 

相关文章