在线检测未来函数

同花顺冷暖KDJ指标公式

来源:Internet,编辑:股旁网,2017-07-19

N:=9;
M1:=3;
M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,M1,1);
D:SMA(K,M2,1);
J:3*K-2*D;
D: EMA(0.667*REF(K,1)+0.333*K,2),colorgreen,LINETHICK1;
TT:=(2*CLOSE+OPEN+HIGH+LOW);
主导动能:TT/EMA(TT,4)-1,COLORSTICK;
FF:=主导动能;
STICKLINE(FF,0,FF,3.2,0),COLOR33CFDD;
STICKLINE(FF,0,FF,2.8,0),COLOR33DFDD;
STICKLINE(FF,0,FF,2,0),COLOR33EFDD;
STICKLINE(FF,0,FF,1,0),COLOR33FFDD;
STICKLINE(FF<0,0,FF,3.2,0),COLOR00CC00;
STICKLINE(FF<0,0,FF,2.8,0),COLOR00DD00;
STICKLINE(FF<0,0,FF,2,0),COLOR00EE00;
STICKLINE(FF<0,0,FF,1,0),COLOR00FF00;
STICKLINE(FF>REF(FF,1)AND FF<0,0,FF,3.2,0),COLORFF9900;
STICKLINE(FF>REF(FF,1)AND FF<0,0,FF,2.8,0),COLORFFAA00;
STICKLINE(FF>REF(FF,1)AND FF<0,0,FF,2,0),COLORFFBB00;
STICKLINE(FF>REF(FF,1)AND FF<0,0,FF,1,0),COLORFFCC00;
STICKLINE(FF>REF(FF,1)AND FF>0,0,FF,3.2,0),COLOR0000CC;
STICKLINE(FF>REF(FF,1)AND FF>0,0,FF,2.8,0),COLOR0000DD;
STICKLINE(FF>REF(FF,1)AND FF>0,0,FF,2,0),COLOR0000EE;
STICKLINE(FF>REF(FF,1)AND FF>0,0,FF,1,0),COLOR0000FF;
A:=EMA(C,14),colorwhite,LINETHICK1;
B:=(A-REF(A,1))/REF(A,1)*100,NODRAW;
支撑:IF(B>=0,REF(EMA(C,14),BARSLAST(CROSS(B,0))+1),DRAWNULL),colorred,LINETHICK2;
阻力:IF(B<0,REF(EMA(C,14),BARSLAST(CROSS(0,B))+1),DRAWNULL),colorgreen,LINETHICK2;
MA3:MA(C,2);
MA5:MA(C,5);
DRAWGBK(C<MA(C,9),STRIP(RGB(0,100,0),RGB(0,100,0),1));
DRAWGBK(C>MA(C,9)AND C/MA(C,9)<1.10,STRIP(RGB(100,0,0),RGB(100,0,0),1));
DRAWGBK(C/MA(C,9)>1.1,STRIP(RGB(120,0,120),RGB(120,0,120),1));
趋势线:MA(CLOSE,13),colorred,LINETHICK2;
涨:IF(短趋势线>REF(短趋势线,1),短趋势线,DRAWNULL),colorred,LINETHICK2;
平:=IF(短趋势线=REF(短趋势线,1),短趋势线,DRAWNULL),COLOR00FFFF,LINETHICK2;
跌:IF(短趋势线<REF(短趋势线,1),短趋势线,DRAWNULL),COLOR80FF00,LINETHICK2;

同花顺冷暖KDJ指标公式

 

相关文章