在线检测未来函数

通达信擒牛图主图指标公式

来源:Internet,编辑:股旁网,2017-07-18

跳空率:(O-REF(C,1))/REF(C,1)*100,COLORMAGENTA,NODRAW;
今板:=DYNAINFO(3)*1.1,DOTLINE,COLORYELLOW,NODRAW;
低1:=REF(LLV(L,150),3);
标底:=REFDATE(低1,DATE)*0.9;
Q:=-100*(HHV(H,10)-C)/(HHV(H,10)-LLV(L,10))+100,NODRAW;
Q1:=-100*(HHV(H,6)-C)/(HHV(H,6)-LLV(L,6))+100,NODRAW;
Q上:=Q>=REF(Q,1);
Q下:=Q<REF(Q,1);
Q1上:=Q1>=REF(Q1,1);
Q1下:=Q1<REF(Q1,1);
TJ01:=Q1>=80 AND Q1上;
TJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买盘:=IF(CLOSE>OPEN,TJ*(HIGH-LOW),IF(CLOSE<OPEN,TJ*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
卖盘:=IF(CLOSE>OPEN,TJ*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,TJ*(HIGH-LOW),VOL/2));
买增:=买盘>=REF(买盘,1);
卖减:=卖盘<=REF(卖盘,1);
正量:=买盘/VOL*100;
增量:=正量>=REF(正量,1);
量比:=正量/50;
TJ02:=正量>=80 AND 增量 AND 正量比>=1.5 AND REF(正量,1)<=90;{ AND 卖减}
分水岭:=EMA(((SLOPE(C,22)*20)+C),55),NODRAW;
操作线:=分水岭-(EMA(C,1)-分水岭);
操作辅线:=分水岭-(EMA(C,3)-分水岭);
开盘比:O/分水岭,NODRAW;
AA:=REF(操作线,1)/操作线;
背离:IF(AA>1,AA,1),COLORYELLOW,NODRAW;
反背离:背离/REF(背离,1),COLORYELLOW,NODRAW;
TJ03:=背离>=REF(背离,1) AND 背离>=1.02 AND 分水岭>=操作线;{开盘比<=1.09 AND }
散筹:=(WINNER(C*1.1)-WINNER(C*0.90));
庄筹:=WINNER(C);
利筹比:=庄筹/散筹,NODRAW;
散出:=散筹<=REF(散筹,1);
散出率:=REF(散筹,1)/散筹;
TJ04:=(利筹比>=2 AND 散出) OR 散出率>=1.3;
成本:COST(50),COLORWHITE;
昨收:=REF(C,1),COLORWHITE,NODRAW;
突破:=昨收*1.1>=COST(90);
牛:=TJ01 AND TJ02 AND TJ03 AND TJ04 AND 突破;
剔跳空:=(O-REF(C,1))/REF(C,1)*100<=5;
涨幅:=(C-REF(C,1))/REF(C,1)*100;
昨涨幅:=REF(涨幅,1);
TJ05:=剔跳空 AND 涨幅>=3.2 AND 昨涨幅<=6.5;
TJ005:=剔跳空 AND 涨幅>=6.2 AND 昨涨幅<=6.5;
可能涨停:=TJ01 AND TJ02 AND TJ03 AND TJ04 AND TJ05,COLORYELLOW,NODRAW;
追涨:=TJ01 AND TJ02 AND TJ03 AND TJ04 AND TJ005,COLORWHITE,NODRAW;
{条件}佛光乍现:=TJ01 AND TJ02 AND TJ03 AND TJ04 AND 剔跳空 AND 昨涨幅<=6.5;
DRAWRECTREL(0,0,999,990,RGB(188,168,168));
DRAWRECTREL(0,0,999,100,RGB(90,0,0));
DRAWBAND(COST(50),RGB(0,0,0),标底,RGB(0,0,255));
DRAWBAND(COST(50),RGB(255,160,255),COST(60),RGB(118,160,255));
DRAWBAND(COST(60),RGB(255,120,255),COST(70),RGB(98,120,255));
DRAWBAND(COST(70),RGB(255,80,255),COST(80),RGB(78,80,255));
DRAWBAND(COST(80),RGB(255,40,255),COST(90),RGB(58,0,255));
STICKLINE(C>0,COST(50),标底,0,1),COLORBLUE;
利筹:=庄筹>=散筹;
IF(操作辅线<=REF(操作辅线,1) AND 操作辅线<=分水岭,标底*1.06,标底),COLORWHITE,LINETHICK3;
IF(利筹,分水岭*0.96,分水岭),COLORYELLOW,LINETHICK2;
标底线:标底,COLORGREEN,LINETHICK3;
底线1:=标底*0.83,COLORGREEN,LINETHICK2;
底线2:=底线1*0.8,COLORGREEN,LINETHICK2;
DRAWBAND(标底,RGB(138,138,138),底线2,RGB(0,0,255));
界线:分水岭,COLORGREEN,LINETHICK2;
IF(分水岭>=REF(分水岭,1),分水岭,DRAWNULL),COLORRED,LINETHICK3;
STICKLINE(ISLASTBAR,DYNAINFO(3),DYNAINFO(3)*1.1,2.8,-1),COLORWHITE;
DRAWKLINE(H,O,L,C);
STICKLINE(佛光乍现 AND C>=REF(C,1),H,L,0,0),COLOR0099FF;
STICKLINE(佛光乍现 AND C>=REF(C,1),C,O,3.2,0),COLOR0000AA;
STICKLINE(佛光乍现 AND C>=REF(C,1),C,O,2.7,0),COLOR0000DD;
STICKLINE(佛光乍现 AND C>=REF(C,1),C,O,2.1,0),COLOR0022FF;
STICKLINE(佛光乍现 AND C>=REF(C,1),C,O,1.5,0),COLOR0066FF;
STICKLINE(佛光乍现 AND C>=REF(C,1),C,O,0.9,0),COLOR0099FF;
STICKLINE(佛光乍现 AND C>=REF(C,1),C,O,0.3,0),COLOR00DDFF;
五:COST(50),COLORYELLOW,LINETHICK1;
六:COST(60),COLORYELLOW,LINETHICK1;
七:COST(70),COLORYELLOW,LINETHICK1;
八:COST(80),COLORYELLOW,LINETHICK1;
顶:COST(90),COLORCYAN,LINETHICK2;
IF(牛 AND 佛光乍现,顶,DRAWNULL),POINTDOT,COLORWHITE,LINETHICK9;
IF(牛 AND 佛光乍现,顶,DRAWNULL),POINTDOT,COLORRED,LINETHICK5;
DRAWBAND(底线2+散筹*(标底-底线2),RGB(0,0,0),底线2,RGB(0,0,255));
STICKLINE(C>0,底线2+散筹*(标底-底线2),底线2,0,0),COLORBLUE;
散:底线2+散筹*(标底-底线2),COLORGREEN,LINETHICK2;
庄:底线2+庄筹*(标底-底线2),COLORRED,LINETHICK2;
STICKLINE(背离>=REF(背离,1) AND 背离>=1.018 AND 反背离>=1.018 AND 牛,散,底线2,0.8,0),COLORYELLOW;
IF(佛光乍现 AND 背离>=1.018,L*0.98,DRAWNULL),CROSSDOT,LINETHICK6,COLORMAGENTA;
IF(佛光乍现 AND 背离>=1.018,L*0.98,DRAWNULL),POINTDOT,LINETHICK4,COLORWHITE;
IF(佛光乍现 AND 背离>=1.023,L*0.95,DRAWNULL),CROSSDOT,LINETHICK6,COLORMAGENTA;
IF(佛光乍现 AND 背离>=1.023,L*0.95,DRAWNULL),POINTDOT,LINETHICK4,COLORWHITE;
IF(佛光乍现 AND 背离>=1.028,L*0.92,DRAWNULL),CROSSDOT,LINETHICK6,COLORMAGENTA;
IF(佛光乍现 AND 背离>=1.028,L*0.92,DRAWNULL),POINTDOT,LINETHICK4,COLORWHITE;
IF(佛光乍现 AND 背离>=1.033,L*0.89,DRAWNULL),CROSSDOT,LINETHICK6,COLORMAGENTA;
IF(佛光乍现 AND 背离>=1.033,L*0.89,DRAWNULL),POINTDOT,LINETHICK4,COLORWHITE;
IF(佛光乍现 AND 背离>=1.038,L*0.86,DRAWNULL),CROSSDOT,LINETHICK6,COLORMAGENTA;
IF(佛光乍现 AND 背离>=1.038,L*0.86,DRAWNULL),POINTDOT,LINETHICK4,COLORWHITE;
{IF(CROSS(庄筹,散筹),分水岭,DRAWNULL),POINTDOT,COLORWHITE,LINETHICK9;
IF(CROSS(庄筹,散筹),分水岭,DRAWNULL),POINTDOT,COLORRED,LINETHICK5;}
操作:=操作线,COLORWHITE,LINETHICK1;
DRAWTEXT(牛 AND 佛光乍现,L*0.96,'←牛?'),COLORWHITE;
DRAWTEXT(追涨,L*0.90,'←抢?'),COLORWHITE;
DRAWRECTREL(0,100,260,610,RGB(18,8,8));
DRAWTEXT_FIX(1,0.01,0.01,0,HYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.35,0.01,1,'涨幅:'),COLORYELLOW;
DRAWNUMBER_FIX(ISLASTBAR,0.45,0.01,1,涨幅),COLORWHITE;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.12,1,INTPART(REF(Q,1))),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND Q上,0.1,0.12,1,'Q↑'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND Q下,0.1,0.12,1,'Q↓'),COLORGREEN;
DRAWNUMBER_FIX(ISLASTBAR,0.17,0.12,1,INTPART(Q)),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND Q上 AND Q>=80,0.23,0.12,1,'★'),COLORYELLOW;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.2,1,INTPART(REF(Q1,1))),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND Q1上,0.1,0.2,1,'Q1↑'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND Q1下,0.1,0.2,1,'Q1↓'),COLORGREEN;
DRAWNUMBER_FIX(ISLASTBAR,0.17,0.2,1,INTPART(Q1)),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND Q1上 AND Q1>=80,0.23,0.2,1,'★'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.07,0.28,1,'背离'),COLORWHITE;
DRAWNUMBER_FIX(ISLASTBAR,0.18,0.28,1,背离),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.07,0.38,1,'反背离'),COLORWHITE;
DRAWNUMBER_FIX(ISLASTBAR,0.18,0.38,1,反背离),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND 买增 AND 卖减,0.23,0.28,1,'★'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND 可能涨停,0.16,0.50,1,'可能涨停'),COLORYELLOW;

通达信擒牛图主图指标公式

 

相关文章