在线检测未来函数

通达信高低点均线主图指标公式

来源:Internet,编辑:股旁网,2017-07-20

N:=10;
筹码集中度:=COST(10)/(COST(80)-COST(10)),NODRAW;
{高低点均线 N=1,500,10}
HH:=MA(REF(H,1),N);
LL:=MA(REF(L,1),N);
STICKLINE(C>HH AND C>O,O,C,-1,1),COLOR0000DD;
STICKLINE(C>HH AND C>O,H,C,0,0),COLOR0000DD;
STICKLINE(C>HH AND C>O,O,L,0,0),COLOR0000DD;
STICKLINE(C>HH AND C<=O,O,C,-1,0),COLOR0000DD;
STICKLINE(C>HH AND C<=O,H,O,0,0),COLOR0000DD;
STICKLINE(C>HH AND C<=O,C,L,0,0),COLOR0000DD;
STICKLINE(C<LL AND C>O,O,C,-1,1),COLORFFBB00;
STICKLINE(C<LL AND C>O,H,C,0,0),COLORFFBB00;
STICKLINE(C<LL AND C>O,O,L,0,0),COLORFFBB00;
STICKLINE(C<LL AND C<=O,O,C,-1,0),COLORFFBB00;
STICKLINE(C<LL AND C<=O,H,O,0,0),COLORFFBB00;
STICKLINE(C<LL AND C<=O,C,L,0,0),COLORFFBB00;
STICKLINE(C>LL AND C<HH AND C>O,C,O,-1,1),COLORAAAAAA;
STICKLINE(C>LL AND C<HH AND C>O,H,C,0,0),COLORAAAAAA;
STICKLINE(C>LL AND C<HH AND C>O,O,L,0,0),COLORAAAAAA;
STICKLINE(C>LL AND C<HH AND C<=O,C,O,-1,0),COLORAAAAAA;
STICKLINE(C>LL AND C<HH AND C<=O,H,O,0,0),COLORAAAAAA;
STICKLINE(C>LL AND C<HH AND C<=O,C,L,0,0),COLORAAAAAA;
UP:HH;
DN:LL;
BIAS:IF(C>HH,(C-HH)/HH*100,IF(C<LL,(C-LL)/LL*100,0)),NODRAW;
{突破上轨,在该K线的最高价画红点、向右画横线}
TP:=CROSS(C,HH) AND EVERY(REF(C,1)<REF(HH,1),3);{突破上轨}
TC:=BARSLAST(TP);
STICKLINE(TC>0,REF(H,TC),REF(H,TC),8,-1),COLORLIRED;{突破上轨,在该K线的最高价向右画横线};
●:IF(TP,H,DRAWNULL),POINTDOT,COLORRED,LINETHICK4; {突破上轨,在该K线的最高价画红点};
{突破上轨、突破横线 选股}
TPUP:=TP AND CROSS(C,REF(H,TC+1));{突破上轨AND前高}
{TPUP:=TP AND CROSS(C>REF(H,TC+1),0.5);} {两个TPUP式等同}
TPHX:=CROSS(C,REF(H*1.004,TC)) AND C>HH; {突破横线};
{TPHX:=CROSS(C>REF(H*1.004,TC),0.5) AND C>HH;} {两个TPHX式等同}
XG:=FILTER(({TPUP OR }TPHX),2);
DRAWICON(XG,L*0.998,1);
{倒数第2、第3根 K线高低点划线}
{HH2:=HHV(H,2);
LL2:=LLV(L,2);
T1:=BARSLAST(CURRBARSCOUNT=2);
T2:=BARSLAST(CURRBARSCOUNT=3);
DRAWLINE(REF(H,T1)=HH2,H,ISLASTBAR,REF(H,T1),0),COLORGREEN;
DRAWLINE(REF(L,T1)=LL2,L,ISLASTBAR,REF(L,T1),0),COLORYELLOW;
DRAWLINE(REF(H,T2)=REFX(HH2,1),H,ISLASTBAR,REF(H,T2),0),COLORGREEN;
DRAWLINE(REF(L,T2)=REFX(LL2,1),L,ISLASTBAR,REF(L,T2),0),COLORYELLOW;};

通达信高低点均线主图指标公式

 

相关文章