在线检测未来函数

同花顺SKDJ逃顶指标公式

来源:Internet,编辑:股旁网,2017-07-20

N:=9;
M:=3;
LOWV:=LLV(LOW,N);
HIGHV:=HHV(HIGH,N);
RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,M);
K:EMA(RSV,M);
D:MA(K,M);
DRAWICON(CROSS(D,K),K,'SELL');
DRAWICON(CROSS(K,D),D,'BUY');
趋势线:MA(CLOSE,13),colorred,LINETHICK2;
涨:IF(短趋势线>REF(短趋势线,1),短趋势线,DRAWNULL),colorred,LINETHICK2;
平:=IF(短趋势线=REF(短趋势线,1),短趋势线,DRAWNULL),COLOR00FFFF,LINETHICK2;
跌:IF(短趋势线<REF(短趋势线,1),短趋势线,DRAWNULL),COLOR80FF00,LINETHICK2;
A:=EMA(C,14),colorwhite,LINETHICK1;
B:=(A-REF(A,1))/REF(A,1)*100,NODRAW;
支撑:IF(B>=0,REF(EMA(C,14),BARSLAST(CROSS(B,0))+1),DRAWNULL),colorred,LINETHICK2;
阻力:IF(B<0,REF(EMA(C,14),BARSLAST(CROSS(0,B))+1),DRAWNULL),colorgreen,LINETHICK2;
VAR1:=REF(CLOSE,1);
VAR2:=SMA(MAX(CLOSE-VAR1,0),7,1)/SMA(ABS(CLOSE-VAR1),7,1)*100,coloryellow;
VAR21:IF(VAR2<20,40,20),colorbrown;
VAR22:IF(VAR2>80,60,80),COLORFFFF50;
VAR2↑:STICKLINE(FILTER(REF(VAR2,1)<20 AND VAR2>REF(VAR2,1),5),20,40,8,0),colorred;
VAR2↓:STICKLINE(FILTER(REF(VAR2,1)>80 AND VAR2<REF(VAR2,1),5),60,80,8,0),COLORFFFF50;
DRAWTEXT(FILTER(REF(VAR2,1)<20 AND VAR2>REF(VAR2,1),5),40 ,'买入' ),COLORFFFFFF;
DRAWTEXT(FILTER(REF(VAR2,1)>80 AND VAR2<REF(VAR2,1),5),60 ,'卖出' ),COLORFFFFFF;
80,colorgreen;
20,colorred;
MACD2:(EXPMA(CLOSE,30)-REF(EXPMA(CLOSE,30),1))/REF(EXPMA(CLOSE,30),1),COLORSTICK;
DIF2:EMA(SUM(MACD2,2),3),LINETHICK2,coloryellow;
入1:IF(DIF2>REF(DIF2,1),DIF2,DRAWNULL),colorred,LINETHICK2;
入2:IF(DIF2<REF(DIF2,1),DIF2,DRAWNULL),COLOR00FF00,LINETHICK2;
DEA2:MA(DIF2,5);

同花顺SKDJ逃顶指标公式

 

相关文章