在线检测未来函数

通达信神龙狙击主图指标公式

来源:Internet,编辑:股旁网,2017-07-20

HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:SQRT(HRY11),COLORGREEN,LINETHICK2;
IF(C>HRY33 AND HRY33 >=REF(HRY33 ,1), HRY33 ,DRAWNULL),LINETHICK2,COLORRED;
WLT1:=EMA(C,3);
WLT2:=EMA(C,5);
WLT3:=EMA(WLT2,5);
DRAWBAND(WLT1,RGB(255,255,0),WLT2,RGB(0,0,220));
HP:=(HHV(CLOSE,10)-LLV(CLOSE,10))/CLOSE<0.10;
LB:=VOL/MA(VOL,5);
X1:=(C+L+H)/3;
BB5:=ATAN(EMA(X1,7)-REF(EMA(X1,7),1))*3.1416*10;
EMA3:=EMA(C,3);
DRAWTEXT(FILTER(BB5>1 AND EMA(X1,7)>REF(EMA(X1,7),1),10),
LOW*0.99,'★∠45'),COLORFFFFFF;
TT:=FILTER(BB5>1 AND EMA(X1,7)>REF(EMA(X1,7),1),10);
MM:=WLT1>REF(WLT1,1) AND REF(WLT1,1)<REF(WLT1,2) ;
GG1:=CROSS(WLT1,WLT2);
TYP:= (HIGH + LOW + CLOSE)/3;
CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,5));
差值1:=ABS(REF(CCI1,1)-CCI1),LINETHICK0;
CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));
差值2:=ABS(REF(CCI2,1)-CCI2),LINETHICK0;
CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));
差值3:=ABS(REF(CCI3,1)-CCI3),LINETHICK0;
CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
差值4:=ABS(REF(CCI4,1)-CCI4),LINETHICK0;
CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
差值5:=ABS(REF(CCI5,1)-CCI5),LINETHICK0;
CCI:=(CCI1+CCI2+CCI3+CCI4+CCI5)/2,COLORRED,LINETHICK2;
WLT91:=HHV(CCI,13);
WLT92:=LLV(CCI,13)<-100;
WLT95:=COUNT(WLT92,13)>=3;
WLT93:=CCI>WLT91;
WLT96:=CROSS(CCI,100);
TJ91:=WLT95 AND WLT96;
JLP:=FILTER(TJ91,5);
超买:=MA(C,10)*IF(CAPITAL=0,1.04,1.1),POINTDOT,COLORGREEN,LINETHICK2;
超卖:=MA(C,10)*IF(CAPITAL=0,0.95,0.9),POINTDOT,COLORRED,LINETHICK2;
TEND:EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),42),POINTDOT,COLORFF00FF,LINETHICK4;
DD:=TEND>REF(TEND,1) AND REF(TEND,1) >REF(TEND,2);
GG2:=CROSS(WLT1,TEND);
HRY1:=LLV(LOW,55);
HRY2:=HHV(HIGH,21);
GG3:=C<HRY2*0.8 AND C>HRY33;
JJ1:=C<HRY1*1.62;
TJ1:=GG1;
TJ2:=GG2 AND JJ1;
TJ3:=GG1 AND GG3 ;
XG:=TJ1 OR TJ3 ;
XG2:=C<HRY2*0.86 OR LB>1;
XG1:=XG AND XG2 AND C>HRY33 AND JLP;
XG3:=XG AND C<HHV(HIGH,250)*0.3;
XG11:=XG1 OR XG3;
DRAWICON(XG11,LOW*0.97,23);
STICKLINE(XG,C,O,4,0),COLOR009999;
STICKLINE(XG,C,O,3,0),COLOR00BBBB;
STICKLINE(XG,C,O,1.5,0),COLOR00DDDD;
STICKLINE(XG,C,O,0.3,0),COLOR00FFFF;
SAL1:=HIGH>超买;
SAL2:=C<O AND (O-C)/C>0.03;
QQ:= C<WLT2;
QQ1:=CROSS(WLT2,WLT1);
QQ3:=HIGH>HRY1*1.38;
SAL01:= SAL1 AND SAL2 AND QQ AND QQ3;
SAL02:=QQ3 AND QQ1;
SAL:=SAL01 OR SAL02;
DRAWICON(SAL,HIGH*1.03,15);
STICKLINE(SAL,C,O,4,0),COLOR009900;
STICKLINE(SAL,C,O,3,0),COLOR00BB00;
STICKLINE(SAL,C,O,1.5,0),COLOR00DD00;
STICKLINE(SAL,C,O,0.3,0),COLOR00FF00;

通达信神龙狙击主图指标公式

 

相关文章