在线检测未来函数

通达信股海重生主图指标公式

来源:Internet,编辑:股旁网,2017-07-21

M1:=5;
M2:=10;
M3:=20;
M4:=30;
M5:=60;
N:=80;
N1:=14;
M:=3;
黄金柱B:=V/REF(V,1)>=2.0;
K1B:=SUMBARS(黄金柱B,1) ;
K2B:=SUMBARS(黄金柱B,2);
K3B:=SUMBARS(黄金柱B,3);
K4B:=SUMBARS(黄金柱B,4);
K5B:=SUMBARS(黄金柱B,5);
K6B:=SUMBARS(黄金柱B,6);
K7B:=SUMBARS(黄金柱B,7);
K8B:=SUMBARS(黄金柱B,8);
K9B:=SUMBARS(黄金柱B,9);
K10B:=SUMBARS(黄金柱B,10);
AABB:STICKLINE(K1B,REFV(L,K1B-1)*1.002,REFV(L,K1B-1),2,0),COLORYELLOW;
T60B:=V=HHV(V,60);
T100B:=V=HHV(V,100);
T2B:=V/REF(VOL,1)>=3;
T3B:=REF(C,1)/REF( O,1)<3;
MA5:=MA(CLOSE,M1),LINETHICK1,COLORYELLOW;
MA10:=MA(CLOSE,M2),LINETHICK1,COLORWHITE;
MA20:=MA(CLOSE,M3),LINETHICK1,COLORYELLOW;
稳健操盘线:MA(CLOSE,M4),POINTDOT,COLORRED;
MA60:=MA(CLOSE,M5),POINTDOT,LINETHICK1,COLORGREEN;
TR1:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N1,1);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),N1,1);
DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),N1,1);
PDI:=DMP*100/TR1,COLORRED;
MDI:=DMM*100/TR1,COLORGREEN;
ADX:=SMA(ABS(MDI-PDI)/(MDI+PDI)*100,N1,1),COLORYELLOW;
阶段线1:=16;
阶段线2:=30;
DMI1:=PDI>MDI AND ADX>=30;
DMI2:=PDI<MDI AND ADX>=30;
DMI3:=PDI>MDI AND 16<ADX<30;
DMI4:=PDI<MDI AND 16<ADX<30;
DMI5:=ADX<=16 AND (PDI>MDI OR PDI<MDI);
DMI6:=ADX>60;
ZT:=C/REF(C,1)>1.097;
XH:=FILTER(ZT,13);
BH:=BARSLAST(ZT);
CZ:=REF(H,BH)-REF(L,BH);
STICKLINE(ZT,O,C,3,0),COLORRED;
DRAWTEXT(ZT,L*0.98,' '),COLORF00FF0;
VARZT:=BARSLAST(C/REF(C,1)>1.097);
{涨跌停显示}
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0);
STICKLINE(涨停,O,C,3,0),COLORRED;
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF<-9.9,O,C,3,0),COLORGREEN;
VAR111:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买:=IF(CLOSE>OPEN,VAR111*(HIGH-LOW),IF(CLOSE<OPEN,VAR111*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED;
卖:=IF(CLOSE>OPEN,0-VAR111*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR111*(HIGH-LOW),0-VOL/2)),COLOR00FF00 ;
买卖差:=(买+卖);
买卖比:=ABS(买/卖);
水平面:=MA(CLOSE,89),COLORFF00FF;
BBI:=(MA(CLOSE,M1)+MA(CLOSE,M2)+MA(CLOSE,M3)+MA(CLOSE,M4))/4;
MA1:=MA(CLOSE,24),COLOR00E300,LINETHICK1;
V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
MA13:=MA(CLOSE,13);
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
A1:=MIN(O,C);
B1:=ABS(O-C);
T1:=FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10);
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
T2:=COUNT(CROSS(BBI,3),3)=1 AND CROSS(C,BBI);

T12:=V2>=1;
T0:=BARSLAST(T12);
L1:=REF(L,T0);
H1:=REF(H,T0);
L11:=MIN(REF(L,1),L);
L10:=MIN(L11,REF(L,2));
L21:=MAX(REF(L,1),L);
L20:=MAX(L21,REF(L,2));
T111:=(REF(V2>=1,3) OR REF(V2>=1,2) OR REF(V2>=1,1)) AND
((L10>L1 AND L20>H1) OR (L11>L1 AND L21>H1));
T11:=T111 AND REF(T111,1)=0;
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2X:=(1-7/100)*(DMA(CLOSE,V1));
V3:=(1+7/100)*(DMA(CLOSE,V1));
V5:=MA((LOW+HIGH+CLOSE)/3,5);
A1XX:=CROSS(MA(C,1),MA(C,3));
XG:=A1XX;
VAR1:=EMA(EMA(CLOSE,13),13);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
A10:=CROSS(控盘,0);
无庄控盘:=IF(控盘<0,控盘,0),COLORGRAY,NODRAW;
短线:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*20,LINETHICK0,COLORWHITE;
中线:=(CLOSE-MA(CLOSE,4))/MA(CLOSE,4)*20,LINETHICK0,COLORYELLOW;
红柱:=SMA(短线,3,1),LINETHICK0,COLORFF00FF;
绿柱:=SMA(中线,3,1),COLORSTICK,COLOR00FF00;
开始控盘:=IF(A10,5,0),LINETHICK1,COLORWHITE;
有庄控盘:=IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),COLORRED,NODRAW;
VAR2:=100*WINNER(CLOSE*0.95);
高度控盘:=IF(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0),COLORFF00FF,NODRAW;
主力出货:=IF(控盘<REF(控盘,1) AND 控盘>0,控盘,0),COLOR00FF00,NODRAW;
DIF1:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA1:=EMA(DIF1,9);
{柱状线}
AAA1:=(DIF1-DEA1)*2*60;
买入线:=10;
绝密:=AAA1-REF(AAA1,1),COLORMAGENTA;
金叉:=CROSS(EMA(C,1),EMA(C,3));
AAA上:=IF(AAA1>REF(AAA1,1),AAA1,DRAWNULL);
AAA下:=IF(AAA1<REF(AAA1,1),AAA1,DRAWNULL);
选股王:=CROSS(绝密,买入线);
突破买点:=有庄控盘 AND 选股王;
XXBB:= EMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*4,5)*100;
抄牛底:=REF(XXBB,1)<50 AND XXBB-REF(XXBB,1)>25;
蓝宝石:=抄牛底 AND 金叉;
拉升:=REF(XXBB,1)>50 AND XXBB-REF(XXBB,1)>40;
回踩买点:=主力出货 AND 选股王;
DRAWTEXT(回踩买点,L*0.995,'↖牛回踩'),COLORYELLOW;
DRAWICON(回踩买点,L*0.985,26);
抄底王:=金叉 AND 选股王,COLORGRAY;
DRAWTEXT(抄底王,L*0.985,'↖抄底王'),COLORWHITE;
DRAWICON(抄底王,L*0.975,27);
VV1:=(C*2+H+L)/4*10;
VV2:=EMA(VV1,13)-EMA(VV1,34);
VV3:=EMA(VV2,5); V4:=2*(VV2-VV3)*5.5;
主力撤:=IF(V4<=0,V4,0),COLORGREEN;
主力进:=IF(V4>=0,V4,0);
VV5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
V6:=EMA(3*VV5-2*SMA(VV5,18,1),5);
V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
V8:=(INDEXC*2+INDEXH+INDEXL)/4;
V9:=EMA(V8,13)-EMA(V8,34);
VA:=EMA(V9,3);
VB:=(V9-VA)/2;
大盘资金进场:=IF(VB>=0,VB,0),COLORYELLOW;
大盘资金撤走:=IF(VB<=0,VB,0),COLORRED;
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势线:=EMA(V11,3);
V12:=(趋势线-REF(趋势线,1))/REF(趋势线,1)*100;
准备现金:=STICKLINE(趋势线<=13,0,20,5,0),COLORCC9900;
AA:=(趋势线<=13) AND FILTER((趋势线<=13),15);
{DRAWTEXT (AA,30,'准备现金'),COLORCC9900;}
买入股票:=STICKLINE(趋势线<=13 AND V12>13,0,50,5,0),COLOR0099FF;
BB:=(趋势线<=13 AND V12>13) AND FILTER((趋势线<=13 AND V12>13),10) ;
{DRAWTEXT (BB,60,'买入股票'),COLOR0099FF;}
红宝石:=BB AND 金叉;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
YXF:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
加仓:=IF(FILTER(YXF=1,5),1,0),STICK,COLORFFFFFF,LINETHICK3;
A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV
(L,55))*100,5,1);
FY:=EMA(A51,5);
A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
QS:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));
绿宝石:=加仓 AND 金叉;
{DRAWTEXT (绿宝石,L*0.945,'绿宝石'),COLORFF00FF;}
LC20:=REF(CLOSE,1);
RSI20:=SMA(MAX(CLOSE-LC20,0),4.1,1)/SMA(ABS(CLOSE-LC20),4.1,1)*100;
底线买阳:=CROSS(RSI20,11)*1,COLORRED;
黄宝石:=底线买阳 AND 金叉;
{DRAWTEXT (黄宝石,L*0.935,'黄宝石'),COLOR0099FF;}
控盘B:=FILTER(IF(A10,1,0),5);
{分时价格原码}
JJ:=DYNAINFO(11);
{波段买卖原码}
P:=55;S:=8;
财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*10,COLORRED,LINETHICK2;
神:=EMA(财,M1),COLORGREEN,LINETHICK1;
{股价与均线偏离买卖条件}
BTJ1:=(C-JJ)/JJ<-0.005;
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ12:=LAST(JJ>=REF(JJ,1),5,1) AND (C-JJ)/JJ<0.005;
STJ1:=(C-JJ)/JJ>0.005;
{控盘买卖条件}
STJ01:=控盘<REF(控盘,1) AND 控盘>0.5;
STJ02:=控盘>0;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ22:=控盘>REF(控盘,1) AND 控盘<0 ;
{波段买卖条件}
BTJ3:=CROSS(财,神) AND 财<-0.3;
BTJ32:=CROSS(财,神) AND 财<-0.1;
STJ31:=CROSS(神,财);
STJ32:=CROSS(神,财) AND 财>1.618;
{以下为信号};
BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);
BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
BTJ82:=FILTER(BTJ12 AND BTJ22 AND BTJ32,13);
{DRAWICON(BTJ82,L*0.993,23);}{追买};
{DRAWICON(BTJ811,L*0.980,5);}
{DRAWICON(绿宝石,L*0.988,27);
DRAWICON(黄宝石,L*0.986,26);}
{DRAWICON(蓝宝石,L*0.982,24);
DRAWICON(红宝石,L*0.980,25);}
DRAWICON(追拉升,L*0.985,23);
{DRAWICON(突破买点,L*0.985,21);}
VAR1A:=EMA(EMA(CLOSE,9),9);
专用:=(VAR1A-REF(VAR1A,1))/REF(VAR1A,1)*1000;
VAR2A:=100*WINNER(CLOSE*0.95);
高手专用:=VAR2A>50 AND COST(85)<CLOSE AND 专用>0;
CV:=CLOSE;
BBIBOLL:=(MA(CV,3)+MA(CV,6)+MA(CV,12)+MA(CV,24))/4;
UPR:=BBIBOLL+6*STD(BBIBOLL,11);
DWN:=BBIBOLL-6*STD(BBIBOLL,11);
QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
XVL:=(IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2)));
HSL:=(XVL/20)/1.15;
强势股:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22))>1500;
绝杀前十:=高手专用 AND 高度控盘,COLORFF00FF;
{机构增仓}
JA1:=(DVOL/C)/2;
A2:=SUM(IF(JA1>100 AND CLOSE>REF(CLOSE,1),JA1,0),0);
A3:=SUM(IF(JA1>100 AND CLOSE<REF(CLOSE,1),JA1,0),0);
A4:=SUM(IF(JA1<100 AND CLOSE>REF(CLOSE,1),JA1,0),0);
A5:=SUM(IF(JA1<100 AND CLOSE<REF(CLOSE,1),JA1,0),0);
A6:=A2+A3+A4+A5;
机买:=(A2/A6)*100;
机卖:=(A3/A6)*100;
主力差:=机买-机卖;
机构加仓:=(主力差>=REF(主力差,1)+1.5)*50 AND 机买>机卖;
机构抄底:=金叉 AND 机构加仓;
DRAWTEXT (机构抄底,L*0.97,'↖机构入驻'),COLORCYAN;
机构追买:=机构加仓 AND 追拉升;
DRAWTEXT (机构追买,L*0.97,'↖机构吃单'),COLORFF00FF;
{猎庄}
LVAR2:=(CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100;
LVAR3:=SMA(LVAR2,20,1);
LVAR4:=SMA(LVAR3,15,1);
猎庄:=LVAR3-LVAR4;
多空分界:=1;
抓庄:=CROSS(猎庄,多空分界) AND 猎庄>=REF(MA(猎庄,多空分界),1);
跟庄抄底:=金叉 AND 抓庄;
{DRAWTEXT (跟庄抄底,L*0.97,'跟庄'),COLORCYAN;}
{稳健追涨}
WMA1:=EMA(CLOSE,5);
WMA2:=EMA(CLOSE,10);
WMA3:=EMA(CLOSE,20);
WMA4:=EMA(CLOSE,30);
WMA5:=EMA(CLOSE,60);
WVAR1:=MAX(WMA1,MAX(WMA2,MAX(WMA3,WMA4)));
WVAR2:=MIN(WMA1,MIN(WMA2,MIN(WMA3,WMA4)));
WVAR3:=(WVAR1-WVAR2)/WVAR2*1000;
WVAR4:=WMA1>REF(WMA1,1) AND WMA2>REF(WMA2,1) AND WMA3>REF(WMA3,1) AND WMA4>REF(WMA4,1) AND WMA5>REF(WMA5,1);
WVAR5:=WVAR3<5;
WVAR6:=COUNT(WVAR5=1,5)>0;
WVAR7:=CROSS(WMA1,WMA4);
稳健追涨:=WVAR4 AND WVAR6 AND WVAR7;
稳健抄底:=金叉 AND 稳健追涨;
{DRAWTEXT (稳健抄底,L*0.97,'稳健'),COLORCYAN;}
{均线粘合}
JDIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
JDEA:=EMA(JDIF,9);
JMACD:=(JDIF-JDEA)*2;
JBOLL:=MA(CLOSE,20);
JUPPER:=JBOLL+2*STD(CLOSE,20);
JLOWER:=JBOLL-2*STD(CLOSE,20);
JK1:=CLOSE>OPEN ;
JK2:=VOL>=2*REF(VOL,1);
JK3:=CROSS(JDIF,JDEA) AND JDIF<=0 ;
JK4:=CROSS(CLOSE,JBOLL);
均线粘合:=JK1 AND JK2 AND JK3 AND JK4 ;
机构拉升:=机构加仓 AND 均线粘合;
DRAWTEXT (机构拉升,L*0.97,'↖机构拉升'),COLORFF00FF;
VARC:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARC),H*1.02,2);
{DRAWTEXT(CROSS(82,VARC),2,'|逃庄'),COLORWHITE ;}
VAR34:=(INDEXC-REF(INDEXC, 1))/REF(INDEXC, 1);
VAR35:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1);
VAR36:=IF(VAR34>0.010, 0.900, 1) AND IF(VAR34>(-0.025), 1, 1.200);
VAR37:=VAR36*(VAR35-VAR34)*100;
VAR38:=SUM(VAR37, 10);
VAR310:=VAR38>20;
VAR326:=IF(CLOSE AND MA(VOL, 5)/240 AND CLOSE>REF(CLOSE, 1)*1.0 AND CLOSE,1,0);{VAR38>VAR39;}
VAR327:=IF(CLOSE/REF(CLOSE, 1)>1.050 AND VOL/CAPITAL*100<10 AND CLOSE<17 AND HIGH/CLOSE<1.010 AND VAR326>0, 1, 0);
{STICKLINE(VAR327=1,0,1,2,0),COLORYELLOW;}
DRAWICON(VAR327=1,L*0.95,1);
{DRAWTEXT(VAR327=1,-1,'|杀庄'),COLORWHITE;}
HZ:=EMA(CLOSE,13);
短波:=EMA(HZ,1);
中波:=EMA(HZ,26);
均线148天:=EMA(C,148);
成本:=SUM(AMOUNT,0)/SUM(VOL,0)/100;
HZ2:=EMA(HZ,8);
拉升一号:=CROSS(短波,HZ2);
DRAWICON(拉升一号,L*0.99,11);
DRAWTEXT (拉升一号,L*0.97,'↖黑马拉升'),COLORFF00FF;
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
红线上牛股起:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED,LINETHICK2;
绿线下熊股出:MA(红线上牛股起,6),COLORGREEN,LINETHICK2;
涨停紫色:STICKLINE((C-REF(C,1))/REF(C,1)>0.095,C,O,3.05,0),COLORMAGENTA;

通达信股海重生主图指标公式

 

相关文章