在线检测未来函数

通达信末日仓位管控指标公式

来源:Internet,编辑:股旁网,2017-07-27

X_1:=CLOSE-REF(CLOSE,1);
X_2:=100*EMA(EMA(X_1,5),3)/EMA(EMA(ABS(X_1),5),3);
X_3:=100*EMA(EMA(X_1,13),8)/EMA(EMA(ABS(X_1),13),8);
X_4:=X_2>X_3;
X_5:=IF(X_4,6,0);
X_6:=EMA(CLOSE,8)-EMA(CLOSE,13);
X_7:=EMA(X_6,5);
X_8:=X_6>X_7;
X_9:=IF(X_8,1,0);
X_10:=(EMA(CLOSE,3)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4;
X_11:=CLOSE>X_10;
X_12:=IF(X_11,5,0);
X_13:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
X_14:=SMA(X_13,3,1);
X_15:=SMA(X_14,3,1);
X_16:=X_14>X_15;
X_17:=IF(X_16,2,0);
X_18:=REF(CLOSE,1);
X_19:=SMA(MAX(CLOSE-X_18,0),5,1)/SMA(ABS(CLOSE-X_18),5,1)*100;
X_20:=SMA(MAX(CLOSE-X_18,0),13,1)/SMA(ABS(CLOSE-X_18),13,1)*100;
X_21:=X_19>X_20;
X_22:=IF(X_21,3,0);
X_23:=(-(HHV(HIGH,13)-CLOSE))/(HHV(HIGH,13)-LLV(LOW,13))*100;
X_24:=SMA(X_23,3,1);
X_25:=SMA(X_24,3,1);
X_26:=X_24>X_25;
X_27:=IF(X_26,4,0);
X_28:=X_8+X_16+X_21+X_26+X_11+X_4-3;
持股】:X_28>0,NODRAW,COLORMAGENTA;
持币】:X_28<0,NODRAW,COLORGREEN;
【变盘】:X_28=0,NODRAW,COLORYELLOW;
0,COLORYELLOW;
STICKLINE(【持股】,0,X_28,2,0),COLORMAGENTA;
STICKLINE(【持币】,0,ABS(X_28),2,0),COLORGREEN;
STICKLINE(【变盘】,0,1,2,0),COLORYELLOW;
DRAWICON(【持股】 AND REF(X_28,1)<=0,-0.8,7);
DRAWICON(【持币】 AND REF(X_28,1)>=0,-0.8,8);
【必买】:【持股】 AND REF(X_28,1)<=0 AND CROSS(CLOSE,EMA(CLOSE,5)) AND CROSS(CLOSE,EMA(CLOSE,10)) AND CROSS(CLOSE,EMA(CLOSE,20)) AND LOW>REF(LOW,1) AND MACD.MACD>0,NODRAW,COLORRED;
STICKLINE(【必买】,-0.5,0,3,0),COLORRED;
STICKLINE(【必买】,-0.5,-1,3,0),COLORYELLOW;

通达信末日仓位管控指标公式

 

相关文章