在线检测未来函数

通达信擒牛之神主图指标公式

来源:Internet,编辑:股旁网,2017-07-27

DRAWGBK(CURRBARSCOUNT=1, RGB(110,108,108),RGB(88,30,0),0,'',0);
P:=1;
K:=1;
N:=8;
ZGD:=HHV(H,60);
ZGD2:=CONST(ZGD);
ZDD:=LLV(L,60);
ZDD2:=CONST(ZDD);
GJ:=(C+H+L+O)/4;
明日阻力:=L+(GJ-L)+(C-L);
明日支撑:=L+(C-GJ);
KOH:=L>REF(H,1);
KOL:=H<REF(L,1);
HIF:=L>REF(H,BARSLAST(KOH)+1);
NHIF:=L<=REF(H,BARSLAST(KOH)+1);
LIF:=H<REF(L,BARSLAST(KOL)+1);
NLIF:=H>=REF(L,BARSLAST(KOL)+1);
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
RRRSV:=SMA(下档线,3,1);
KKK:=SMA(RRRSV,3,1);
DDDDD:=((3 * RRRSV) - (2 * KKK));
JJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
RSV24:=SMA(JJ12,3,1);
K24:=SMA(RSV24,3,1);
D24:=((3 * RSV24) - (2 * K24));
压力2:=IF(CROSS(D24,DDDDD),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDDDD)))),COLORFFFFFF;
底部:=LLV(HIGH,30),COLOR00FF00;
AA:=REF(H,N)=HHV(H,2*N+1);
AA1:=REF(L,N)=LLV(L,2*N+1);
QY:=BACKSET(AA,N+1);
QY1:=BACKSET(AA1,N+1);
CC:=FILTER(QY,N) AND H=HHV(H,N+1);
CC1:=FILTER(QY1,N) AND L=LLV(L,N+1);
DDD:=BARSLAST(CC);
DD1:=BARSLAST(CC1);
GDTS:=IF(CC,CURRBARSCOUNT,0); DDTS:=IF(CC1,CURRBARSCOUNT,0);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS); DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
GDCS1:=CONST(DINGBUTS); DDCS1:=CONST(DDTS1);
GDCS13:=CONST(REF(HIGH,GDCS1-1)); DDCS13:=CONST(REF(L,DDCS1-1));
DINGBUTS1:=REF(DINGBUTS,DDD+1); DDTS2:=REF(DDTS1,DD1+1);
GDCS2:=CONST(DINGBUTS1); DDCS2:=CONST(DDTS2);
GDCS23:=CONST(REF(HIGH,DINGBUTS1-1)); DDCS23:=CONST(REF(L,DDTS2-1));
XG1:=BACKSET(ISLASTBAR,GDCS1); XD1:=BACKSET(ISLASTBAR,DDCS1);
XG2:=BACKSET(ISLASTBAR,DINGBUTS1); XD2:=BACKSET(ISLASTBAR,DDTS2);
XDD:=IF(DDCS13<=DDCS23,XD1,XD2);
M:=INTPART(3*N/5);
AAA:=REF(H,M)=HHV(H,2*M+1);
QYY:=BACKSET(AAA,M+1);
CCC:=FILTER(QYY,M) AND H=HHV(H,M+1);
DDDD:=BARSLAST(CCC),NODRAW;
GDTSS:=IF(CCC,CURRBARSCOUNT,0);
DINGBUTSS:=IF(DDDD,REF(GDTSS,DDDD),GDTSS);
GDCS11:=CONST(DINGBUTSS);
DINGBUTS11:=REF(DINGBUTSS,DDDD+1);
GDCS22:=CONST(DINGBUTS11);
AA11:=REF(L,M)=LLV(L,2*M+1);
QY11:=BACKSET(AA11,M+1);
CC11:=FILTER(QY11,M) AND L=LLV(L,M+1);
DD11:=BARSLAST(CC11);
DDTSS:=IF(CC11,CURRBARSCOUNT,0);
DDTS11:=IF(DD11,REF(DDTSS,DD11),DDTSS);
DDCS11:=CONST(DDTS11);
DDTS22:=REF(DDTS11,DD11+1);
DDCS22:=CONST(DDTS22);
高点压力M:=DRAWLINE(CURRBARSCOUNT=GDCS22,H,CURRBARSCOUNT=GDCS11,H,1),COLORYELLOW,LINETHICK2;
低点支撑M:=DRAWLINE(CURRBARSCOUNT=DDCS22,L,CURRBARSCOUNT=DDCS11,L,1),COLORYELLOW,LINETHICK2;
BCG:=SUM(XG1,0); BCD:=SUM(XDD,0);
今日阻力:REF(明日阻力 , 1),NODRAW;
今日支撑:REF(明日支撑 , 1),NODRAW;
压力位:IF(ISLASTBAR,压力2,DRAWNULL),NODRAW;
底部位:IF(ISLASTBAR,底部,DRAWNULL),NODRAW;
高点压力:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1),CROSSDOT,COLORWHITE,LINETHICK2;
低点支撑:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1),CROSSDOT,COLORWHITE,LINETHICK2;
高F:=CONST(MAX(MAX(MAX(MAX(MAX(MAX(ZGD2,高点压力),低点支撑),GDCS13),GDCS23),高点压力M)
,低点支撑M));
低F:=CONST(MIN(MIN(MIN(MIN(MIN(MIN(ZDD2,DDCS23),DDCS13),低点支撑),高点压力),低点支撑M)
,高点压力M));
{DRAWBAND(高,RGB(100,100,100),低,RGB(100,100,100));}
DRAWBAND(高点压力,RGB(00,00,100),低点支撑,RGB(00,00,100));
ZGSTAR:=(高点压力+低点支撑)/2;
ZGEND:=CONST((高点压力+低点支撑)/2);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
{NN:=IF(BARSCOUNT(C)>=10,10,BARSCOUNT(C));
STICKLINE(C>=MA(C,NN),MA(C,NN),MA(C,NN*0.7),3,0),COLORYELLOW;
STICKLINE(C<MA(C,NN),MA(C,NN),MA(C,NN*0.7),4,0),COLORBLUE;}
DRAWKLINE(H,O,L,C);
下降压力线:DRAWLINE(HIGH>=HHV(HIGH,12),HIGH,LOW<=LLV(LOW,12),HHV(HIGH,4),1),LINETHICK1,COLOR00BC00;
上涨支撑线:DRAWLINE(LOW<=LLV(LOW,12),LOW,HIGH>=HHV(HIGH,4),LLV(LOW,4),1),LINETHICK1,COLORWHITE;
N1:=10;
T01:=CONST(HHVBARS(V,10)),COLOR0000FF,LINETHICK0;
量能平台:IF(CURRBARSCOUNT<=N1+15,CONST(IF(T01=0,C,REF(C,T01))),DRAWNULL)
,COLORLIBLUE,LINETHICK4;
新量能点:IF(CURRBARSCOUNT=T01+1,量能平台,DRAWNULL),CIRCLEDOT,COLORFFFFFF,LINETHICK7;
DRAWTEXT(ISLASTBAR,量能平台,' 量能平台'),COLOR00F0F0;
HV:=HHV(V,5)=V OR V/REF(V,1)>=5;
FT:=BARSLAST(HV);
量能平台1:=IF(HV,C,REF(C,FT));
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;
HAN:=DATE<1141230;
当前获利筹码:=IF(WINNER(CLOSE),WINNER(CLOSE)*100,0);
DRAWKLINE(H,O,L,C);
九十成本集中:=(COST(95)-COST(5))/(COST(95)+COST(5))*100;
成本价:COST(九十成本集中),LINETHICK2,COLORMAGENTA;
入1:IF(成本价>REF(成本价,1),成本价,DRAWNULL),COLORRED,LINETHICK1;
出1:IF(成本价<REF(成本价,1),成本价,DRAWNULL),COLORGREEN,LINETHICK1;
STICKLINE(成本价>LOW AND 成本价<HIGH,成本价,MIN(MIN(OPEN,CLOSE),成本价),3.2,0)*HAN,COLOR0077FF;
STICKLINE(成本价>LOW AND 成本价<HIGH,成本价,MIN(MIN(OPEN,CLOSE),成本价),2.5,0)*HAN,COLOR0099FF;
STICKLINE(成本价>LOW AND 成本价<HIGH,成本价,MIN(MIN(OPEN,CLOSE),成本价),1.9,0)*HAN,COLOR00BBFF;
STICKLINE(成本价>LOW AND 成本价<HIGH,成本价,MIN(MIN(OPEN,CLOSE),成本价),1.2,0)*HAN,COLOR00DDFF;
STICKLINE(成本价>LOW AND 成本价<HIGH,成本价,MIN(MIN(OPEN,CLOSE),成本价),0.3,0)*HAN,COLOR00FFFF;
STICKLINE(成本价>MIN(C,O) AND 成本价<MAX(C,O),成本价,MIN(OPEN,CLOSE),3.2,0)*HAN,COLOR0077FF;
STICKLINE(成本价>MIN(C,O) AND 成本价<MAX(C,O),成本价,MIN(OPEN,CLOSE),2.5,0)*HAN,COLOR0099FF;
STICKLINE(成本价>MIN(C,O) AND 成本价<MAX(C,O),成本价,MIN(OPEN,CLOSE),1.9,0)*HAN,COLOR00BBFF;
STICKLINE(成本价>MIN(C,O) AND 成本价<MAX(C,O),成本价,MIN(OPEN,CLOSE),1.2,0)*HAN,COLOR00DDFF;
STICKLINE(成本价>MIN(C,O) AND 成本价<MAX(C,O),成本价,MIN(OPEN,CLOSE),0.3,0)*HAN,COLOR00FFFF;
STICKLINE(成本价>HIGH,CLOSE,OPEN,3.2,0)*HAN,COLOR0077FF;
STICKLINE(成本价>HIGH,CLOSE,OPEN,2.5,0)*HAN,COLOR0099FF;
STICKLINE(成本价>HIGH,CLOSE,OPEN,1.9,0)*HAN,COLOR00BBFF;
STICKLINE(成本价>HIGH,CLOSE,OPEN,1.2,0)*HAN,COLOR00DDFF;
STICKLINE(成本价>HIGH,CLOSE,OPEN,0.3,0)*HAN,COLOR00FFFF;
STICKLINE(成本价>HIGH,HIGH,LOW,0,0),COLORGREEN;
M1:EMA(CLOSE,3),NODRAW;
M2:EMA(CLOSE,8),NODRAW;
M3:EMA(M2,13),NODRAW;
M4:EMA(M2,55),NODRAW;
VAR1:=EMA(M3,55);
M5:EMA(M4,81), COLORRED,LINETHICK0;
VAR2:=(REF(HIGH,1)+REF(LOW,1))/2;
VAR3:=MA(CLOSE,21)+2*STD(CLOSE,21);
DRAWICON(CROSS(VAR2,VAR3),HIGH*1.035,2);
DRAWTEXT(CROSS(VAR2,VAR3),HIGH*1.02,'卖出'), COLORGREEN;
DF2:=(C-REF(C,1))/REF(C,1)*100>5;
DF3:=(C-O)/O*100>4;
当天涨幅:(C-O)/O*100,NODRAW;
V型反转:=L<成本价 AND DF2;
V型反转2:=CROSS(C,成本价) AND DF2;
V型反转3:=L<成本价 AND DF3;
DRAWTEXT(V型反转,L*0.98,'↖狙击'),COLORCYAN;
DRAWTEXT(V型反转2,L*0.98,'↖狙击'),COLORCYAN;
DRAWTEXT(V型反转3,L*0.98,'↖狙击'),COLORCYAN;
STICKLINE(V型反转=1,C,O,3.2,0),COLORRED;
STICKLINE(V型反转2=1,C,O,3.2,0),COLORRED;
STICKLINE(V型反转3=1,C,O,3.2,0),COLORRED;
MA5L:MA(CLOSE,5),LINETHICK0;
MA20L:MA(CLOSE,20),COLORMAGENTA,LINETHICK0;
BT34L:=IF(BACKSET(BARSTATUS=2,34)=1,1,DRAWNULL);
近期成本线: BT34L*SUM(AMOUNT,13)/SUM(VOL,13)/100,LINETHICK2,COLORRED;
DRAWNUMBER(ISLASTBAR,近期成本线,近期成本线),COLORWHITE;
AHC1:=CLOSE*VOL;
AHC2:=EMA((EXPMA(AHC1,3)/EXPMA(VOL,3)+EXPMA(AHC1,6)/EXPMA(VOL,6)+EXPMA(AHC1,12)/EXPMA(VOL,12)+EXPMA(AHC1,24)/EXPMA(VOL,24))/4,13);
内下:AHC2*0.94,LINETHICK0;
AHC3:=EXPMA(CLOSE,9);
外下:EXPMA(AHC3*0.86,5),LINETHICK0;
抄底:=O<内下 AND C<外下;
千载难逢:=O>内下 AND C<外下;
STICKLINE(抄底,C,O,2.5,0),COLORYELLOW;
STICKLINE(抄底,H,L,0,0),COLORYELLOW;
DZ:=MIN(C,O)<MA(C,5) AND (MIN(C,O)-L)/O>0.05;
DRAWICON(DZ AND L< 外下,L*0.98,9);
MAA5K:MA(C,5),COLORFF00FF,LINETHICK0;
MAA10K:=MA(C,10),LINETHICK0;
MAA30K:MA(C,30),COLORRED,LINETHICK0;
KS:IF(MAA10K>MAA30K,MAA10K,MAA30K),COLORBLUE,LINETHICK0;
A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
A4:=SMA(A3,3,1);
A5:=SMA(A4,3,1);
A6:=3*A4-2*A5;
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
买K:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
DRAWTEXT(FILTER(买K=1,5),LOW-0.05,'↖买进'),COLORYELLOW;
STICKLINE(买K,OPEN,CLOSE,2,0),COLORYELLOW;
高:=REFDATE(HHV(H,N),DATE);
低:=REFDATE(LLV(L,N),DATE);
L1:=低+(高-低)*0.191;
L2:=低+(高-低)*0.382;
L3:=低+(高-低)*0.5;
L4:=低+(高-低)*0.618;
L5:=低+(高-低)*0.809;
DRAWTEXT(CURRBARSCOUNT=1,高*0.996,'高'),COLORGREEN;
阻力1:DRAWTEXT(CURRBARSCOUNT=1,L1*0.996,'191'),COLORFFFFFF;
阻力2:DRAWTEXT(CURRBARSCOUNT=1,L2*0.996,'382'),COLORFFFFFF;
阻力3:DRAWTEXT(CURRBARSCOUNT=1,L3*0.996,'500'),COLORFFFFFF;
阻力4:DRAWTEXT(CURRBARSCOUNT=1,L4*0.996,'618'),COLORFFFFFF;
阻力5:DRAWTEXT(CURRBARSCOUNT=1,L5*0.996,'809'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=1,低*1.004,'低'),COLORRED;
STICKLINE(CURRBARSCOUNT=13,高*1.001,高,100,0),COLOR00FFFF;
STICKLINE(CURRBARSCOUNT=13,L1,L1,100,0),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=13,L2,L2,100,0),COLORFF00FF;
STICKLINE(CURRBARSCOUNT=13,L3*1.001,L3,100,0),COLORFFFF00,LINETHICK3;
STICKLINE(CURRBARSCOUNT=13,L4,L4,100,0),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=13,L5,L5,100,0),COLORFF00FF;
STICKLINE(CURRBARSCOUNT=13,低*0.999,低,100,0),COLORRED,LINETHICK3;
DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLORCYAN;
DRAWTEXT_FIX(1,0.06,0,0,HYBLOCK),COLORWHITE;
DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLORCYAN;
DRAWTEXT_FIX(1,0.20,0,0,DYBLOCK),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR,0.65,0.8,0,HYBLOCK),COLOR00FF00;
DRAWTEXT_FIX(ISLASTBAR,0.75,0.8,0,DYBLOCK),COLOR00FFFF;
DRAWTEXT_FIX(ISLASTBAR,0.65,0.9,0,GNBLOCK),COLORYELLOW;
{以上为显示所属板块,地域,概念等}
DRAWTEXT_FIX(1,0.00,0.05,0,'主营业务:'),COLORRED;
DRAWTEXT_FIX(1,0.06,0.05,0,EXTERNSTR(0,3)),COLORWHITE;

通达信擒牛之神主图指标公式

 

相关文章