在线检测未来函数

通达信江恩八分法主图指标公式

来源:Internet,编辑:股旁网,2017-08-02

N:=107;
{背景}
DRAWGBK(O>0,RGB(33,47,58),RGB(0,0,0),0,'02',0);
高:REFDATE(HHV(H,N),DATE);
低:REFDATE(LLV(L,N),DATE);
H1:=高-(高-低)*1.000;
H2:=高-(高-低)*0.875;
H3:=高-(高-低)*0.750;
H4:=高-(高-低)*0.666;
H5:=高-(高-低)*0.625;
H6:=高-(高-低)*0.500;
H7:=高-(高-低)*0.375;
H8:=高-(高-低)*0.333;
H9:=高-(高-低)*0.250;
H10:=高-(高-低)*0.125;
H11:=高-(高-低)*0.000;
STICKLINE(CURRBARSCOUNT=15,高,高,100,1),COLORGREEN;
STICKLINE(CURRBARSCOUNT=15,H1,H1,100,1),COLORCYAN;
STICKLINE(CURRBARSCOUNT=15,H2,H2,100,1),COLORRED;
DRAWTEXT(CURRBARSCOUNT=2,H1,'0.000'),COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=2,H2,'0.125 ┄ 1/8'),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=2,H3,' 0.25 ┄ 1/4'),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=2,H4,' 0.333┄ 1/3'),COLOR808080;
DRAWTEXT(CURRBARSCOUNT=2,H5,' 0.375┄ 3/8'),COLOR808080;
DRAWTEXT(CURRBARSCOUNT=2,H6,' 0.50┄ 1/2'),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=2,H7,' 0.625┄ 5/8'),COLOR808080;
DRAWTEXT(CURRBARSCOUNT=2,H8,' 0.666┄2/3'),COLOR808080;
DRAWTEXT(CURRBARSCOUNT=2,H9,' 0.75┄ 3/4'),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=2,H10,' 0.875┄ 7/8'),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=2,H11,' 1.000'),COLORGREEN;
{比例坐标}
STICKLINE(CURRBARSCOUNT=15,H3,H3,100,1),COLORGREEN;
STICKLINE(CURRBARSCOUNT=15,H4,H4,100,1),COLOR808080;
STICKLINE(CURRBARSCOUNT=15,H6,H6,100,1),COLORGREEN;
STICKLINE(CURRBARSCOUNT=15,H5,H5,100,1),COLOR808080;
STICKLINE(CURRBARSCOUNT=15,低,低,100,1),COLORRED;
STICKLINE(CURRBARSCOUNT=15,H7,H7,100,1),COLOR808080;
STICKLINE(CURRBARSCOUNT=15,H8,H8,100,1),COLOR808080;
STICKLINE(CURRBARSCOUNT=15,H9,H9,100,1),COLORGREEN;
STICKLINE(CURRBARSCOUNT=15,H10,H10,100,1),COLORRED;
{价格坐标}
DRAWTEXT(CURRBARSCOUNT=30,高*0.997,CON2STR(高,2)),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=30,H10,CON2STR(H10,2)),COLORLIRED;
DRAWTEXT(CURRBARSCOUNT=30,H9,CON2STR(H9,2)),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=30,H8,CON2STR(H8,2)),COLORRED;
DRAWTEXT(CURRBARSCOUNT=30,H1,CON2STR(H1,2)),COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=30,H2,CON2STR(H2,2)),COLORRED;
DRAWTEXT(CURRBARSCOUNT=30,H3,CON2STR(H3,2)),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=30,H6,CON2STR(H6,2)),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=30,H4,CON2STR(H4,2)),COLORLIRED;
DRAWTEXT(CURRBARSCOUNT=30,H5,CON2STR(H5,2)),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=30,H7,CON2STR(H7,2)),COLORRED;
DRAWTEXT(CURRBARSCOUNT=30,低*1.00,CON2STR(低,2)),COLORGREEN;
{变色K线}
STICKLINE(C>REF(C,1),H,L,0,0),COLOR0099FF;
STICKLINE(C>REF(C,1),C,O,3.2,0),COLOR0000AA;
STICKLINE(C>REF(C,1),C,O,2.7,0),COLOR0000DD;
STICKLINE(C>REF(C,1),C,O,2.1,0),COLOR0022FF;
STICKLINE(C>REF(C,1),C,O,1.5,0),COLOR0066FF;
STICKLINE(C>REF(C,1),C,O,0.9,0),COLOR0099FF;
STICKLINE(C>REF(C,1),C,O,0.3,0),COLOR00DDFF;
STICKLINE(C<REF(C,1),H,L,0,1),COLORFF8800;
STICKLINE(C<REF(C,1),C,O,3.2,0),COLOR990000;
STICKLINE(C<REF(C,1),C,O,2.7,0),COLORCC0000;
STICKLINE(C<REF(C,1),C,O,2.1,0),COLORFF4400;
STICKLINE(C<REF(C,1),C,O,1.5,0),COLORFF8800;
STICKLINE(C<REF(C,1),C,O,0.9,0),COLORFFCC00;
STICKLINE(C<REF(C,1),C,O,0.3,0),COLORFFDD00;
STICKLINE(C=REF(C,1),H,L,0,1),COLORFFFFFF;
STICKLINE(C=REF(C,1),C,O,3.2,0),COLOR555555;
STICKLINE(C=REF(C,1),C,O,2.7,0),COLOR777777;
STICKLINE(C=REF(C,1),C,O,2.1,0),COLOR999999;
STICKLINE(C=REF(C,1),C,O,1.5,0),COLORBBBBBB;
STICKLINE(C=REF(C,1),C,O,0.9,0),COLORDDDDDD;
STICKLINE(C=REF(C,1),C,O,0.3,0),COLORFFFFFF;

通达信江恩八分法主图指标公式

 

相关文章