在线检测未来函数

同花顺顶底背离MACD指标公式

来源:Internet,编辑:股旁网,2017-08-09

DIFF:EMA(CLOSE,9)-EMA(CLOSE,17);
DEA:EMA(DIFF,8),COLOrffaa00;
MACD:=2*(DIFF-DEA);
STICKLINE(MACD>=0,MACD,0,4,1),colorred;
STICKLINE(MACD<0,MACD,0,4,1),colorgreen;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,4,0 ),colorcyan;
X1:IF(diff<0,diff,0),COLOR0000FF,LINETHICK2;
X2:IF(diff<0,0,diff),colormagenta,LINETHICK1;
X3:IF(diff<dea,diff,dea),COLOR00ff00,linethick1;
X4:IF(diff>dea,dea,dea),linethick1,COLORffbb11;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
STICKLINE(低位金叉,DEA*0.86,DEA*0.66,6,0),coloryellow;
DRAWTEXT(低位金叉,dea*0.86,' 低位金叉'),coloryellow;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,DEA*0.96,DEA*0.76,6,0),ColorFF00FF;
DRAWICON(二次金叉,dea*1.1,'BUY') ;
DRAWTEXT(二次金叉,DEA*0.96,' 二次金叉'),ColorFF00FF;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(底背离,DEA*1.09,DEA*0.86,6,0),Color00FF00;
DRAWLINE(A1=0,DEA,底背离,DEA,0),colorred,linethick1;
DRAWTEXT(底背离,DEA*1.09,' 底背离'),Color6600FF;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
DRAWLINE(A2=0,DEA,顶背离,DEA,0),colorgreen,linethick1;
DRAWTEXT(顶背离,DEA*1.2,' 顶背离'),Color00FF00;
TT:=(2*CLOSE+OPEN+HIGH+LOW);
主导动能:TT/EMA(TT,4)-1,COLORSTICK;
FF:=主导动能;
STICKLINE(FF>0,0,FF,8,0),COLOR33CFDD;
STICKLINE(FF>0 AND FF>REF(FF,1),0,FF,8,0),COLOR0000CC;
STICKLINE(FF<=0,0,FF,8,0),COLOR00CC00;
STICKLINE(FF<=0 AND FF>REF(FF,1),0,FF,8,0),COLORFF9900;
做多主导:IFF(FF>0 AND FF>REF(FF,1),FF,0),NODRAW,COLOR0000CC;
获利回吐:IFF(FF>0 AND FF<=REF(FF,1),FF,0),NODRAW,COLOR33CFDD;
做空主导:IFF(FF<=0 AND FF<=REF(FF,1),FF,0),NODRAW,COLOR00CC00;
空头回补:IFF(FF<=0 AND FF>REF(FF,1),FF,0),NODRAW,COLORFF9900;

同花顺顶底背离MACD指标公式

 

相关文章