在线检测未来函数

通达信锁定主升浪选股指标公式

来源:Internet,编辑:股旁网,2017-08-07

MA1:=MA(V,5);
MA2:=MA(V,60);
MA5:=MA(C,5);
MA10:=MA(CLOSE,10);
MA13:=MA(C,13);
MA20:=MA(C,20);
MA30:=MA(C,30);
MA60:=MA(C,60);
MA120:=MA(C,120);
MA250:=MA(C,250);
MA530:=MA(C,530);
V1:=240/FROMOPEN*DYNAINFO(8);
D:=MA(C,5);
A:=D>=REF(D,1) ;
B1:=C>D AND (C-D)/D<=0.08;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
MID := MA(CLOSE,26);
UPPER:=MID + 2*STD(CLOSE,26);
LOWER:=MID - 2*STD(CLOSE,26);
S2:=IF(NAMELIKE('S'),0,1);
S3:=IF(NAMELIKE('*'),0,1);
S4:=DYNAINFO(17)>0;
GX:=DIF>0 AND DEA>0 AND DIF>DEA AND S2 AND S3 AND S4 AND MA5>MA13 AND MA13>MA20 AND MA20>MA30 AND MA20>REF(MA20,1) AND MA13>REF(MA13,1) AND MA30>REF(MA30,1) AND MA5>REF(MA5,1) AND C> REF(C,1) AND VOL>REF(VOL,1) AND C>MA60 AND C>MA120 AND C>MA250 AND C>REF(HHV(C,150),1) AND C>UPPER AND UPPER>REF(UPPER,1) AND CROSS(CLOSE,UPPER);
ENTERLONG:=DIF>0 AND DEA>0 AND DIF>DEA AND S2 AND S3 AND S4 AND MA5>MA13 AND WINNER(C)>0.9 AND MA13>MA20 AND MA20>MA30 AND MA20>REF(MA20,1)AND MA13>REF(MA13,1) AND MA30>REF(MA30,1) AND MA5>REF(MA5,1) AND C> REF(C,1) AND VOL>REF(VOL,1) AND C>MA60 AND C>MA120 AND C>MA250 AND C>REF(HHV(C,50),1) AND C>UPPER AND UPPER>REF(UPPER,1) AND CROSS(CLOSE,UPPER) AND COUNT(C>MA(C,5),3)=3 AND LOW<MA(CLOSE,3) AND CLOSE>MA(CLOSE,5) AND MA5>MA20 AND MA5>MA60 AND MA13>MA60 AND V1>MA(V,60) AND V1>MA(V,5);
ENTERLONG1:=VOL>MA1 AND VOL>MA2 AND C>MA13 AND C>MA20 AND C>MA30 AND C>MA60 AND C>MA120 AND C>MA250 AND A AND B1 AND DIF=HHV(DIF,30) AND MACD=HHV(MACD,2) AND WINNER(C)>0.9 AND S2 AND S3 AND S4 AND MA5>MA13 AND WINNER(C)>0.9 AND MA13>MA20 AND MA20>MA30 AND MA20>REF(MA20,1) AND MA13>REF(MA13,1) AND MA30>REF(MA30,1) AND MA5>REF(MA5,1) AND C>REF(C,1)AND VOL>REF(VOL,1) AND C>REF(HHV(C,50),1) AND C>UPPER AND UPPER>REF(UPPER,1) AND CROSS(CLOSE,UPPER);
YY2:=V>MA(V,135);
YY3:=WINNER(C)>=0.85;
换手:=VOL/CAPITAL*100;
A1:=REF(CLOSE,1)<MA5 OR REF(CLOSE,1)<MA10 OR REF(CLOSE,1)<MA20 OR REF(CLOSE,1)<MA60 OR REF(CLOSE,1)<MA120 AND MA60>MA120;
A2:=CLOSE>OPEN AND VOL>REF(VOL,1) AND CLOSE>MAX(MA5,MAX(MA10,MAX(MA20,MAX(MA60,MA120))));
去除停牌:=DYNAINFO(13)>0;
DIF1:=EMA(CLOSE,10)-EMA(CLOSE,22);
DEA1:=EMA(DIF1,9);
MACD1:=(DIF1-DEA1)*2;
XG:=A1 AND A2 AND YY2 AND YY3 AND 换手>2.7 AND MACD1>REF(MACD,1) AND 去除停牌;
GX OR ENTERLONG OR ENTERLONG1 OR XG;

通达信锁定主升浪选股指标公式

 

相关文章