在线检测未来函数

通达信多年用过来的主图指标公式

来源:Internet,编辑:股旁网,2017-08-15

ZT:=BARSLAST(ABS(REF(C,1)*1.1-C)<=0.01);
IF(ZT<=10,REF((H+L)/2,ZT),DRAWNULL),LINETHICK2,COLORBLUE;
C6:=REF(C,1);
涨停:=IF((C-C6)*100/C6>=(10-0.01*100/C6),1,0);
STICKLINE(涨停,OPEN,CLOSE,3,1),COLORYELLOW;
STICKLINE(涨停,H,C,0,0),COLORYELLOW;
STICKLINE(涨停,O,L,0,0),COLORYELLOW;
STICKLINE(涨停,OPEN,CLOSE,1,0),COLORYELLOW;
STICKLINE(涨停,H,C,0,0),COLORYELLOW;
STICKLINE(涨停,O,L,0,0),COLORYELLOW;
BB:=CLOSE/REF(C,1)<=0.95;
STICKLINE(BB,O,C,3,0),COLORGREEN;
STICKLINE(BB,O,L,0,0),COLORGREEN;
STICKLINE(BB,H,C,0,0),COLORGREEN;
工作线:(EMA(C,40)),POINTDOT,LINETHICK5,COLORMAGENTA;
确认线:(EMA(C,62))LINETHICK2,COLORGREEN;
MA5:MA(CLOSE,5),COLORRED,LINETHICK2;
MA20:MA(C,20),COLORYELLOW,LINETHICK2;
获利%:WINNER(CLOSE)*100,NODRAW,COLORWHITE;
所属板块:=STRCAT('【所属板块】',STRCAT(STRCAT(STRCAT(' [行业]—',HYBLOCK),STRCAT(' [地域]—',DYBLOCK)),STRCAT(' [概念]—',GNBLOCK)));
DRAWTEXT_FIX(ISLASTBAR,0.005,0.02,0,所属板块),COLORWHITE;
止损价:=STICKLINE(ISLASTBAR,HHV(C,5)*0.95,HHV(C,5)*0.95,20,2);
支撑价:H*0.95,LINETHICK0.5,COLORRED;
{止盈价盘中破掉三十分钟不再站上来,立即止盈出局}
阻力价:HHV(HIGH,19),LINETHICK1,COLORRED,NODRAW;
Y:=(MA(C,5)-MA(C,30))/MA(C,5)*100;
YY1:=C>MA(C,5) AND OPEN<MA(C,5);{龙出海}
YY3:=C>MA(C,10) AND OPEN<MA(C,10);
YY5:=C>MA(C,30) AND OPEN<MA(C,30);
DRAWTEXT(YY1 AND YY5 AND YY3,LOW-0.2,'←龙出海'),COLORYELLOW;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
主力成本:EMA(X,13),COLORFF00FF,LINETHICK0;
ZZ:=(O+H+L)/3;
YC:=(H+L)/2;
YCHJX:=(EMA(ZZ,4))+(YC-REF(ZZ,3))/4;
今日买点:=EMA(ZZ,3),COLORYELLOW,LINETHICK0;
明日买点:=YCHJX,LINETHICK0;
昨测今日买点:=REF(YCHJX,1),LINETHICK0;

通达信多年用过来的主图指标公式

 

相关文章