在线检测未来函数

通达信KDJ分时指标公式

来源:Internet,编辑:股旁网,2017-08-15

N:=45;
M1:=15;
M2:=15;
DRAWGBK(C>1,RGB(0,0,0),RGB(1,1,1),1,0,0);
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:SMA(K,M2,1),COLORYELLOW;
J:(3*K-2*D),COLORWHITE;
NOTEXTA:-10,COLORRED,DOTLINE;
NOTEXTB:50,COLORGRAY,DOTLINE;
NOTEXTC:120,COLORGREEN,DOTLINE;
A1:=CROSS(J,100);
B1:=CROSS(100,J);
A2:=CROSS(5,J);
B2:=CROSS(J,5);
NOTEXTAA1:DRAWLINE(A1,100,B1,100,0),COLORFF8000,LINETHICK1;
NOTEXTAA2:DRAWLINE(A2,5,B2,5,0),COLORRED,LINETHICK1;
NOTEXTAA:IF(J>100,J,DRAWNULL),LINETHICK2,COLORFF8000;
NOTEXTBB:IF(J<5,J,DRAWNULL),LINETHICK2,COLORRED;
STICKLINE(J>100,100,J,2,1),COLORFF8000;
STICKLINE(J<5,5,J,2,1),COLORRED;
DRAWTEXT(BARSLAST(J>100),NOTEXTAA1,' 风险区'),COLORGREEN;
DRAWTEXT(BARSLAST(J<5),NOTEXTAA2,' 机会区'),COLORRED;
DIF:(EMA(CLOSE,12) - EMA(CLOSE,26)),COLORFFFF00,NODRAW;
DEA:EMA(DIF,9),COLORGREEN,NODRAW;

通达信KDJ分时指标公式

 

相关文章