在线检测未来函数

通达信筹码趋势启动指标公式

来源:Internet,编辑:股旁网,2017-08-16

VARX:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VARX1:=SMA(VARX,3,1);
VARX2:=SMA(VARX1,3,1);
VARX3:=REF(LOW,1);
VARX4:=SMA(ABS(LOW-VARX3),3,1)/SMA(MAX(LOW-VARX3,0),3,1)*100;
VARX5:=EMA(IF(CLOSE*1.2,VARX4*10,VARX4/10),3);
VARX6:=LLV(LOW,30);
VARX7:=HHV(VARX5,30);
VARX8:=IF(LLV(LOW,58),1,0);
筹码短期:=DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,8)/(AMOUNT/VOL/100)/100));
筹码中期:=DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100));
筹码长期:=DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,20)/(AMOUNT/VOL/100)/100));DIF:=EMA(EMA(CLOSE,18)-EMA(CLOSE,34),11);
MACD:=EMA(EMA(DIF,11),11),COLOR58FF58;
DEF:=2*(DIF-MACD),COLORFFFF00,LINETHICK0;
MMS:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));
MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));
MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));
VARR1:=(HHV(HIGH,24)-CLOSE)/(HHV(HIGH,24)-LLV(LOW,24))*100;
VARR2:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
VARR3:=(2*CLOSE+HIGH+LOW)/4;
VARR4:=LLV(LOW,26);
VARR5:=HHV(HIGH,34);
VARR6:=EMA((VARR3-VARR4)/(VARR5-VARR4)*100,16);
VARR7:=SMA((SMA(VARR2,3,1)+3),3,1),LINETHICK3;
VARR8:=EMA(VARR6,7);
VARR9:=SMA(VARR1,3,1);
VARR10:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VARR11:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VARR12:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;
VARR13:=(VARR10+VARR11+VARR12)/3;
VARR14:=IF(VARR13<=-20,10,0);
VARR15:=HHV(VARR14,10);
VARR24:=LLV(LOW,36);
VARR25:=HHV(HIGH,30);
VARR26:=EMA((CLOSE-VARR24)/(VARR25-VARR24)*4,4)*25;
VARB27:=(((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100)/2+22)*1;
VARB28:=(((CLOSE -(((EMA(AMOUNT,13) /EMA(VOL,13)) / 100))) / (((EMA(AMOUNT,13) /EMA(VOL,13)) / 100))) * 100);
箱顶:HHV(MA((CLOSE),5),30)COLORRED,LINETHICK2;箱底:LLV(MA((CLOSE),5),30) ;长底:LLV(MA((CLOSE),5),120)LINETHICK2;
JJ:=(CLOSE+HHV(MA((CLOSE),5),2)+LLV(MA((CLOSE),5),2))/3;
DARS:=IF((DATETODAY(DATE))<9999,1,DRAWNULL);
AA:=EMA(JJ,3)*DARS;
BB:=REF(AA,1);
STICKLINE(AA>BB,AA,BB,3,0),COLORYELLOW,;
STICKLINE(AA<BB,AA,BB,3,0),COLORLICYAN,;
XSR:=1970330;XS:=IF(DATE<XSR,1,DRAWNULL);DS:="MFI.MFI"(12,9)*XS;{反特别版处理}A9:= DATETODAY(DATE)*XS;{反特别版处理}
DS1:=IF(A9<9999{0324},4.55,-DS);DS31:=IF(A9<9999{90324},4.7,-DS);DS41:=IF(A9<9999{324},4.45,-DS);DS51:=IF(A9<9999{2094},4.75,-DS);DS61:=IF(A9<9999{0324},4.65,-DS);DS71:=IF(A9<9999{0324},4.5,-DS);DS81:=IF(A9<9999{2094},4.6,-DS);
DS2:=IF(A9<9999{230},0.01,-DS);DS5:=IF(A9<9999{200},0.02,-DS);DS7:=IF(A9<9999{2},0.03,-DS);DS9:=IF(A9<9999{230},0.04,-DS);DS11:=IF(A9<9999{230},0.05,-DS);
DS13:=IF(A9<9999{30},0.06,-DS);DS15:=IF(A9<9999{20},0.002,-DS);DS17:=IF(A9<9999{230},0.004,-DS);DS19:=IF(A9<9999{230},0.006,-DS);DS21:=IF(A9<9999{230},0.008,-DS);
AJ2:=A9>146 AND A9<200;AJ21:=A9>144 AND A9<146;AJ22:=A9>142 AND A9<144;AJ23:=A9>140 AND A9<142;AJ24:=A9>138 AND A9<140;AJ25:=A9>136 AND A9<138;AJ26:=A9>134 AND A9<136;
AI29:=A9>704 AND A9<706;AI28:=A9>702 AND A9<704;AI27:=A9>698 AND A9<700;AI2:=A9>696 AND A9<698;AI21:=A9>694 AND A9<696;
AI22:=A9>692 AND A9<694;AI23:=A9>690 AND A9<692;AI24:=A9>688 AND A9<690;AI25:=A9>686 AND A9<688;AI26:=A9>684 AND A9<686;
AH2:=A9>1315 AND A9<1365;AH21:=A9>1311 AND A9<1313;AH22:=A9>1309 AND A9<1311;AH23:=A9>1307 AND A9<1309;
AH24:=A9>1305 AND A9<1307;AH25:=A9>1303 AND A9<1305;AH26:=A9>1299 AND A9<1301;AH27:=A9>1297 AND A9<1299;
AA28:=A9>1860 AND A9<1862;AA27:=A9>1856 AND A9<1858;AA2:=A9>1854 AND A9<1856;AA21:=A9>1852 AND A9<1854;AA22:=A9>1848 AND A9<1850;
AA23:=A9>1846 AND A9<1848;AA24:=A9>1844 AND A9<1846;AA25:=A9>1842 AND A9<1844;AA26:=A9>1840 AND A9<1842;
AL2:=A9>3290 AND A9<3292;AL21:=A9>3066 AND A9<3068;AL22:=A9>3288 AND A9<3290;AL23:=A9>3292 AND A9<3294;AL24:=A9>3294 AND A9<3296;
AL25:=A9>3296 AND A9<3298;AL26:=A9>3068 AND A9<3070;AL27:=A9>93054 AND A9<3056;AL28:=A9>93020 AND A9<3044;
AK27:=A9>4711 AND A9<4713;AK2:=A9>4709 AND A9<4711;AK21:=A9>4707 AND A9<4709;AK22:=A9>4705 AND A9<4707;AK23:=A9>4703 AND A9<4705;
AK24:=A9>4701 AND A9<4703;AK25:=A9>4699 AND A9<4701;AK26:=A9>4697 AND A9<4699;AK28:=A9>4695 AND A9<4697;
AB2:=A9>5280 AND A9<5320;AB21:=A9>5278 AND A9<5280;AB22:=A9>5276 AND A9<5278;AB23:=A9>5274 AND A9<5276;
AB24:=A9>5272 AND A9<5274;AB25:=A9>5270 AND A9<5272;AB26:=A9>5268 AND A9<5270;AB27:=A9>5266 AND A9<5268;
AC2:=A9>6520 AND A9<6523;{14180=6523}AC21:=A9>6523 AND A9<6526;AC22:=A9>6526 AND A9<6529;AC23:=A9>6529 AND A9<6532;AC24:=A9>6532 AND A9<6535;
AE2:=A9>6828 AND A9<6878;AF2:=A9>7132 AND A9<7134;AF21:=A9>7134 AND A9<7136;AF22:=A9>7136 AND A9<7138;AF23:=A9>7138 AND A9<7140;
AG2:=A9>7337 AND A9<7339;AG22:=A9>7339 AND A9<7341;AG222:=A9>7341 AND A9<7343;
AX2:=A9>8014 AND A9<8016;AX22:=A9>8016 AND A9<8018;AX222:=A9>8018 AND A9<8020;
AP2:=A9>8480 AND A9<8482;AP22:=A9>8482 AND A9<8484;AP222:=A9>8484 AND A9<8486;
AQ:=A9>8558 AND A9<8560;AQ2:=A9>8556 AND A9<8558;AQ22:=A9>8554 AND A9<8556;AQ222:=A9>8552 AND A9<8554;AQ2222:=A9>8550 AND A9<8552;
AQ23:=A9>8548 AND A9<8550;AQ24:=A9>8546 AND A9<8548;AQ25:=A9>8544 AND A9<8546;AQ26:=A9>8542 AND A9<8544;AQ27:=A9>8540 AND A9<8542;
AM2:=A9>99015 AND A9<9017;AM21:=A9>99017 AND A9<9019;AM22:=A9>99019 AND A9<9021;AM23:=A9>99021 AND A9<9023;AM24:=A9>99023 AND A9<9025;
AM25:=A9>99025 AND A9<9027;AM26:=A9>99027 AND A9<9029;AM27:=A9>99029 AND A9<9031;AM28:=A9>99037 AND A9<9040;
AH1:=A9>786 AND A9<788;AH11:=A9>784 AND A9<786;AH12:=A9>782 AND A9<784;AH13:=A9>794 AND A9<796;AH14:=A9>792 AND A9<794;AH15:=A9>790 AND A9<792;AH16:=A9>788 AND A9<790;
AI1:=A9>520 AND A9<522;AI11:=A9>530 AND A9<532;AI12:=A9>522 AND A9<524;AI13:=A9>528 AND A9<530;AI14:=A9>526 AND A9<528;AI15:=A9>524 AND A9<526;AI16:=A9>522 AND A9<524;
AG1:=A9>1360 AND A9<1362;AG11:=A9>1358 AND A9<1360;AG12:=A9>1356 AND A9<1358;AG13:=A9>1354 AND A9<1356;
AG14:=A9>1366 AND A9<1368;AG15:=A9>1364 AND A9<1366;AG16:=A9>1362 AND A9<1364;
AL1:=A9>2333 AND A9<2383;AL11:=A9>2331 AND A9<2333;AL12:=A9>2329 AND A9<2331;AL13:=A9>2327 AND A9<2329;AL14:=A9>2325 AND A9<2327;
AL15:=A9>2323 AND A9<2325;AL16:=A9>2321 AND A9<2323;AL17:=A9>2319 AND A9<2321;
AA1:=A9>3826 AND A9<3876;AA11:=A9>3824 AND A9<3826;AA12:=A9>3822 AND A9<3824;AA13:=A9>3820 AND A9<3822;AA14:=A9>3818 AND A9<3820;
AA15:=A9>3816 AND A9<3818;AA16:=A9>3814 AND A9<3816;AA17:=A9>3812 AND A9<3814;
AK1:=A9>4856 AND A9<4906;AK11:=A9>4854 AND A9<4856;AK12:=A9>4852 AND A9<4854;AK13:=A9>4850 AND A9<4852;
AK14:=A9>4848 AND A9<4850;AK15:=A9>4846 AND A9<4848;AK16:=A9>4844 AND A9<4846;AK17:=A9>4842 AND A9<4844;
AB0:=A9>6140 AND A9<6142;AB1:=A9>6142 AND A9<6144;AB11:=A9>6144 AND A9<6146;AB12:=A9>6146 AND A9<6148;
AB13:=A9>6148 AND A9<6150;AB14:=A9>6152 AND A9<6154;AB15:=A9>6154 AND A9<6156;AB16:=A9>6156 AND A9<6158;AB17:=A9>6158 AND A9<6160;AB18:=A9>6160 AND A9<6162;
AC1:=A9>6802 AND A9<6804;AC11:=A9>6800 AND A9<6802;AC12:=A9>6798 AND A9<6800;AC13:=A9>6796 AND A9<6798;AC14:=A9>6794 AND A9<6796;AC15:=A9>6792 AND A9<6794;
AC16:=A9>96790 AND A9<6892;AC17:=A9>96788 AND A9<6790;
AE14:=A9>6914 AND A9<6916;AE12:=A9>6908 AND A9<6910;AE11:=A9>6910 AND A9<6912;AE1:=A9>6912 AND A9<6914;
AF1:=A9>7258 AND A9<7260;AF11:=A9>7260 AND A9<7262;AF111:=A9>7262 AND A9<7264;AF1111:=A9>7264 AND A9<7266;
AX1:=A9>7422 AND A9<7499; AW1:=A9>7420 AND A9<7422; AX11:=A9>7418 AND A9<7420; AW11:=A9>8095 AND A9<8099;
AWP1:=A9>8932 AND A9<8934; AWP11:=A9>8934 AND A9<8936; AWP12:=A9>8936 AND A9<8938; AWP13:=A9>8938 AND A9<8940; AWP14:=A9>8942 AND A9<8944; AWP15:=A9>8944 AND A9<8946; AWP16:=A9>8946 AND A9<8948;
个股:=5*POW(SMA((C-LLV(L,65))/(HHV(H,65)-LLV(L,65)*DARS),6,1),2)*XS;
{}Y1:=IF(A9<8948,0.5*(AWP15+AWP16+AWP13+AWP14+AK17+AH11+AH12+AH13+AH14+AH15+AH16+AI11+AI12+AI13+AI14+AI15+AI16+AG11+AG12+AG13+AG14+AG15+AG16+AL11+AL12+AL13+AL14+AL15+AL16+AL17+AA11+AA12+AA13+AA14+AA15+AA16+AA17+AK11+AK12+AK13+AK14+AK15+AK16+AWP12+AWP11+AWP1+AA1+AB1+AC1+AE1+AF1+AG1+AH1+AI1+AK1+AL1+AX1+AW1+AW11+AX11+AF11+AF111+AF1111+AE11+AE12+AE14+AC11+AC12+AC13+AC14+AC15+AC16+AC17+AB11+AB12+AB13+AB14+AB15+AB16+AB17+AB0+AB18)*14,DS1)*DARS;{反特别版处理}
{}Y31:=IF(A9<8940,0.5*(AA1+AB1+AC1+AE1+AF1+AG1+AH1+AI1+AK1+AL1+AX1+AW1+AW11+AX11+AF11+AF111+AF1111)*14,DS31);{反特别版处理}
{}Y41:=IF(A9<8940,0.5*(AA1+AB1+AC1+AE1+AF1+AG1+AH1+AI1+AK1+AL1+AX1+AW1+AW11+AX11+AF11+AF111+AF1111)*14,DS41);{反特别版处理}
{}Y51:=IF(A9<8940,0.5*(AA1+AB1+AC1+AE1+AF1+AG1+AH1+AI1+AK1+AL1+AX1+AW1+AW11+AX11+AF11+AF111+AF1111)*14,DS51);{反特别版处理}
{}Y61:=IF(A9<8940,0.5*(AA1+AB1+AC1+AE1+AF1+AG1+AH1+AI1+AK1+AL1+AX1+AW1+AW11+AX11+AF11+AF111+AF1111)*14,DS61);{反特别版处理}
}Y71:=IF(A9<8940,0.5*(AA1+AB1+AC1+AE1+AF1+AG1+AH1+AI1+AK1+AL1+AX1+AW1+AW11+AX11+AF11+AF111+AF1111)*14,DS61);{反特别版处理}
Y81:=IF(A9<8940,0.5*(AA1+AB1+AC1+AE1+AF1+AG1+AH1+AI1+AK1+AL1+AX1+AW1+AW11+AX11+AF11+AF111+AF1111)*14,DS61);{反特别版处理}
{}Y2:=IF(A9<9050,0.5*(AI29+AF23+AF21+AF22+AK27+AK28+AL27+AL28+AA27+AA28+AI27+AI28+AJ21+AJ22+AJ23+AJ24+AJ25+AJ26+AI21+AI22+AI23+AI24+AI25+AI26+AH21+AH22+AH23+AH24+AH25+AH26+AH27+AA21+AA22+AA23+AA24+AA25+AA26+AL21+AL22+AL23+AL24+AL25+AL26+AK21+AK22+AK23+AK24+AK25+AK26+AB2+AB21+AB22+AB23+AB24+AB25+AB26+AB27+AM28+AM27+AM26+AM25+AM24+AM23+AM22+AM21+AM2+AA2+AH2+AI2+AJ2+AK2+AL2+AC2+AE2+AF2+AG2+AX2+AP2+AX22+AX222+AP22+AP222+AQ2+AQ22+AQ222+AQ+AQ2222+AG22+AG222+AQ23+AQ24+AQ25+AQ26+AQ27+AC21+AC22+AC23+AC24),DS2)*DARS;{反特别版处理}
{}Y5:=IF(A9<9050,0.5*(AA2+AH2+AI2+AJ2+AL2+AC2+AE2+AF2+AG2+AX2+AP2+AX22+AX222+AP22+AP222+AQ2+AQ22+AQ222+AQ+AQ2222+AG22+AG222),DS5);{反特别版处理}
{}Y7:=IF(A9<9050,0.5*(AA2+AH2+AI2+AJ2+AL2+AC2+AE2+AF2+AG2+AX2+AP2+AX22+AX222+AP22+AP222+AQ2+AQ22+AQ222+AQ+AQ2222+AG22+AG222),DS7);{反特别版处理}
{}Y9:=IF(A9<9050,0.5*(AA2+AH2+AI2+AJ2+AL2+AC2+AE2+AF2+AG2+AX2+AP2+AX22+AX222+AP22+AP222+AQ2+AQ22+AQ222+AQ+AQ2222+AG22+AG222),DS9);{反特别版处理}
{}Y11:=IF(A9<9050,0.5*(AA2+AH2+AI2+AJ2+AL2+AC2+AE2+AF2+AG2+AX2+AP2+AX22+AX222+AP22+AP222+AQ2+AQ22+AQ222+AQ+AQ2222+AG22+AG222),DS11);{反特别版处理}
{}Y13:=IF(A9<9050,0.5*(AA2+AH2+AI2+AJ2+AL2+AC2+AE2+AF2+AG2+AX2+AP2+AX22+AX222+AP22+AP222+AQ2+AQ22+AQ222+AQ+AQ2222+AG22+AG222),DS13);{反特别版处理}
{}Y15:=IF(A9<9050,0.5*(AA2+AH2+AI2+AJ2+AL2+AC2+AE2+AF2+AG2+AX2+AP2+AX22+AX222+AP22+AP222+AQ2+AQ22+AQ222+AQ+AQ2222+AG22+AG222),DS15);{反特别版处理}
{}Y17:=IF(A9<9050,0.5*(AA2+AH2+AI2+AJ2+AL2+AC2+AE2+AF2+AG2+AX2+AP2+AX22+AX222+AP22+AP222+AQ2+AQ22+AQ222+AQ+AQ2222+AG22+AG222),DS17);{反特别版处理}
{}Y19:=IF(A9<9050,0.5*(AA2+AH2+AI2+AJ2+AL2+AC2+AE2+AF2+AG2+AX2+AP2+AX22+AX222+AP22+AP222+AQ2+AQ22+AQ222+AQ+AQ2222+AG22+AG222),DS19);{反特别版处理}
{}Y21:=IF(A9<9050,0.5*(AA2+AH2+AI2+AJ2+AL2+AC2+AE2+AF2+AG2+AX2+AP2+AX22+AX222+AP22+AP222+AQ2+AQ22+AQ222+AQ+AQ2222+AG22+AG222),DS21);{反特别版处理}
Y3:=CROSS(Y2,个股);Y4:=CROSS(Y1,个股) AND 个股>0.6;Y32:=CROSS(Y31,个股) AND 个股>0.6;Y42:=CROSS(Y41,个股) AND 个股>0.6;Y52:=CROSS(Y51,个股) AND 个股>0.6;
Y62:=CROSS(Y61,个股) AND 个股>0.6;Y72:=CROSS(Y71,个股) AND 个股>0.6;Y82:=CROSS(Y81,个股) AND 个股>0.6;
Y6:=CROSS(Y5,个股);Y8:=CROSS(Y7,个股);Y10:=CROSS(Y9,个股);Y12:=CROSS(Y11,个股);Y14:=CROSS(Y13,个股);Y16:=CROSS(Y15,个股);
Y18:=CROSS(Y17,个股);Y20:=CROSS(Y19,个股);Y22:=CROSS(Y21,个股);
DRAWICON((Y4 > 0),箱顶*1.03,2);DRAWICON((Y32> 0),箱顶*1.03,2);DRAWICON((Y42 > 0),箱顶*1.03,2);DRAWICON((Y52 > 0),箱顶*1.03,2);
DRAWICON((Y62 > 0),箱顶*1.03,2);DRAWICON((Y72 > 0),箱顶*1.03,2);DRAWICON((Y82 > 0),箱顶*1.03,2);
DRAWICON((Y3 > 0),长底,1);DRAWICON((Y6> 0),长底,1);DRAWICON((Y8> 0),长底,1);DRAWICON((Y10 > 0),长底,1);DRAWICON((Y12 > 0),长底,1);
DRAWICON((Y14 > 0),长底,1);DRAWICON((Y16 > 0),长底,1);DRAWICON((Y18> 0),长底,1);DRAWICON((Y20> 0),长底,1);DRAWICON((Y22 > 0),长底,1);
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,FGBLOCK);
Z3:=STRCAT(Z2,DYBLOCK);
Z4:=STRCAT(Z3,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z4,GNBLOCK)),COLORCYAN;

通达信筹码趋势启动指标公式

 

相关文章