在线检测未来函数

通达信金牛王主图指标公式

来源:Internet,编辑:股旁网,2017-08-18

M11:=5;M22:=10;M33:=20;M44:=60;P:=VOL;VOLUME:=VOL;
LB:=VOL/REF(MA(VOL,5),1);LJC:=MA(P,M11)>MA(P,M44)*0.9;
M1:=4;M2:=6;M3:=9;M4:=13;M5:=18;M6:=24;MA5:=MA(C,60);
MA60:MA(C,60),COLORRED,LINETHICK3;
PB1:(EXPMA(CLOSE,M1)+MA(CLOSE,M1*2)+MA(CLOSE,M1*4))/3;
PB2:(EXPMA(CLOSE,M2)+MA(CLOSE,M2*2)+MA(CLOSE,M2*4))/3;
PB3:(EXPMA(CLOSE,M3)+MA(CLOSE,M3*2)+MA(CLOSE,M3*4))/3;
PB4:(EXPMA(CLOSE,M4)+MA(CLOSE,M4*2)+MA(CLOSE,M4*4))/3;
PB5:(EXPMA(CLOSE,M5)+MA(CLOSE,M5*2)+MA(CLOSE,M5*4))/3;
PB6:(EXPMA(CLOSE,M6)+MA(CLOSE,M6*2)+MA(CLOSE,M6*4))/3;
AAA:=MIN(MIN(MIN(MIN(MIN(PB1,PB2),PB3),PB4),PB5),PB6);
BBB:=MAX(MAX(MAX(MAX(MAX(PB1,PB2),PB3),PB4),PB5),PB6);
XG:=(O<AAA OR REF(O<AAA,1)) AND C>BBB;
P6:=ABS(PB1-PB2)+ABS(PB1-PB3)+ABS(PB1-PB4)
+ABS(PB1-PB5)+ABS(PB1-PB6)+ABS(PB2-PB3)+ABS(PB2-PB4)
+ABS(PB2-PB5)+ABS(PB2-PB6)+ABS(PB3-PB4)
+ABS(PB3-PB5)+ABS(PB3-PB6)+ABS(PB4-PB5)+ABS(PB4-PB6)+ABS(PB5-PB6);
LXZH:=P6/C<20/100,COLORRED;
SS:=XG AND LB>2.2 AND C>MA5*1.02 AND C<MA5*1.15
AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>3/100 AND C>O*1.02,COLORRED;
DRAWICON(SS,PB1*0.97,1),LINETHICK5;
DRAWICON(SS,PB1*0.95,1),LINETHICK5;
DRAWICON(SS,PB1*0.93,1),LINETHICK5;
DRAWICON(SS,PB1*0.91,1),LINETHICK5;
DRAWICON(SS,PB1*0.88,1),LINETHICK5;
DRAWTEXT(SS=1,PB1*0.88,'买入')COLORYELLOW;
JL:=C>MA5 AND LJC AND (LB>2.2 OR REF(LB>2.2,1))
AND (XG OR REF(XG,1)) AND C>MA5*1.02 AND C<MA5*1.15 AND C>O*1.02
AND (LXZH OR REF(LXZH,1))
AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>3/100,COLORRED;
PD:=(JL OR REF(JL,1)),COLORRED;
DRAWICON(PD,PB1*0.97,3);
DRAWICON(PD,PB1*0.95,3);
DRAWICON(PD,PB1*0.93,3);
DRAWICON(PD,PB1*0.91,3);
DRAWICON(PD,PB1*0.88,3);
DRAWTEXT(FILTER(PD=1,PB1*0.88),PB1*0.85,'金牛王'),COLORRED;

通达信金牛王主图指标公式

 

相关文章