在线检测未来函数

同花顺MACD能量操盘指标公式

来源:Internet,编辑:股旁网,2017-08-21

DIFF : EMA(CLOSE,12) - EMA(CLOSE,26),colorwhite;
DEA : EMA(DIFF,9),coloryellow;
MACD:2*(DIFF-DEA);
Zero : 0;
gj:=MAX(C,O);
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),0,MACD,1,0),color0000ff;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,1,0),colorffff00;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,1,0),colorff00ff;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,1,0),color00ff00;
L4:=LLV(gj,4);
H4:=HHV(gj,4);
long:=26;short:=12;m:=9;
DIFF :=EMA(CLOSE,12) - EMA(CLOSE,26),LAYER0;
DEA :=EMA(DIFF,9),LAYER0;
MACD : 2*(DIFF-DEA),COLORSTICK,LAYER0;
主升 := DIFF>0 AND DIFF>DEA,COLORffffff,POINTDOT,LINETHICK0;
FILLRGN(DIFF,DEA,DIFF>DEA AND DIFF>REF(DIFF,1),color0999ff,DIFF>DEA AND DIFF<REF(DIFF,1),colorff3303);
FILLRGN(DIFF,DEA,主升 AND DIFF>DEA AND DIFF>REF(DIFF,1),color0333ff,主升 AND DIFF>DEA AND DIFF<REF(DIFF,1),colorff3303);
FILLRGN(DIFF,DEA,DIFF<DEA AND DIFF>REF(DIFF,1),colorFFFFFF,DIFF<DEA AND DIFF<REF(DIFF,1),color111111);
PARTLINE(DIFF,DIFF>REF(DIFF,1),color333333,DIFF<REF(DIFF,1),color444444),LINETHICK1;
PARTLINE(DEA,DEA>REF(DEA,1),color333333,DEA<REF(DEA,1),color444444),LINETHICK1;

同花顺MACD能量操盘指标公式

 

相关文章