在线检测未来函数

通达信DMI高手指标公式

来源:Internet,编辑:股旁网,2017-08-21

MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI: DMP*100/MTR;
MDI: DMM*100/MTR;
ADX: EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6),LINETHICK1;
ADXR:EXPMEMA(ADX,6),COLORWHITE,LINETHICK3;
DRAWBAND(ADX,RGB(139,101,108),ADXR,RGB(72,118,255));
DMM*100/MTR,COLOR00FF00,LINETHICK3;
DMP*100/MTR,COLOR0000FF,LINETHICK3;
VARA4:=(L+H+C+O)/4;

通达信DMI高手指标公式

 

相关文章