在线检测未来函数

通达信画蛇添足主图指标公式

来源:Internet,编辑:股旁网,2017-08-21

周:=C#WEEK;
CL:=L#WEEK;
RC:=C#WEEK;
ZF:=(CL-RC)/RC*100;
DRAWTEXT(CURRBARSCOUNT=3,RC*0.998,STRCAT('周涨%',CON2STR(ZF,2))),COLORFFFFFF;
M:=BARSCOUNT(CLOSE)>31;
ISCOLOR:=IF(周<>REF(周,1) OR M=0,1,0);
DIS0:=IF(M=0 OR NOT(ISCOLOR),0,0);
DIS:=SUM(DIS0,0);
NUM:=COUNT(ISCOLOR,0)+DIS;
PD0:=ISCOLOR AND MOD(NUM,4)=0;
PD1:=ISCOLOR AND MOD(NUM,4)=1;
PD2:=ISCOLOR AND MOD(NUM,4)=2;
PD3:=ISCOLOR AND MOD(NUM,4)=3;
HH:=CONST(HHV(H,360));
LL:=CONST(LLV(L,360));
STICKLINE(ISCOLOR AND MOD(NUM,4)=0,HH,LL,0,-1),COLOR0000FF;
STICKLINE(ISCOLOR AND MOD(NUM,4)=1,HH,LL,0,-1),COLOR00FFFF;
STICKLINE(ISCOLOR AND MOD(NUM,4)=2,HH,LL,0,-1),COLORFFFF00;
STICKLINE(ISCOLOR AND MOD(NUM,4)=3,HH,LL,0,-1),COLOR00FF00;
DRAWTEXT(PD0,HH*0.98,'【红】'),COLOR0000FF;
DRAWTEXT(PD1,HH*0.98,'【黄】'),COLOR00FFFF;
DRAWTEXT(PD2,HH*0.98,'【兰】'),COLORFF9900;
DRAWTEXT(PD3,HH*0.98,'【绿】'),COLOR00FF00;
MID:MA(CLOSE,26),COLOR00FFFF,DOTLINE;
UPPER:MID + 2*STD(CLOSE,26),COLOR00FF00;
LOWER:MID - 2*STD(CLOSE,26),COLOR0099FF;
DRAWBMP(CROSS(UPPER,C),H*1.008,'SE');
DRAWBMP(CROSS(LOWER,C),L*0.99,'BU');

通达信画蛇添足主图指标公式

 

相关文章