在线检测未来函数

通达信操盘手一红主图指标公式

来源:Internet,编辑:股旁网,2017-08-25

MA1:MA(CLOSE,5),COLORRED;
MA2:MA(CLOSE,10),COLORRED;
IF(MA1<REF(MA1,1),MA1,DRAWNULL),COLORGREEN;
IF(MA2<REF(MA2,1),MA2,DRAWNULL),COLORGREEN;
天使:=EMA(C,2),COLOR000000;
魔鬼:=EMA(SLOPE(C,21)*20+C,42),COLOR000000;
买:=CROSS(天使,魔鬼);
卖:=CROSS(魔鬼,天使);
DRAWTEXT(买,L-0.3,'B'),COLORYELLOW;
DRAWICON(卖,H+0.5,2);
DRAWTEXT(卖,H*1.05,'S'),COLORWHITE;
STICKLINE(天使>=魔鬼,LOW,HIGH,0.01,0),COLOR0000DD;
STICKLINE(天使>=魔鬼,CLOSE,OPEN,2,1),COLORRED;
STICKLINE(天使<魔鬼,LOW,HIGH,0.01,0),COLORFFDD00;
STICKLINE(天使<魔鬼,CLOSE,OPEN,2,0),COLORFFFF00;
STICKLINE(CROSS(天使,魔鬼),OPEN,CLOSE,2.5,0),COLORYELLOW;
STICKLINE(CROSS(魔鬼,天使),OPEN,CLOSE,2.5,0),COLORWHITE;
A1A:=EMA(CLOSE, 9);
A1B:=((A1A - EMA(CLOSE, 5)) < 0);
A1C:=((A1A - EMA(CLOSE, 5)) > 0);
A1D:=BARSLAST(A1B);
A1E:=BARSLAST(A1C);
A1F:=IF((A1E > 0),(CLOSE - REF(CLOSE, 1)) / REF(CLOSE, 1) * 100,0);
A20:=SUM(A1F,0);
A21:=IF((A1D > 0),(0 - 2),0);
A22:=IF((A1E > 0),SUM((CLOSE - REF(CLOSE, 1)) / REF(CLOSE, 1) * 100,A1E),0);
A23:=A22 / A1E;
A25:=EMA(EMA(EMA(CLOSE, 3), 3), 3);
多方:((A25 - REF(A25, 1)) + A25)COLOR0000FF,LINETHICK2;
空方:MA(多方, 15)COLORFF49FF;
DRAWTEXT(CROSS(多方,空方),L-0.3,'↑买')COLOR0000FF;
DRAWICON(((REF(A21, 1) = (0 - 2)) AND (A21 = 0)),L-0.9, 38);
DRAWICON(((REF(A1E, 1) > 0) AND (A1E = 0)),H+0.5, 39);

通达信操盘手一红主图指标公式

 

相关文章