在线检测未来函数

同花顺提前MACD指标公式

来源:Internet,编辑:股旁网,2017-08-25

DIF:EMA(CLOSE,9)-EMA(CLOSE,18);
DEA:EMA(DIF,7),LINETHICK1;
MACD:=2*(DIF-DEA);
STICKLINE(MACD>=0,MACD,0,0,0),COLORF00FF0;
STICKLINE(MACD<0,MACD,0,0,0),COLORF00FF0;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0,0 ),COLORFFFF00;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0,0 ),COLORFFFF00;
IF(DIF<0,DIF,0),colorred,LINETHICK1;
IF(DIF<0,0,DIF),colorred,LINETHICK1;
IF(DIF<DEA,DIF,DEA),COLOR00FF00,LINETHICK1;
IF(DIF>DEA,DEA,DEA),colorwhite,LINETHICK1;
金叉:=CROSS(DIF,DEA) AND DIF<0.3;
DRAWICON(金叉,DEA,1);
DIFF : EMA(CLOSE,12) - EMA(CLOSE,26);
DEA : EMA(DIFF,9);
MACD=2*(DIFF-DEA);
XG:(DIFf-DEA)>0.0 AND MACD>0.02;

同花顺提前MACD指标公式

 

相关文章