在线检测未来函数

同花顺黄金顶底指标公式

来源:Internet,编辑:股旁网,2017-08-28

EMA((H+L+C)/3,10),coloryellow,POINTDOT,linethick5;
PARTLINE(EMA((H+L+C)/3,10),C<EMA((H+L+C)/3,10),RGB(0,0,255)),POINTDOT,linethick5;
磁力线:(MA(CLOSE,30)+MA(CLOSE,72))/2,colorgreen;
多空线:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
DRAWTEXT(CROSS(多空线,磁力线),多空线,''),colorgreen,LINETHICK2;
DRAWTEXT(CROSS(磁力线,多空线),磁力线,''),colorred,LINETHICK2;
DA:=(EMA(C,1)+EMA(C,2)+EMA(C,3)+EMA(C,4))/4;
DB:=(EMA(C,10)+EMA(C,20)+EMA(C,40)+EMA(C,80))/4;
DRAWTEXT(CROSS(DA-DB,0),L*0.95,'★'),colorred;
JH:=SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100;
DRAWTEXT(CROSS(84,JH),H*1.02,'☆'),colorgreen;
STICKLINE(CLOSE>=CLOSE[1],CLOSE,CLOSE[1],9,1),colorred;
STICKLINE(CLOSE<CLOSE[1],CLOSE,CLOSE[1],9,0),colorgreen;
STICKLINE(CLOSE[1]>=CLOSE[2] AND CLOSE<CLOSE[1],CLOSE[1],MAX(CLOSE[2],CLOSE),9,1),colorred;
STICKLINE(CLOSE[1]<CLOSE[2] AND CLOSE>=CLOSE[1],CLOSE[1],MIN(CLOSE[2],CLOSE),9,0),colorgreen;
N:=27;
M1:=9;
M2:=5;
M3:=3;
A:=6;
B:=49;
VAR2:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
VAR3:=SMA(VAR2,M1,1);
VARA:=(CLOSE-LLV(LOW,21.55))/(HHV(HIGH,21.55)-LLV(LOW,34))*80;
VARB:=SMA(VARA,9,1);
VARC:=SMA(VARB,5,1);
LC:=REF(CLOSE,1);
山:=SMA(MAX(CLOSE-LC,0),A,1)/SMA(ABS(CLOSE-LC),A,1)*100;
花:=CROSS(山,14);
底1:=IF(CROSS(VARB,VARC) AND VARB<13,20,0);
顶:IF(CROSS(68,山),81,100),LINETHICK2,colorgreen;
底:IF((底1 OR 花),30,0),LINETHICK2,colorred;
短线成本:=EMA(CLOSE,17),LINETHICK2,colorwhite;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
中线成本:=EMA(X,13),LINETHICK2,COLORFF00FF;
STICKLINE(BARSLAST(短线成本<中线成本)>30,95,100,5,0),colorred;
STICKLINE(BARSLAST(短线成本>中线成本)>30,0,5,5,0),colorgreen;
VAR1:=1;
VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
N1:=5;
N4:=34;
CQ:=100*(C-LLV(L,N4))/(HHV(C,N4)-LLV(L,N4));
SAT:=(AMOUNT/C)/(HHV(AMOUNT,N4)/HHV(C,N4));
饱和度:=IF(SAT>1,1,SAT)*100;
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=CROSS(C,REF(W3,1));
STICKLINE(饱和度>=97 AND CQ>90,0,100,2,0),colorred;
中期:=100*(C-LLV(L,N4))/(HHV(C,N4)-LLV(L,N4));
持股:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
支撑:=LLV(持股,3);
短期线:EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*VAR1*30,LINETHICK1,colorbrown;
中期线:MA(持股,12),colorwhite,LINETHICK1;
STICKLINE(支撑<中期线,支撑,中期线,2,0),COLOR6B8E23;
STICKLINE(持股>0,支撑,持股,2,0),colorred;
STICKLINE(支撑>中期线,中期线,支撑,2,0),COLOR38B0DE;
STICKLINE(支撑=持股 AND 持股>中期线,中期线,支撑,2,0),COLORFF00FF;
STICKLINE(REF(中期,1)<1 AND 中期>1,0,15,2,0),colorwhite;
STICKLINE(W4 AND COUNT(W4,5)=1,85,100,2,0),coloryellow;
N:=3;
L0:=0.00;
L1:=ABS(L-REF(L,1))<=L0;
L2:=ABS(L-REF(L,2))<=L0;
L3:=ABS(L-REF(L,3))<=L0;
L4:=ABS(L-REF(L,4))<=L0;
L5:=ABS(L-REF(L,5))<=L0;
精准线首次:=L1 OR L2 OR L3 OR L4 OR L5;
精准左:=FILTER(精准线首次,N) ;
天数:=BARSLAST(精准左);
LTS:=REF(L,天数);
精准右:=ABS(L-LTS)<=L0;
STICKLINE(精准左,L,L,50,-1),Color8080FF;
G1:=ABS(H-REF(H,1))<=L0;
G2:=ABS(H-REF(H,2))<=L0;
G3:=ABS(H-REF(H,3))<=L0;
G4:=ABS(H-REF(H,4))<=L0;
G5:=ABS(H-REF(H,5))<=L0;
G6:=ABS(H-REF(H,6))<=L0;
G7:=ABS(H-REF(H,7))<=L0;
G8:=ABS(H-REF(H,8))<=L0;
精准线1首次:=G1 OR G2 OR G3 OR G4 OR G5 OR G6 OR G7 OR G8;
精准左1:=FILTER(精准线1首次,N) ;
天数1:=BARSLAST(精准左1);
GTS:=REF(L,天数1);
精准右1:=ABS(H-LTS)<=L0;
STICKLINE(精准左1,H,H,50,-1),Color00FF00;
支撑位:IF((EMA(CLOSE,15)-REF(EMA(CLOSE,15),1))/REF(EMA(CLOSE,15),1)*100>=0,REF(EMA(CLOSE,15),BARSLAST(CROSS((EMA(CLOSE,15)-REF(EMA(CLOSE,15),1))/REF(EMA(CLOSE,15),1)*100,0))+1),DRAWNULL),colorred,LINETHICK1;
阻力位:IF((EMA(CLOSE,15)-REF(EMA(CLOSE,15),1))/REF(EMA(CLOSE,15),1)*100<0,REF(EMA(CLOSE,15),BARSLAST(CROSS(0,(EMA(CLOSE,15)-REF(EMA(CLOSE,15),1))/REF(EMA(CLOSE,15),1)*100))+1),DRAWNULL),colorgreen,LINETHICK1;
N:=5;
VAR1:4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),coloryellow,LINETHICK0;
VAR2:8,colorgreen,LINETHICK0;
上升在即: IF(CROSS(VAR1,VAR2),80,0),STICK,COLOR0000CC,LINETHICK2;
专吸庄血: IF(VAR1<=8,25,0),STICK,colorwhite,LINETHICK2;
DRAWTEXT(CROSS(VAR1,VAR2),80,''),COLOR00FFFF;
VARO5:=LLV(LOW,27);
VARO6:=HHV(HIGH,34);
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
建仓区: IF((VARO7<10),80,100) ,COLOR00CCFF,LINETHICK1;
0,LINETHICK2 ,COLORFFCC00;
DRAWTEXT(上升在即=80,上升在即,'');
DRAWTEXT(VAR1>80,80,'');
中轴:50;

同花顺黄金顶底主图指标公式

 

相关文章