在线检测未来函数

同花顺MACD正负能量指标公式

来源:Internet,编辑:股旁网,2017-08-30

DI:=(EMA(CLOSE,12) - EMA(CLOSE,26))*200;
DE:=EMA(DI,9);
MACD:=2*(DI-DE);
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*400-200;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,8,0),colorred;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,8,0),colorblue;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,8,0),colorgreen;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,8,0),colormagenta;
Zero : 0;
gj:=MAX(C,O);
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),0,MACD,2,0),color0000ff;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,2,0),colorffff00;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,2,0),colorff00ff;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,2,0),color00ff00;
L4:=LLV(gj,4);
H4:=HHV(gj,4);
A9:=(HIGH+LOW)/2;
TYP := (IF(ISNULL(HIGH),CLOSE,HIGH) + IF(ISNULL(LOW),CLOSE,LOW) + CLOSE)/3;
CI:(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
C2:MA(CI,4);
C3:MA(CI,10),linethick1;;
FILLRGN(CI,C2,CI>C2,RGB(0,255,0,),CI<C2,colorblack);
FILLRGN(CI,C3,CI>C3,RGB(255,0,0,),CI<C3,colorblack);
LC := REF(CLOSE,1);
TT:=(2*CLOSE+OPEN+HIGH+LOW);
主导动能:TT/EMA(TT,4)-1,COLORSTICK;
FF:=主导动能;
STICKLINE(FF>0,0,FF,8,0),COLOR33CFDD;
STICKLINE(FF>0 AND FF>REF(FF,1),0,FF,8,0),COLOR0000CC;
STICKLINE(FF<=0,0,FF,8,0),COLOR00CC00;
STICKLINE(FF<=0 AND FF>REF(FF,1),0,FF,8,0),COLORFF9900;
做多主导:IFF(FF>0 AND FF>REF(FF,1),FF,0),NODRAW,COLOR0000CC;
获利回吐:IFF(FF>0 AND FF<=REF(FF,1),FF,0),NODRAW,COLOR33CFDD;
做空主导:IFF(FF<=0 AND FF<=REF(FF,1),FF,0),NODRAW,COLOR00CC00;
空头回补:IFF(FF<=0 AND FF>REF(FF,1),FF,0),NODRAW,COLORFF9900;

同花顺MACD正负能量指标公式

 

相关文章