在线检测未来函数

通达信私募波段共振指标公式

来源:Internet,编辑:股旁网,2017-08-30

{使用方法:1、底部区域同时出现红色,形成共振,可视为买进的可靠信号;2、高位区域同时出现绿色或蓝绿色,形成共振,可视为卖出的可靠信号。}

VAR1:=EMA(SMA((CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100,8,1),3);
STICKLINE(VAR1>20 AND VAR1<80,VAR1,VAR1,10,1),COLORRED;
STICKLINE(VAR1<REF(VAR1,1),VAR1,VAR1,10,1),COLORFFCC66;
STICKLINE(VAR1>80,VAR1,VAR1,10,1),COLOR00FF00;
STICKLINE(VAR1<20,VAR1,VAR1,10,1),COLORYELLOW;
RSV:=(CLOSE-LLV(LOW,35))/(HHV(HIGH,35)-LLV(LOW,35))*100;
K:=SMA(RSV,5,1);
D:=MA(K,7);
E:=MA(K,3);
J:=3*K-2*D;
STICKLINE((K-D>0),K,E,8,1),COLORRED;
STICKLINE((K-D<0),K,E,8,1),COLORGREEN;
红色柱1:=K-D>0 OR (K-D>0 AND REF(K-D<0,1));
红色柱2:=VAR1>REF(VAR1,1);
红色共振:=红色柱1;
ABV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/25000,2);
M1:=EMA(ABV,12);
M2:=EMA(ABV,26);
MTM:=CLOSE-REF(CLOSE,1);
MMS:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));
MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));
MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));
MTGJ:=C-REF(C,1);
ZLGJ:=100*EMA(EMA(MTGJ,9),9)/EMA(EMA(ABS(MTGJ),9),9);
MAZL:=MA(ZLGJ,5);
A:=((VOL)/(CAPITAL))*(100);
S:=((MA(A,30))/(MA(INDEXA,10)))*(MA(INDEXA,60));
Y:=((MA(A,120))/(MA(INDEXA,10)))*(MA(INDEXA,60));
X:=1;
V1:=(HIGH+OPEN+LOW+(2)*(CLOSE))/(5);
V2:=REF(V1,1);
V3:=MAX(V1-V2,0);
V4:=ABS(V1-V2);
V5:=SMA(V3,10,1);
V6:=SMA(V4,10,1);
V8:=COUNT(((V5)/(V6)<0.2),5);
V9:=COUNT((LLV(V1,10)=V1),10);
精准买卖:=V8>=1 AND V9>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND (VOL>REF(VOL,1)) AND MMS>MML AND CROSS(ABV,M2);
短线买点:=V8>=1 AND V9>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND (VOL>REF(VOL,1)) AND CROSS(MMS,MML) AND ABV>REF(ABV,1);
中线买点:=V8>=1 AND V9>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND (VOL>REF(VOL,1)) AND ABV>REF(ABV,1) AND MMS>MML AND CROSS(MMM,MML) AND MMS>REF(MMS,1) AND MMM>REF(MMM,1) AND MML>REF(MML,1);
主进主买:=ABV>M2 AND ZLGJ>MAZL AND CROSS(MMS,MML) AND MMS>REF(MMS,1) AND MMM>REF(MMM,1) AND MML>REF(MML,1);
短中精:=精准买卖 OR 短线买点 OR 中线买点 OR 主进主买;
VAR13:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
VAR14:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
VAR16:=MAX(EMA(VAR13,2)-EMA(VAR14,5),0)*200;
VAR17:=EMA(VAR16,5);
分水岭:=VAR17>REF(VAR17,1);
LOWV:=LLV(LOW,9);
HIGHV:=HHV(HIGH,9);
RSV1:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);
KK:=EMA(RSV1,3);
DD:=MA(KK,3);
慢速KD:=KK>DD AND KK<82;
主力进出:IF((MMS>REF(MMS,1) AND ZLGJ>REF(ZLGJ,1) AND CROSS(ABV,M2) AND ABV>REF(ABV,1) AND M1>REF(M1,1) AND M2>REF(M2,1) AND 红色共振),00,0),COLORWHITE,POINTDOT;
主进主轨:ABV>M2 AND CROSS(ABV,M1) AND CROSS(ZLGJ,MAZL) AND 红色共振;
STICKLINE(主力进出 OR 主进主轨,00,0,2,1),COLORWHITE;
波段启动1:STICKLINE(CROSS(K,D) AND K<30 AND 红色柱2,0,0,4,1),COLORMAGENTA;
VARA:=REF(LOW,1);
VARB:=SMA(ABS(LOW-VARA),3,1)/SMA(MAX(LOW-VARA,0),3,1)*100;
VARC:=EMA(IF(CLOSE*1.3,VARB*10,VARB/10),3);
VARD:=LLV(LOW,30);
VARE:=HHV(VARC,30);
VARF:=IF(MA(CLOSE,58),1,0);
VARG:=EMA(IF(LOW<=VARD,(VARC+VARE*2)/2,0),3)/618*VARF;
VARH:=IF(VARG>28,28,VARG);
吸筹:STICKLINE(VARH>-120,0,VARH,6,1),COLORWHITE;
备钱:=IF(吸筹,1,0),COLOR0FFFFF;

通达信私募波段共振指标公式

 

相关文章