在线检测未来函数

通达信易经主图指标公式

来源:Internet,编辑:股旁网,2017-09-12

会:HHV(FORCAST(CLOSE,7),7),COLORWHITE;
用:HHV(FORCAST(CLOSE,7),14),COLORLIBLUE;
会用:HHV(FORCAST(CLOSE,7),21),COLORGREEN;
HJ_1:=HHV(FORCAST(CLOSE,7),28);
IF(HJ_1,HJ_1,DRAWNULL),DOTLINE,COLORYELLOW;
IF(HJ_1=REF(HJ_1,1) AND BARSLAST(HJ_1>REF(HJ_1,1) OR HJ_1<REF(HJ_1,1))>3,HJ_1,DRAWNULL),COLORGREEN;
DRAWKLINE(H,O,L,C);
阳:=C-REF(C,1)>0 OR (C-REF(C,1)=0 AND C>O);
阴:=C-REF(C,1)<0 OR (C-REF(C,1)=0 AND C<=O);
乾:=阳 AND REF(阳,1) AND REF(阳,2);
兑:=阳 AND REF(阳,1) AND REF(阴,2);
离:=阳 AND REF(阴,1) AND REF(阳,2);
震:=阳 AND REF(阴,1) AND REF(阴,2);
巽:=阴 AND REF(阳,1) AND REF(阳,2);
坎:=阴 AND REF(阳,1) AND REF(阴,2);
艮:=阴 AND REF(阴,1) AND REF(阳,2);
坤:=阴 AND REF(阴,1) AND REF(阴,2);
DRAWTEXT( (震 AND REF(乾,3)) OR (震 AND REF(兑,3)), L*0.99,'雷四'),COLOR0066FF;
DRAWTEXT( (震 AND REF(离,3)) OR (震 AND REF(震,3)), L*0.99,'雷三'),COLOR0066FF;
DRAWTEXT( (震 AND REF(巽,3)) OR (震 AND REF(坎,3)), L*0.99,'雷二'),COLOR0066FF;
DRAWTEXT( (震 AND REF(艮,3)) OR( 震 AND REF(坤,3)), L*0.99,'雷一'),COLOR0066FF;
DRAWTEXT( (兑 AND REF(乾,3)) OR (兑 AND REF(兑,3)), L*0.99,'泽四'),COLORRED;
DRAWTEXT( (兑 AND REF(离,3)) OR (兑 AND REF(震,3)), L*0.99,'泽三'),COLORRED;
DRAWTEXT( (兑 AND REF(巽,3)) OR (兑 AND REF(坎,3)), L*0.99,'泽二'),COLORRED;
DRAWTEXT( (兑 AND REF(艮,3)) OR( 兑 AND REF(坤,3)), L*0.99,'泽一'),COLORRED;
DRAWTEXT( (乾 AND REF(乾,3)) OR (乾 AND REF(兑,3)), L*0.99,'天四'),COLORCC66FF;
DRAWTEXT( (乾 AND REF(离,3)) OR (乾 AND REF(震,3)), L*0.99,'天三'),COLORCC66FF;
DRAWTEXT( (乾 AND REF(巽,3)) OR (乾 AND REF(坎,3)), L*0.99,'天二'),COLORCC66FF;
DRAWTEXT( (乾 AND REF(艮,3)) OR( 乾 AND REF(坤,3)), L*0.99,'天一'),COLORCC66FF;
DRAWTEXT( (巽 AND REF(乾,3)) OR (巽 AND REF(兑,3)), H*1.01,'风4'),COLORFF9933;
DRAWTEXT( (巽 AND REF(离,3)) OR (巽 AND REF(震,3)), H*1.01,'风3'),COLORFF9933;
DRAWTEXT( (巽 AND REF(巽,3)) OR (巽 AND REF(坎,3)), H*1.01,'风2'),COLORFF9933;
DRAWTEXT( (巽 AND REF(艮,3)) OR( 巽 AND REF(坤,3)), H*1.01,'风1'),COLORFF9933;
DRAWTEXT( (艮 AND REF(乾,3)) OR (艮 AND REF(兑,3)), H*1.01,'山4'),COLORGREEN;
DRAWTEXT( (艮 AND REF(离,3)) OR (艮 AND REF(震,3)), H*1.01,'山3'),COLORGREEN;
DRAWTEXT( (艮 AND REF(巽,3)) OR (艮 AND REF(坎,3)), H*1.01,'山2'),COLORGREEN;
DRAWTEXT( (艮 AND REF(艮,3)) OR( 艮 AND REF(坤,3)), H*1.01,'山1'),COLORGREEN;
DRAWTEXT( (坤 AND REF(乾,3)) OR (坤 AND REF(兑,3)), H*1.01,'地4'),COLORFF3366;
DRAWTEXT( (坤 AND REF(离,3)) OR (坤 AND REF(震,3)), H*1.01,'地3'),COLORFF3366;
DRAWTEXT( (坤 AND REF(巽,3)) OR (坤 AND REF(坎,3)), H*1.01,'地2'),COLORFF3366;
DRAWTEXT( (坤 AND REF(艮,3)) OR( 坤 AND REF(坤,3)), H*1.01,'地1'),COLORFF3366;
DRAWTEXT( (离 AND REF(乾,3)) OR (离 AND REF(兑,3)), L*0.99,'火四'),COLORFFFFFF;
DRAWTEXT( (离 AND REF(离,3)) OR (离 AND REF(震,3)), L*0.99,'火三'),COLORFFFFFF;
DRAWTEXT( (离 AND REF(巽,3)) OR (离 AND REF(坎,3)), L*0.99,'火二'),COLORFFFFFF;
DRAWTEXT( (离 AND REF(艮,3)) OR (离 AND REF(坤,3)), L*0.99,'火一'),COLORFFFFFF;
DRAWTEXT( (坎 AND REF(乾,3)) OR (坎 AND REF(兑,3)), H*1.01,'水4'),COLOR888888;
DRAWTEXT( (坎 AND REF(离,3)) OR (坎 AND REF(震,3)), H*1.01,'水3'),COLOR888888;
DRAWTEXT( (坎 AND REF(巽,3)) OR (坎 AND REF(坎,3)), H*1.01,'水2'),COLOR888888;
DRAWTEXT( (坎 AND REF(艮,3)) OR (坎 AND REF(坤,3)), H*1.01,'水1'),COLOR888888;

通达信易经主图指标公式

 

相关文章