在线检测未来函数

通达信金蝉脱壳主图指标公式

来源:Internet,编辑:股旁网,2017-09-13

AMV0:=VOL*(O+C)/2;MA5:MA(C,5)COLORYELLOW,LINETHICK1;
博杀生命线:SUM(AMV0,88)/SUM(VOL,88)CROSSDOT,COLOR888888,LINETHICK1;
MJ:IF(CLOSE>SAR(4,6,20),SAR(4,6,20),DRAWNULL),CIRCLEDOT,COLORRED;
MC:IF(CLOSE<SAR(4,6,20),SAR(4,6,20),DRAWNULL),CIRCLEDOT,COLORGREEN;
变1:=REF(C<MC,6) AND REF(C<MC,5) AND REF(C<MC,4) AND REF(C<MC,3) AND REF(C<MC,2) AND REF(C<MC,1) AND REF(C>MC,0),NODRAW;
MJ1:=IF(变1=1,MJ,DRAWNULL),CIRCLEDOT,COLORRED;
DRAWTEXT(变1=1,MJ-MJ*0.03,'进'),COLORRED;
变无效:=IF(变1=1,0,1);
变2:=变无效 AND REF(C<MC,1) AND REF(C>MJ,0);
DD:=IF(变2=1,MJ,DRAWNULL),CIRCLEDOT,COLORYELLOW;
DRAWTEXT(变2=1,MJ-MJ*0.03,'进'),COLORRED;
变3:=REF(C>MJ,1) AND REF(C<MC,0);
MC1:=IF(变3=1,MC,DRAWNULL),CIRCLEDOT,COLORGREEN;
DRAWTEXT((CLOSE>MC),MC,'*'),COLOR0000FF,LINETHICK5;
DRAWTEXT(变3=1,MC+MC*0.03,'出')COLORGREEN;
多:IF(MA5>REF(MA5,1),MA5,DRAWNULL)COLORMAGENTA,LINETHICK1;
空:IF(MA5<REF(MA5,1),MA5,DRAWNULL),COLORYELLOW,LINETHICK1;
Z1:=STRCAT(HYBLOCK,' ')COLORFF00FF; Z2:=STRCAT(Z1,FGBLOCK)COLOR0000FF;
Z3:=STRCAT(Z2,DYBLOCK)COLORCFB53B;Z4:=STRCAT(Z3,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z4,GNBLOCK)),COLORCYAN;
VAR9:=CLOSE-REF(CLOSE,5); VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5);
VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20);
卖出:=IF(VARA>0 AND CROSS(VARC,VARA),90,100); DRAWICON(卖出<0,H+0.05,2);
VC:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3;
S2:=IF(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.02,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORGREEN;
A0:=(L+H+C*2)/4;
A1:EMA(A0,14)COLORGREEN,LINETHICK2;
A2:=EMA(A0,25)COLORCYAN,LINETHICK2;
A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
买入持股:IF(A1X>=0,A1,DRAWNULL)COLORRED,LINETHICK2;
卖出空仓:IF(A1X<0 AND A2X<0,A1,DRAWNULL)COLORGREEN,LINETHICK2;
出击:IF(A1X>=0,REF(EMA(C,14),BARSLAST(CROSS(A1X,0))+1),DRAWNULL),COLORB000B0,LINETHICK2;
休假:IF(A1X<0,REF(EMA(C,14),BARSLAST(CROSS(0,A1X))+1),DRAWNULL),COLORFFFF00,LINETHICK2;
STICKLINE(CROSS(A1X,0),H,L,0,0 ),COLOR9933FF; STICKLINE(CROSS(A1X,0),C,O,3,0 ),COLOR0000CC;
STICKLINE(CROSS(A1X,0),C,O,1,0 ),COLOR0033FF; STICKLINE(CROSS(0,A1X),L,H,0,0 ),COLOR66CC33;
DRAWTEXT(CURRBARSCOUNT=1,出击*0.999,'出击'),COLORB000B0;
DRAWTEXT(CURRBARSCOUNT=1,休假*0.999,'休假'),COLORFFFF00;
BU:=CROSS(HIGH,SAR(3,1,20));
SEL:=CROSS(SAR(3,1,20),LOW);
DRAWTEXT(BU,LOW*0.99,'B买'),COLORYELLOW,LINETHICK2;
DRAWTEXT(SEL,1.01*HIGH,'S卖'),COLORWHITE,LINETHICK2;
AC:=AMOUNT/(VOL);YY:=MA(AC,13);LLL:=(C-YY)/YY*100;MIDC := MA(CLOSE,22);
UPPERC:= MIDC + 2*STD(C,22);LOWERC:= MIDC - 2*STD(C,22);BBA:=(C-LOWERC)/(UPPERC-LOWERC);
BBC:=FORCAST(BBA,3);LIFENGCYC:=(REF(LLL,1)<-15 AND REF(BBA,1)<0 AND LLL>REF(LLL,1));
STICKLINE(LIFENGCYC>0,C,O,2,0),COLOR10ABFF;
STICKLINE(LIFENGCYC>0,C,O,1.5,0),COLOR10D0FF;
STICKLINE(LIFENGCYC>0,C,O,1,0),COLOR10FFFF;
DRAWTEXT(LIFENGCYC>0,LOW*0.99,'☆'),COLORDD00DD;
DRAWTEXT((O-C)/O>8/100 ,H+0.501,'☆逃命'),COLOR00FFFF;
N1:=6;MTM:=C-REF(C,1);
ZLGJ:=100*EMA(EMA(MTM,N1),N1)/EMA(EMA(ABS(MTM),N1),N1);
买1:=IF(LLV(ZLGJ,2)=LLV(ZLGJ,7) AND COUNT(ZLGJ<0,2) AND CROSS(ZLGJ,MA(ZLGJ,2)),1,0);
卖1:=IF(HHV(ZLGJ,2)=HHV(ZLGJ,7) AND COUNT(ZLGJ>50,2) AND CROSS(MA(ZLGJ,2),ZLGJ),1,0);

通达信金蝉脱壳主图指标公式

 

相关文章