在线检测未来函数

通达信天涯精准主图指标公式

来源:Internet,编辑:股旁网,2017-09-18

MA05:MA(C,5)LINETHICK3,COLOR00CCFF;
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
五日乖离率:=(C-MA05)/MA05*100;
BB05:=ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((MA05-REF(MA05,1))/REF(MA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;
IF(BB05>30 AND MA05>REF(MA05,1), MA05,DRAWNULL),LINETHICK3,COLORRED;
BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
IF(BB05<0 AND MA05<REF(MA05,1), MA05,DRAWNULL),LINETHICK3,COLORGREEN;
三拾日乖离率:=(C-MA30)/MA30*100,NODRAW;
VAR1:=(MA20-MA30)>REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);
VAR2:=(MA30-MA20)<REF((MA30-MA20),1) AND MA20<REF(MA20,1) AND MA30<REF(MA30,1);
BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND MA05>REF(MA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>MA30 OR O>MA30) AND MA05<REF(MA05,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10<REF(MA10,1),10);
DRAWTEXT(加仓 ,LOW*0.98,'←加仓'),COLORRED;
JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10>REF(MA10,1) ;
减仓:=FILTER(JC,10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA05>REF(MA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;
买入:=FILTER(MR,10);
DRAWTEXT(减仓,HIGH*1.02,'←风险'),COLORCYAN;
DRAWTEXT(买入,LOW*0.98,'←买入'),COLORYELLOW;
DRAWTEXT(清仓 ,HIGH*1.02,'←清仓'),COLORGREEN;
DRAWTEXT(强势狙击,LOW*0.98,'←强势狙击'),COLORYELLOW;
VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));
VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);
MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;
压力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF,DOTLINE;
支撑:MA(REF(LLV(C,30),1),2),COLORABFF46,DOTLINE;
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;
大盘涨家数:INDEXADV,NODRAW,COLORRED;
大盘跌家数:INDEXDEC,NODRAW,COLORGREEN;
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0);
N:=89;M1:=3;M2:=3;
AA:=100*(C-REF(C,1))/REF(C,1);
BB:=100*(H-C)/REF(C,1);
HH:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
EE:=SMA(HH,M1,1);
FF:=SMA(EE,M2,1);
GG:=3*EE-2*FF;
V5:=EMA(CLOSE,1);
AE:=EMA(V5,5) ;
AB:=EMA(HHV(AE,5),1);
{CC:=C<FF;
OK: C>FF AND LAST(CC,22,1) AND AA>3 AND BB<3 AND GG<87 AND H!=L
AND LAST(GG<80,20,1) AND LLV(GG,32)<3 AND GG>REF(GG,1)*1.25;};
ZDT:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDT>6,O,C,0.5,0),COLORYELLOW;
STICKLINE(ZDT<-9.8,O,C,0.5,0),COLOR00FF00;
V五:=EMA(CLOSE,1);主线:=EMA(V五,5) ;
本:=EMA(HHV(主线,5),1);
急进:=EMA(HHV(本,17),1);
稳健:=EMA(HHV(急进,17),2);
主升浪:EMA(HHV(稳健,17),3),LINETHICK2,COLORBLUE;

通达信天涯精准主图指标公式

 

相关文章