在线检测未来函数

通达信弯弓射箭指标公式

来源:Internet,编辑:股旁网,2017-09-20

MA1:=MA(C,5);
MA2:=MA(C,10);
MA3:=MA(C,20);
MA4:=MA(C,40);
MA5:=MA(C,60);
MA6:=MA(C,30);
M1:=5;
M2:=10;
M3:=20;
M4:=60;
M5:=40;
P:=VOL;
VOLUME:=VOL;
量比:=VOL/REF(MA(VOL,5),1)COLORGREEN;
LONG:=26;
SHORT:=12;
M:=9;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
WW:=DEA>REF(DEA,1);
DD:=CROSS(DIFF,REF(DIFF,1));
TT:=WW AND DD;
底部金叉:=CROSS(DIFF,DEA) AND DIFF<0 AND DEA<0 AND 量比>2;
反身向上:=WW AND DD AND 量比>2,COLORFF00FF,LINETHICK2;
空中加油:=IF(DIFF>0 AND DEA>0 AND CROSS(DIFF,DEA) AND LAST(DIFF<DEA,15,2)
AND MACD>REF(MACD,1) AND DIFF>REF(DIFF,1) AND 量比>1.8 ,0.8,0)COLORRED,LINETHICK2;
MACD1:=MACD+100;
OZ:=COUNT(CROSS(DIFF,DEA) AND DIFF>0,BARSLAST(CROSS(DIFF,DEA) AND DIFF<0));
零上二金叉:=IF(CROSS(DIFF,DEA) AND OZ=1,44444,0)COLORFFFF00,LINETHICK4;
价金叉:=IF(CROSS(MA1,MA2*0.995),33,0)COLORGREEN,LINETHICK3;
量金叉:=IF(CROSS(MA(P,M1),MA(P,M2)),22,0)COLORFF33CC,LINETHICK3;
MACD金叉:=IF(CROSS(DIFF,DEA) AND DIFF<0.3,38,0)COLORRED,LINETHICK2;
三金叉见底:IF((价金叉 OR REF(价金叉,1) OR REF(价金叉,2) OR REF(价金叉,3)) AND (量金叉 OR REF(量金叉,1) OR REF(量金叉,2) OR REF(量金叉,3))
AND (MACD金叉 OR REF(MACD金叉,1) OR REF(MACD金叉,2) OR REF(MACD金叉,3)) AND MA(P,M1)>MA(P,M2) AND C>MA2 AND MA1>MA2*0.995 AND MACD>REF(MACD,1) AND MACD>REF(MACD,2) AND MACD>0 AND DIFF<0.3,48,0)COLORRED,LINETHICK5;
GOL:=(REF(三金叉见底,11) OR REF(三金叉见底,12)
OR REF(三金叉见底,13) OR REF(三金叉见底,14)
OR REF(三金叉见底,15) OR REF(三金叉见底,16)
OR REF(三金叉见底,17) OR REF(三金叉见底,18)
OR REF(三金叉见底,19) OR REF(三金叉见底,20)
OR REF(三金叉见底,21) OR REF(三金叉见底,22)
OR REF(三金叉见底,23) OR REF(三金叉见底,24)
OR REF(三金叉见底,25) OR REF(三金叉见底,26))
AND (三金叉见底 OR 空中加油 OR REF(空中加油,1)
OR 零上二金叉 OR 反身向上 OR REF(反身向上,1) OR 底部金叉);
弯弓射箭:IF(GOL AND MA1<MA5*1.033 AND MA2<MA5*1.033
AND C>MA1 AND C>MA2 AND MA1>MA2*0.99
AND DIFF<0.02 AND (DEA>REF(DEA,10) OR DEA>REF(DEA,11)
OR DEA>REF(DEA,13) OR DEA>REF(DEA,12)
OR DEA>REF(DEA,14) OR DEA>REF(DEA,15)
OR DEA>REF(DEA,16) OR DEA>REF(DEA,17)
OR DEA>REF(DEA,18) OR DEA>REF(DEA,19)
OR DEA>REF(DEA,20) OR DEA>REF(DEA,21)
OR DEA>REF(DEA,22) OR DEA>REF(DEA,23)
OR DEA>REF(DEA,25)),78,0)COLORYELLOW,LINETHICK5;

通达信弯弓射箭指标公式

 

相关文章