在线检测未来函数

通达信见血封喉指标公式

来源:Internet,编辑:股旁网,2017-09-25

底部周期:=9;
X_1:=CLOSE<=REF(LLV(CLOSE,底部周期),1) AND CLOSE<=OPEN;
X_2:=REF(X_1,1) AND CLOSE>OPEN AND CLOSE<=REF(CLOSE,1);
X_3:=X_1 OR X_2 AND FINANCE(42)>20;
X_4:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.04 OR (CLOSE-OPEN)/OPEN>=0.04 AND (VOL<=MA(VOL,60) OR VOL/REF(VOL,1)<=1.2 OR VOL<HHV(VOL,5)) AND HIGH>LOW;
X_5:=(OPEN-CLOSE)/OPEN>=0.04 OR (REF(CLOSE,1)/CLOSE>=1.04 AND CLOSE<OPEN) AND (VOL/MA(VOL,60)<=2/3 OR VOL/REF(VOL,1)<=1.15 OR VOL<HHV(VOL,5));
X_6:=CLOSE<OPEN;
X_7:=REF(VOL,2)>REF(VOL,1) AND REF(VOL,1)>VOL AND COUNT(X_6,3)>=2;
X_8:=VOL<REF(LLV(VOL,20),1) AND HIGH>LOW;
X_9:=REF(VOL,2)>REF(VOL,1) AND REF(VOL,1)>VOL;
X_10:=VOL/REF(VOL,1)<0.67;
X_11:=IF(DATE=1160107,REF(VOL,1),VOL);
X_12:=X_11<REF(LLV(X_11,100),1) AND HIGH>LOW;
X_13:=VOL/MA(VOL,60)<=1/3;
X_14:=X_3 AND X_5 AND COUNT(X_9 OR X_10 OR X_12,3);
亮剑:X_14,NODRAW,COLORRED;
STICKLINE(亮剑,0.75,0.6,0,0),COLORWHITE;
STICKLINE(亮剑,0.6,0.175,0,0),COLORWHITE;
STICKLINE(亮剑,0.175,0.155,3,0),COLORWHITE;
STICKLINE(亮剑,0.155,0,0.3,0),COLORWHITE;
X_15:=REF(X_14,1) AND CLOSE>OPEN AND VOL>REF(VOL,1) AND (CLOSE>REF((CLOSE+OPEN)/2,1) OR CLOSE/OPEN>1.008);
X_16:=REF(X_14,1) OR (REF(X_14,2) AND REF(CLOSE,1)<REF(OPEN,1)) AND CLOSE>OPEN AND VOL>REF(VOL,1) AND CLOSE>REF(OPEN,1);
X_17:=REF(X_14,1) AND X_4 OR (REF(X_14,2) AND REF(VOL,1)<VOL) AND X_4;
X_18:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1);
X_19:=REF(X_14,1) OR REF(X_14,2) AND X_18 AND CLOSE/OPEN>1.02;
X_20:=100*(MIN(CLOSE,OPEN)-LOW)/LOW>3.5;
X_21:=REF(X_14,1) OR REF(X_14,2) AND X_20 AND CLOSE>OPEN;
X_22:=REF(X_14,1) AND REF(X_20,1) OR (REF(X_14,2) AND (REF(X_20,2) OR REF(X_20,1))) AND CLOSE/OPEN>1.02;
X_23:=X_21 OR X_22;
X_24:=REF(X_14,1) AND CLOSE/OPEN>1.01 AND VOL<REF(VOL,1);
X_25:=X_15 OR X_16 OR X_17 OR X_19 OR X_23 OR X_24;
出击:FILTER(X_25,2),COLORYELLOW,LINETHICK2;

相关文章