在线检测未来函数

同花顺MACD量能分析指标公式

来源:Internet,编辑:股旁网,2017-09-28

N1:=10;
N2:=10;
SHORT:=12;
LONG:=26;
M:=9;
N:=5;
量能饱和度:IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))>1,1,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20)))*100,coloryellow;
a:105,colorred;
b:70,colorgreen;
C:50,colorbluee;
N:=9;
TYP := (HIGH + LOW + CLOSE)/3;
RS:=SUM(IF(TYP>REF(TYP,1),TYP*VOL,0),N)/SUM(IF(TYP<=REF(TYP,1),TYP*VOL,0),N);
MFI:=100-100/(1+RS);
资金流量:MFI,NODRAW;
A1:=SUM(IF(MFI>REF(MFI,1),VOL,IF(MFI<REF(MFI,1),-VOL,0)),0);//{OBV}
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),0,MACD,1,0),color0000ff;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,1,0),colorffff00;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,1,0),colorff00ff;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,1,0),color00ff00;
DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA : EMA(DIFF,M);
MACD : 2*(DIFF-DEA);
Zero : 0;
IF(CODETYPE>0)
{
IF( CODETYPE>2 AND CODETYPE <> 6)
{
a="该指标只用于个股和沪深指数。";
换手:=a*100;
RETURN 0;
}
ELSE
{
a=VOL/SHGZG;
}
}
涨幅:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
换手率:=a;
N1天平均换手率:=MA(换手率,60);
N1天平均涨幅:=MA(涨幅,N1);
平均动能V:=N1天平均涨幅/N1天平均换手率;
当日动能V:=涨幅/换手率;
平均动能:平均动能V/100;
IF(涨幅<=0 OR CLOSE<=OPEN)
RETURN 0;
IF(当日动能V<=平均动能V)
RETURN 0;
IF(当日动能V>平均动能V*50)
{
DRAWICON(1,0,1);
爆表:0;
RETURN 0;
}
当日动能:当日动能V/100;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
阶段底部:=(AV + NEWVOL);
出击:CROSS(阶段底部,0);
DIF3:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA3:=EMA(DIF3,9);
MACD3 := 2*(DIF3-DEA3);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
止跌:MACD3>REF(MACD3,1) AND REF(MACD3,2)>=REF(MACD3,1) AND J<50 AND C>REF(C,1) AND C>O AND J>REF(J,1);
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
换手率:VOL/SHGZG*100;
N日换手率平滑:EMA(换手率 ,N)

同花顺MACD量能分析指标公式

 

相关文章